locked
Server 2012 hanging on "Please wait for Local Session Manager" RRS feed

  • Question

  • i have server 2012 running with Hyper V3. i have built a handful of server 2012 boxes, and al have been behaving themseles, unitl one of themrecently started taking ages to allow logon. it sits with the message "Please wait for the Local Session Manager" when RDP'ing to the machine, it times out, and wont allow you to logon. you can log into it using VMM, but you still get hit with a long wait at the "Please wait for the Local Session Manager", but you obviously dont get timed out.

    i have seen a similar issue on 2008, but the hotfix provided will not work on server 2012.

    does anybody have any ideas as to what might be causing this issue - there is nothing appearing in the event logs, i have run all Windows Updates up until the beginning of Dec 2013, and it was happening before then. it doesnt bother me, but obviously it bothers my client who doesnt connect via VMM, but uses RDP.

    any help would be most gratefully received

    thanks

    Chris

    Wednesday, March 5, 2014 5:16 PM

All replies

  • Hi Chris,

    Before going further, would you please let me know how much RAM was used in the server? Please monitor memory usage of lsm.exe.

    Meanwhile, would you please let me know how did users close a client session? Did log off or disconnect? Please configure disconnected sessions to be automatically logged off, then monitor this issue.

    If this issue still exists, please navigate to: Applications and Services Logs-> Microsoft-> Windows-> TerminalServices-LocalSessionManager and TerminalServices-RemoteConnectionManager. Please check again if find any clue.

    Hope this helps.

    Best regards,

    Justin Gu

    Friday, March 7, 2014 8:11 AM
  • Hi Justin

    Thanks for the reply; the servers have 16GB RAM and 8 CPUs. I shall monitor the lsm.ese, and check the logs but I won’t be able to do that for a couple of days as the servers are in transit. The problem is apparent even after the machine has been rebooted. Due to the nature of use of the servers, the users would disconnect their session so as to leave the applications running, but we don’t get the option of inputting a username or password, it hangs at the "please wait for the Local Session Manager" screen before eventually giving the screen to log on. It times out using RDP before being given this option, but using VMM you eventually get the user select screen.

    I shall report back once i can check the lsm.exe. If it does transpire to be the lsm.exe is there a fix for this?

    regards

    Chris

    Friday, March 7, 2014 9:02 AM
  • Hi Justin

    I have checked the LSM.exe, and it is sitting at about 3MB RAM usage, no fluctuation during a user trying to login.

    Having looked at the event logs for TerminalServices there are only Operational once for the LocalSessionManager, which talks of session logon succeeded, Shell start notification received, successful logoff and Plugin RDSAppXPlugin has been succesffully initialised.

    Under RemoteConnectionManager, again there doesnt seem to be any errors, messages referring to user authentication succeeded, TCP received a connection and RD Session Host Server role not being installed.

    I could look at rebuilding the machine, but i dont want to as i then wont know what to do if the problem comes back again. any suggestions are most welcome

    thanks

    Chris

    Monday, March 10, 2014 8:03 AM
  • Hi Chris,

    We're experiencing the exact same problem. It only accors on our Server 2012 R2 servers. I do have warnings in TerminalServices-RemoteConnectionManage with event id20499 Remote Desktop Services has taken too long to load the user configuration from server .....

    If you have the same message we got the same problem. Otherwise I start a new topic on mine.

    Regards,

    Rob

    Monday, March 10, 2014 10:41 AM
  • Hi Rob

    Sorry, no, we are not seeing any errors or warnings in the event logs, plus we are not running R2, just Standard 2012.

    Regards

    Chris

    Tuesday, March 11, 2014 3:05 AM
  • We are experiencing this issue as well.  Any suggestions?
    Tuesday, March 18, 2014 8:34 PM
  • I am also experiencing this after the system rebooted itself during a install of sqlserver service pack. I've been waiting now 2 hours and it is still sitting on the please wait screen.

    we have server 2012 r2.

    Karl

    Friday, March 28, 2014 9:47 PM
  • Hi there

    I had the same problem with 3 Windows 2012 R2 machines. They're behind a firewall and just as the port 49155 was opened for RPC-response in direction to the domaincontroller all works fine.

    At the moment i have opend a short range of rpc-ports around 49155 bidirectionaly.
    Most importand ports are 49152 - 49159 i think.

    see it @ WindowsServer 2008 und WindowsServer 2008 R2
    http://support.microsoft.com/kb/179442/de#method3<//a>

    let me know, if it works for you

    daniel

    Tuesday, April 15, 2014 6:36 AM
  • The same issue with Windows Server 2012. One curiosity, the same virtual Machine, in Hyper-V 2012 does not the problema. When I migrate to Hyper-V 2012 R2. The logon process slow.

    Wednesday, September 3, 2014 10:58 AM
  • Hi chris,

    have you found a solution for this problem? as I m having the same issue

    Friday, September 19, 2014 3:21 PM
  • Hi Chris, i have exactly the same issue, i have tried a lot of configurations and updates without resolving this problem. Have you resolved it? the last reply in this post was recently, please, if you have any update tell us. 

    Thanks!

    Atte.

    Cristian Diaz.

    Monday, September 22, 2014 2:35 PM
  • Hi

    no sorry i havent found a solution to the problem. fortuntaely for me as the server was on HyperV3, i was able to just kill it and start again, and the new machine hasnt exhibited any of those symptons.

    i too had tried all windows updates and hotfixes that i could find, along with trying everyything that was found in search engines to attempt to fx this no matter whether it applied to the S version or not, all to no avail.

    sorry

    Wednesday, September 24, 2014 8:16 AM
  • This isn't necessarily a "fix" but I've been having the same problem on a couple 2K12 servers and noticed that I can log in via RDP with the command mstsc /console. 

    Chris S.

    Tuesday, September 8, 2015 11:41 PM
  • hi Chris,

    I meet the same issue from real server :(, until now i don't know exactly what's problem.

    please kindly reply if you find out the way to resolve this error.

    Thank you.

    Tuesday, October 20, 2015 2:04 AM
  • From the looks of the issue, this exists since 2014 and there isnt any patch available. This leads to 2 assumptions

    a) There isn't a real problem which microsoft could fix it - unable to reproduce by Microsoft

    b) Microsoft is aware of the problem and working towards the fix - your question would be "why this long", i might not be best guy to answer this. 

    This issue involves several components in the communication 
    a) DNS 

    b) DC

    C) Network 

    as a test, can you guys test if the issue happens over safe mode with networking ?

    also unjoin / rejoin the machine from Domain to clear secure channel issue 

    NOte: Please perform the tests on "test PC"

    Tuesday, October 20, 2015 4:26 AM
  • Hi,

    I was stuck also with same issue and worked for me after deleting some of SID's of from registry.

    Regards  

    Tuesday, January 26, 2016 11:00 AM
  • Just to add a fix I found for this issue.

    In my case I found that a couple of our group policies that were applied to our domain users were using WMI filters to detect if the user's hardware was a workstation or a server. So the user logins were waiting a long time for the WMI test to run at each login. I disabled the WMI test on those group policies and all runs fine now. The first thing I would recommend to test for a group policy issue is create an OU with no group policies applied and then use a test account to see if the problem goes away. Then you can track down the offending policy.

    Thursday, June 16, 2016 8:47 PM
  • We had this issue with a local administrator account. So before checking your group policies, I would advice you to add a local account if you can still and test with that to eliminate possible group policy issues.

    Wednesday, March 1, 2017 9:01 AM
  • HI

    I too have this issue with a Windows 2012 R2 and a Windows 2016 Server.  We don't use AD its just local users and I can't login with Administrator account it just stays in waiting for local session manager then times out after 60 seconds.

    Sunday, May 14, 2017 9:48 PM
  • please check profiles in control panel- user accounts-configure advanced user profile

     in my case any domain profile is broken , delete this unknow profile 

    • Edited by besodake Tuesday, July 4, 2017 4:54 AM
    Tuesday, July 4, 2017 4:51 AM