Sharepoint SP2 Configuration Wizzard Error (failed to start MSSQL$OfficeServers) after applying WSS & MOSS SP2 Language Pack


  • Hi, 

    I can't run the configuration wizzard anymore.
    Have you experienced also the same issue after deploying this week service packs  (SP2)?

    I tried to repair in add/remove programs but it didn't help.

    ERR                        Failed to start the database service MSSQL$OfficeServers
    ERR                        Une exception de type System.InvalidOperationException a été générée. Informations complémentaires sur l'exception : Le service MSSQL$OfficeServers est introuvable sur l'ordinateur '.'.
    System.InvalidOperationException: Le service MSSQL$OfficeServers est introuvable sur l'ordinateur '.'. ---> System.ComponentModel.Win32Exception: Le service spécifié n'existe pas en tant que service installé
       --- Fin de la trace de la pile d'exception interne ---
       à System.ServiceProcess.ServiceController.GenerateNames()
       à System.ServiceProcess.ServiceController.get_ServiceName()
       à System.ServiceProcess.ServiceController.GenerateStatus()
       à System.ServiceProcess.ServiceController.get_Status()
       à Microsoft.SharePoint.PostSetupConfiguration.ServiceHelper.Start(String serviceName)
       à Microsoft.SharePoint.PostSetupConfiguration.ConfigurationDatabaseTask.DefaultDatbaseServer()

    I checked the installed components afterwards, the sharepoint admin console is in version where the SharePoint Team Services is running in version

    I tried to re-apply the services packs, but the setup wizzard states that the installed components are up to date. 


    Friday, May 01, 2009 12:59 PM


  • Solved !

    I initiated a comparaison between a confing wizzard log that succeeded and the one that failed.

    For some unknown reason some registry keys where changed or simply removed
    I changed or Added the following registry keys to
    HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Shared Tools\Web Server Extensions\12.0\WSS

    added string key  SetupType Run psconfig to run upgrade and setted to SKU2SKU_UPGRADE
    changed SetupType string key from CLEAN_INSTALL to B2B_UPGRADE

    I hope that will help others.

    However the HTTP Header of sites created before applying SP2 are still

    If I add a new application the HTTP Header is



    • Marked as answer by Dejan MILIC Friday, May 01, 2009 8:00 PM
    Friday, May 01, 2009 8:00 PM