none
Powerpivot on Sharepoint: GetSnapshot.exe erroring out... (red x on the thumbnail)

    Question

  • I see that the GetSnapshot.exe is running (in the task manager) when I upload a new powerpivot file or update an existing file. It runs for about 10 seconds and goes away.

    Here is the error message I am seeing in the ULS log...

    06/20/2012 11:21:39.48  GetSnapshot.exe (0x12A8)         0x14F0  PowerPivot Service         Report Gallery   0000       High       An error occurred: 'Terminating capture process: 'Illegal redirection to resources outside of the web application: 'res://ieframe.dll/navcancl.htm'''.         

    What could be the cause of this error? Please help!!

    Wednesday, June 20, 2012 6:52 PM

Answers

  • Hi there,

    Take a look at this KB item:

    http://support.microsoft.com/kb/2361559

    Work through the solutions in the document and if they do not resolve your issue, you will need to open up a paid support ticket with Microsoft so that we can take a deeper look at the issue.

    Gregg


    MSFT

    Wednesday, June 27, 2012 3:28 PM
    Moderator
  • Thanks Gregg! The issue is actually resolved now!! There was a group policy setting in the domain controller that overrode privacy and security settings & restricted access to the farm admin of the SharePoint server to the database server. Once that was removed, the getsnapshot.exe started working!



    Siva

    • Marked as answer by siviki_LA Wednesday, June 27, 2012 5:10 PM
    Wednesday, June 27, 2012 5:10 PM

All replies

  • Hi there,

    Take a look at this KB item:

    http://support.microsoft.com/kb/2361559

    Work through the solutions in the document and if they do not resolve your issue, you will need to open up a paid support ticket with Microsoft so that we can take a deeper look at the issue.

    Gregg


    MSFT

    Wednesday, June 27, 2012 3:28 PM
    Moderator
  • Thanks Gregg! The issue is actually resolved now!! There was a group policy setting in the domain controller that overrode privacy and security settings & restricted access to the farm admin of the SharePoint server to the database server. Once that was removed, the getsnapshot.exe started working!



    Siva

    • Marked as answer by siviki_LA Wednesday, June 27, 2012 5:10 PM
    Wednesday, June 27, 2012 5:10 PM
  • We are experiencing the same "Red X" issue in our production farm.  We first created the farm by copying the content database from a lab machine that was working correctly, and which was generating thumbnails .  The lab is a single server SharePoint 2010 environment.  The resulting site in production worked fine as is.  Then we needed to make updates to the production galleries , so we uploaded workbooks directly to thosse galleris (we couldn't continue copying the content database over).  The result?  Red Xs appear on all the thumbnails of workbooks we uploaded.  I worked through all the suggestions in the http://support.microsoft.com/kb/2361559 document but we still have the issue. 

    Here is what I checked:

    1. Excel services is rendering workbooks.

    2. Internet Explorer 9 is not installed.

    3. We already installed Sql 2008 R2 SP1 for PowerPivot for SharePoint.

    4. I was able to test to see that getsnapshot.exe is being spawned (by checking task manager): 

    5.  We tried running GetSnapshot.exe manually.

    6.  The workbook contains embedded PowerPivot data, and is generating thumbnails correctly in our single server lab environment.  (Note that in production is that this is a web frint end and SQL back end.)

    7.  The workbook does not contain more than one data source.

    8. The file is an .xlsx file. 

    9. Alternate Access Mappings are setup correctly.

    10. We added the PowerPivot site to the trusted intranet sites for the account running Getsnapshot.exe

    11. We disabled loopback check.  

    12. We do not have the check box checked off for "refresh on open" in the workbook connection properties

    13. We set Advanced Settings for the Document library(PowerPivot Gallery), opening documents in the browser setting to "Default-Open in Browser".

    One question for siviki_LA: Can you share any more specifics about what kind of group policy change was made to solve your issue?



    Thursday, September 6, 2012 10:33 PM