none
Cannot upgrade Windows 7 to Windows 7 SP1 RRS feed

  • Question

  • I am trying to upgrade windows 7 to SP1 using windows6.1-KB976932-X64.exe d and it does not complete successfully.

    I tried installing System readiness tool which resulted in no errors.

    below is the CBS.log 

    2015-03-11 11:36:05, Info                  CSI    00000204 Manifest hash for component [ml:280{140},l:200{100}]"amd64_microsoft-windows-l..se-eval-enterprisee_31bf3856ad364e35_6.1.7600.16385_none_3e65560ca3c6db98" does not match expected value. 
     Expected:{l:32 b:dba5fa4fee0ea6a1a3e4d1d53a3b990d301c563e4c0da8e38037e3b235fbafe2}
     Found:{l:32 b:dba5fa4fee0ea6a1a3e4d1d53a3b990d301c563a4c0da8e38037e3b235fbafe2}.
    2015-03-11 11:36:05, Info                  CSI    00000205 Looking for manifest in Backup Dir...
    2015-03-11 11:36:05, Error                 CSI    00000206 (F) Unable to load manifest for component [ml:280{140},l:200{100}]"amd64_microsoft-windows-l..se-eval-enterprisee_31bf3856ad364e35_6.1.7600.16385_none_3e65560ca3c6db98"[gle=0x80004005]
    2015-03-11 11:36:05, Error                 CSI    00000207@2015/3/11:06:06:05.469 (F) d:\win7sp1_gdr\base\wcp\componentstore\storelayout.cpp(2714): Store corruption detected in function ComponentStore::CRawStoreLayout::FetchManifestContent expression: 0
      FileHashMismatch on resource [127]"\winsxs\manifests\amd64_microsoft-windows-l..se-eval-enterprisee_31bf3856ad364e35_6.1.7600.16385_none_3e65560ca3c6db98.manifest"[gle=0x80004005]
    2015-03-11 11:36:08, Error                 CSI    00000208 (F) HRESULT_FROM_WIN32(14098) #677133# from Windows::ServicingAPI::CCSITransaction::ICSITransaction_EnumMissingComponents(Flags = 0, ppe = NULL, disp = 0)[gle=0x80073712]
    2015-03-11 11:36:08, Error                 CSI    00000209 (F) HRESULT_FROM_WIN32(14098) #677132# from Windows::ServicingAPI::CCSITransaction_ICSITransaction::EnumMissingComponents(flags = 0, enum = NULL, disp= 0)
    [gle=0x80073712]
    2015-03-11 11:36:08, Info                  CBS    Failed to get enumerator for missing components. [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
    2015-03-11 11:36:08, Error                 CBS    Failed to complete component closure [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
    2015-03-11 11:36:08, Info                  CSI    0000020a@2015/3/11:06:06:08.593 CSI Transaction @0x4c65f60 destroyed
    2015-03-11 11:36:08, Info                  CBS    Perf: Resolve chain complete.
    2015-03-11 11:36:08, Info                  CBS    Failed to resolve execution chain. [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
    2015-03-11 11:36:08, Error                 CBS    Failed to process Multi-phase execution. [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
    2015-03-11 11:36:08, Info                  CBS    WER: Generating failure report for package: Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17514, status: 0x80073712, failure source: Resolve, start state: Absent, target state: Staged, client id: SP Coordinater Engine
    2015-03-11 11:36:08, Info                  CBS    Failed to query DisableWerReporting flag.  Assuming not set... [HRESULT = 0x80070002 - ERROR_FILE_NOT_FOUND]
    2015-03-11 11:36:08, Info                  CBS    Failed to add %windir%\winsxs\pending.xml to WER report because it is missing.  Continuing without it...
    2015-03-11 11:36:08, Info                  CBS    Failed to add %windir%\winsxs\pending.xml.bad to WER report because it is missing.  Continuing without it...
    2015-03-11 11:36:10, Info                  CBS    Reboot mark refs: 0
    2015-03-11 11:36:10, Info                  CBS    SQM: Reporting package change for package: Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17514, current: Absent, pending: Default, start: Absent, applicable: Installed, target: Staged, limit: Staged, hotpatch status: StillGoing, status: 0x0, failure source: Resolve, reboot required: False, client id: SP Coordinater Engine, initiated offline: False, execution sequence: 484, first merged sequence: 484
    2015-03-11 11:36:12, Info                  CBS    SQM: Upload requested for report: PackageChangeBegin_Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17514, session id: 101457923, sample type: Standard
    2015-03-11 11:36:12, Info                  CBS    SQM: Ignoring upload request because the sample type is not enabled: Standard
    2015-03-11 11:36:12, Info                  CBS    SQM: Reporting package change completion for package: Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17514, current: Absent, original: Absent, target: Staged, status: 0x80073712, failure source: Resolve, failure details: "(null)", client id: SP Coordinater Engine, initiated offline: False, execution sequence: 484, first merged sequence: 484
    2015-03-11 11:36:12, Info                  CBS    SQM: resolve time performance datapoint is invalid. [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
    2015-03-11 11:36:12, Info                  CBS    SQM: stage time performance datapoint is invalid. [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
    2015-03-11 11:36:12, Info                  CBS    SQM: execute time performance datapoint is invalid. [HRESULT = 0x80070490 - ERROR_NOT_FOUND]
    2015-03-11 11:36:12, Info                  CBS    SQM: Upload requested for report: PackageChangeEnd_Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17514, session id: 101457924, sample type: Standard
    2015-03-11 11:36:12, Info                  CBS    SQM: Ignoring upload request because the sample type is not enabled: Standard
    2015-03-11 11:36:13, Info                  CBS    Enabling LKG boot option
    2015-03-11 11:36:13, Info                  CBS    Restored system sleep block state: 0x80000000
    2015-03-11 11:36:13, Info                  CBS    SPI: Error callback - 0x80073712
    2015-03-11 11:36:13, Info                  CBS    Exec: Processing complete.  Session: 30432189_3805838705, Package: Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17514 [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
    2015-03-11 11:36:14, Error                 CBS    Failed to perform operation.  [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
    2015-03-11 11:36:14, Info                  CBS    Session: 30432189_3805838705 finalized. Reboot required: no [HRESULT = 0x80073712 - ERROR_SXS_COMPONENT_STORE_CORRUPT]
    2015-03-11 11:36:14, Error                 CBS    SPI: (CSPICbsClient::Finalize:737)Failed to finalize session hr=0x80073712
    2015-03-11 11:36:14, Error                 CBS    SPI: (CSPICbsClient::ChangeState:519)Failed to finalize CBS session to install package hr=0x80073712
    2015-03-11 11:36:14, Error                 CBS    SPI: (CSPCInstallTask::Execute:1010)Failed to install package with identity Package_for_KB976932~31bf3856ad364e35~amd64~~6.1.1.17514 hr=0x80073712
    2015-03-11 11:36:14, Info                  CBS    SPI: Reporting Failed package event
    2015-03-11 11:36:14, Error                 CBS    Cannot finalize a session that has been finalized. [HRESULT = 0x800f0842 - CBS_E_SESSION_FINALIZED]
    2015-03-11 11:36:14, Info                  CBS    Session: 30432189_3805838705 finalized. Reboot required: no [HRESULT = 0x800f0842 - CBS_E_SESSION_FINALIZED]
    2015-03-11 11:36:14, Error                 CBS    SPI: (CSPICbsClient::Finalize:737)Failed to finalize session hr=0x800f0842
    2015-03-11 11:42:22, Info                  CBS    SPI: Deleting directory: C:\623188cebe792da8065834\5bac74d7c7ab07ba8a7d4796\4039cda3b9179ac034.  ret=0
    2015-03-11 11:42:22, Error                 CBS    SPI: (CSPInstall::Install:1583)Failed executing Install task hr=0x80073712
    2015-03-11 11:42:22, Info                  CBS    SPI: Ending SP Installation
    2015-03-11 11:42:22, Error                 CBS    SPI: (PerformSPInstallation:833)Failed to install SP using UI hr=0x80073712
    2015-03-11 11:42:22, Error                 CBS    SPI: (wmain:1105)Failed to perform SP installation hr=0x80073712
    2015-03-11 11:42:22, Info                  CBS    SPI: Reporting Failed event
    2015-03-11 11:52:22, Info                  CBS    Reboot mark refs incremented to: 1
    2015-03-11 11:52:22, Info                  CBS    Scavenge: Starts
    2015-03-11 11:52:22, Info                  CSI    0000020b@2015/3/11:06:22:22.995 CSI Transaction @0x4c65b40 initialized for deployment engine {d16d444c-56d8-11d5-882d-0080c847b195} with flags 00000002 and client id [10]"TI6.0_0:0/"

    2015-03-11 11:52:22, Info                  CBS    Scavenge: Begin CSI Store
    2015-03-11 11:52:23, Info                  CSI    0000020c Performing 1 operations; 1 are not lock/unlock and follow:
      Scavenge (8): flags: 00000017
    2015-03-11 11:52:28, Info                  CSI    0000020d Creating NT transaction (seq 2), objectname [6]"(null)"
    2015-03-11 11:52:28, Info                  CSI    0000020e Created NT transaction (seq 2) result 0x00000000, handle @0x3e8


    Wednesday, March 11, 2015 9:15 AM

Answers

  • Got it working. 

    Details are as below. 

    1. If you see the logs above the found and expected hash value of the manifest is different by just one alphabet 

    Expected : dba5fa4fee0ea6a1a3e4d1d53a3b990d301c563<mark>e</mark>4c0da8e38037e3b235fbafe2

    Found :     dba5fa4fee0ea6a1a3e4d1d53a3b990d301c563<mark>a</mark>4c0da8e38037e3b235fbafe2


    2. I compared it with the hash of same file on other system and saw that it is was equal to the Found value

    3. I figured out that there is nothing wrong in the component but the expected value.

    4. The components in the winsxs folder were correct. but the sfc /scannow now was still giving issues as it was false comparing the hash.

    5. I found the expected hash in the components registry under HKLM and changes it to the found value i.e. changes only that one alphabet.

    I was able to update to SP1 with any further issues.

    Thanks for all your help.

    • Marked as answer by PratikVParab Friday, March 20, 2015 4:45 AM
    Friday, March 20, 2015 4:45 AM

All replies

  • There are errors in CBS log.

    Try this before installing SP1:

    • Open an elevated command prompt.
    • Run the "sfc /scannow" command.
    • Try to install update again.

    S.Sengupta, Windows Entertainment and Connected Home MVP

    Wednesday, March 11, 2015 12:43 PM
  • Hi PratikVParab,

    Based on your CBS log, there are errors about your system and components store corruption.

    Have you made any change to %windir%\system\Winsxs folder?

    As what has been suggested by S.sengupta try fix your system corruption first.

    I am supposing your service pack has been already applied to your system. Windows components store corruption won’t affect system running, but when you try to repair system by using Winsxs folder, error might occurs.

    Regards

    D. Wu

    Monday, March 16, 2015 2:28 AM
    Moderator
  • Hi,

    Some antivirus software might prevent SP1 from installing, or might slow down the installation. You can try temporarily disabling your antivirus software. If you do so, be sure that you're aware of the risks involved, and be sure to re-enable it after the service pack is installed. Good luck

    Regards

    Biswajeet

    Monday, March 16, 2015 2:34 AM
  • Got it working. 

    Details are as below. 

    1. If you see the logs above the found and expected hash value of the manifest is different by just one alphabet 

    Expected : dba5fa4fee0ea6a1a3e4d1d53a3b990d301c563<mark>e</mark>4c0da8e38037e3b235fbafe2

    Found :     dba5fa4fee0ea6a1a3e4d1d53a3b990d301c563<mark>a</mark>4c0da8e38037e3b235fbafe2


    2. I compared it with the hash of same file on other system and saw that it is was equal to the Found value

    3. I figured out that there is nothing wrong in the component but the expected value.

    4. The components in the winsxs folder were correct. but the sfc /scannow now was still giving issues as it was false comparing the hash.

    5. I found the expected hash in the components registry under HKLM and changes it to the found value i.e. changes only that one alphabet.

    I was able to update to SP1 with any further issues.

    Thanks for all your help.

    • Marked as answer by PratikVParab Friday, March 20, 2015 4:45 AM
    Friday, March 20, 2015 4:45 AM
  • Hi pratikVparab,

    Thanks for sharing.

    Regards

    D. Wu


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, March 20, 2015 4:53 AM
    Moderator