none
Fresh Enterprise 1809 kiosks are prompted to change homepage to MSN.com and search to Bing in IE11 RRS feed

Answers

  • I think I might have figured this out. I did some investigation with Sysinternals Process Monitor and noticed that IE was looking for and not finding this registry key

    FEATURE_DEFAULTS_FRE_GLOBAL_FORCE_DISABLE

    in HKCU\Software\Microsoft\Internet Explorer\Main\FeatureControl

    Since it has FRE in the name, I thought it might be associated with the IE11DefaultsFRE... properties in the Main key. I did some testing and it appears that if you create that key, and then under that you create the following property

    Name: iexplore.exe

    Type: REG_DWORD

    Value: 1

    It will prevent the recommended settings page from launching entirely. It even prevents the other FRE related properties from being created at all. It also works if you create it at the machine level in the corresponding HKLM location. I'm not sure if it causes any other side effects, so make sure to test it out before blasting it out to production.



    https://ccmcache.wordpress.com/ | @kevmjohnston

    Friday, August 2, 2019 10:16 PM

All replies

  • I think I might have figured this out. I did some investigation with Sysinternals Process Monitor and noticed that IE was looking for and not finding this registry key

    FEATURE_DEFAULTS_FRE_GLOBAL_FORCE_DISABLE

    in HKCU\Software\Microsoft\Internet Explorer\Main\FeatureControl

    Since it has FRE in the name, I thought it might be associated with the IE11DefaultsFRE... properties in the Main key. I did some testing and it appears that if you create that key, and then under that you create the following property

    Name: iexplore.exe

    Type: REG_DWORD

    Value: 1

    It will prevent the recommended settings page from launching entirely. It even prevents the other FRE related properties from being created at all. It also works if you create it at the machine level in the corresponding HKLM location. I'm not sure if it causes any other side effects, so make sure to test it out before blasting it out to production.



    https://ccmcache.wordpress.com/ | @kevmjohnston

    Friday, August 2, 2019 10:16 PM
  • Update:

    I was only seeing this issue on Windows 7, but yesterday I updated my Windows 10 1809 reference image with the latest cumulative update, and I'm now seeing it there as well. Prior to that, I was not able to reproduce the issue in Windows 10. Perhaps they tweaked the logic used to determine whether or not to present the FRE (First Run Experience) page. For example, if it detects that you are using group policies (or their registry equivalents) then it does not present the page, or it only presents one or two of the three options if it detects the others are set via policy. I'm using the IEAK to set IE11 defaults in a non-enforced way so I'm not sure how it handles that. It sure would be nice if there were some public documentation about this process...but as far as I can tell, I'm the first person on the internet to mention FEATURE_DEFAULTS_FRE_GLOBAL_FORCE_DISABLE ...

    In any case, my solution above works just as well to disable the FRE related actions whether on Windows 7 or 10.


    https://ccmcache.wordpress.com/ | @kevmjohnston

    Wednesday, August 14, 2019 1:55 PM
  • Thank you for your contribution.

    We have noticed the same situation on our computers running Windows 10 1809 Enterprise since yesterday. We also expect the URL to be https://ie11welcome.microsoft.com/v2/en-us/index.html since the August 2019 cumulative update.

    Can I reproduce the situation in a forced manner? I would like to check if the URL call is blocked via the Reg Key HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Internet Explorer\Main\FeatureControl\FEATURE_DEFAULTS_FRE_GLOBAL_FORCE_DISABLE.



    Martin Schneeberger

    Thursday, August 15, 2019 5:35 AM
  • If you delete the IE11DefaultsFRE... properties out of the registry in HKEY_CURRENT_USER\SOFTWARE\Microsoft\Internet Explorer\Main then that should force the settings page to open again the second time you open IE afterwards.

    https://ccmcache.wordpress.com/ | @kevmjohnston

    Thursday, August 15, 2019 6:06 AM
  • It works! Thanks

    Martin Schneeberger

    Thursday, August 15, 2019 6:52 AM
  • This is what I am seeing in Fiddler (an HTTP protocol sniffer) when I launch a new instance of IE 11 KB4507434:

    [Fiddler] The connection to 'ie11welcome.microsoft.com' failed. <br />Error: TimedOut (0x274c). <br />System.Net.Sockets.SocketException A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond 104.214.77.221:443                                                                                                                                                                             

    When I launch a new instance of IE11, the first HTTP request it makes is to connect with ie11welcome.microsoft.com.  IE11 then waits about 20 seconds until it timesout then continues with loading the home page (google.com in my case).  This connection attempt results in an HTTP error 502 (Bad Gateway) from the ie11welcome.microsoft.com server.  I'm not sure if this is the fault of my IE11 browser or the ie11welcome.microsoft.com server.  Maybe someone from Microsoft could check their ie11welcome.microsoft.com server and see if it is operating correctly?

    Kevin, when I added the registry key that you suggested my IE11 stopped requesting a connection to ie11welcome.microsoft.com and my IE11 loaded quickly as it has in the past.  Thanks for your help with this issue!


    Friday, August 16, 2019 7:23 PM
  • And just to clarify, whether you're adding this setting to your install media/reference image so it's pre-fixed on new systems or you're pushing it out to remediate existing systems via something like a Group Policy Preference or a ConfigMgr Compliance Setting, it's easier/better to put it in the HKLM location.

    https://ccmcache.wordpress.com/ | @kevmjohnston


    Friday, August 16, 2019 8:48 PM
  • Yes, you are right. Currently I set the registry entry with a ConfigMgr Compliance Setting in the HKLM location. In the next installation medium we will integrate your entry immediately.

    Martin Schneeberger

    Saturday, August 17, 2019 6:16 AM