none
Surface Hub Wifi doesnt re connect after powerdown

    Question

  • Hi

    We can connect to our corp wifi fine, which use's user domain authentication. The problem is when the device is powered off(restarted), the wifi doesn't automatically connect, we have to go into the wifi settings and hit connect, we don't have to re-enter any creds. This is very annoying as are users don't have access to do this. is there a solution?

    thanks

    Dave 

    Tuesday, January 02, 2018 11:51 PM

All replies

  • Kindly go through the following steps to fix the problem:

    Click on the WiFi icon in the taskbar.

    Click on Network Settings

    Under the Wireless Network Connection section, choose Manage Wi-Fi Settings. Then from under Manage Known Networks, Click the name of your wireless network and choose Forget.

    Restart your computer. Click on the WiFi icon in the taskbar and click on your WiFi network from the list of available networks.

    Make sure that you check the Connect automatically. Click on Connect.

    ==============

    Open  Device manager.Double click on the Network adapters section to expand it.

    Select WiFi adapter and then right click on it. From the right click menu, click on Properties.In the dialog that appears, click on the Power management tab to navigate to it.

    Uncheck the Allow this computer to turn off this device to save power. Click on OK.



    S.Sengupta,Microsoft MVP Windows and Devices for IT, Windows Insider MVP




    Wednesday, January 03, 2018 12:48 AM
  • We can connect to our corp wifi fine, which use's user domain authentication. The problem is when the device is powered off(restarted), the wifi doesn't automatically connect, we have to go into the wifi settings and hit connect, we don't have to re-enter any creds. This is very annoying as are users don't have access to do this. is there a solution?

    did you implement/configure/apply, by using the XML profile for EAPUserData ?

    https://docs.microsoft.com/en-us/surface-hub/enable-8021x-wired-authentication


    Don [doesn't work for MSFT, and they're probably glad about that ;]

    Wednesday, January 03, 2018 4:17 AM
  • Hi,

    We could refer to link Fix: Windows 10 will not connect to WIFI Automatically to troubleshoot the issue.

    NOTE: This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you. Microsoft does not control these sites and has not tested any software or information found on these sites.

    Bests,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, January 03, 2018 9:59 AM
    Moderator
  • I tried the forget network and connect automatically but it doesn't help. also remember this is a hub so there's no such thing as device manager 
    Thursday, January 04, 2018 12:45 AM
  • Hi

    Ive tried both xml profile and just connecting the normal way

    Thursday, January 04, 2018 12:46 AM
  • Hi,

    "so there's no such thing as device manager" 

    If you can't find "Allow this computer to turn off this device to save power" option in Device Manager, please try to find it by the following measure.

    Open Registry and navigate to the following link:

    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Class\{4D36E972-E325-11CE-BFC1-08002bE10318}\DeviceNumber

    Change "PnPCapabilities" value to 24

    Note: DeviceNumber is the network adapter number. If a single network adapter is installed on the computer, the DeviceNumber is 0001.

    By default, a value of 0 indicates that power management of the network adapter is enabled. A value of 24 will prevent Windows from turning off the network adapter or let the network adapter wake the computer from standby.

    Bests,


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Thursday, January 04, 2018 10:02 AM
    Moderator