locked
Composed looks / Change the look themes are missing when creating site from saved template RRS feed

  • Question

  • Hi,

    I found an issue when save you own site template and then want to create a new site from that template the "Change the Look" themes are missing and if you go to site settings, Comosed looks where the themes are stored is empty! Anyone else has the same experience? Any workaround for this?

    regards

    Martin

    Wednesday, March 13, 2013 6:13 AM

Answers

  • OK, I've worked out a fix for the problem of the Composed Looks not appearing in the Change the look wizard pages.

    The cause appears to be malformed URLs in the paths to each of the files that make up a Composed Look. In one example on our farm, the Theme URL in a working site is a site collection relative path in this form: /_catalogs/theme/15/Palette032.spcolor.

    But in a non-working site, the URL has had the sub-site name appended to the front of the URL, e.g. /somesitename/_catalogs/theme/15/Palette032.spcolor which isn't valid as there is no Theme Gallery at that URL (The Theme gallery is in the root site of the Site Collection).

    And, it seems that if one or more of these URLs are invalid, then that Composed Look isn't displayed in the Change the Look wizard page (which is fair enough - broken links equals a broken theme and who would want that).

    The fix is simple but tedious, in addition to fixing the broken default view WebPart in the Composed Looks list, you will also need to edit the following URL fields for each Composed Look in the list and shorten them back to clean Site Collection relative links if they are messed up:-

    Theme URL

    Image URL

    Font Scheme URL

    Note that I didn't include the Master Page URL in that list. It is supposed to have the site name appended to the front of the URL as SharePoint creates a Master pages library at that URL and populates it with the necessary files.

    Note that I am unable to create an e-mail alert to this post so I won't know if anyone replies with a question but I'll try to check in on it over the next few days or so.

    Regards,

    Glenn.






    • Edited by Glenn Laugesen Monday, April 1, 2013 1:05 AM
    • Proposed as answer by ezadler Saturday, April 6, 2013 9:20 PM
    • Unproposed as answer by ezadler Saturday, April 6, 2013 9:20 PM
    • Marked as answer by Qiao Wei Sunday, April 7, 2013 7:21 AM
    Sunday, March 31, 2013 1:18 AM
  • I've just seen this exact problem on a SharePoint 2013 farm as well this morning, but have managed to fix the blank "Composed Looks" list issue, although am still working on the "Change the look" wizard pages. Edit: found a fix for this too now. See my next post below.

    It appears that the process of saving a site as a template and then creating a new site from that template causes the original XsltListViewWebPart used to display the default view of the "Composed Looks" list, to be replaced with a ListViewWebPart, which appears to be broken.

    Edit: have also seen this behaviour on sites created from the built-in templates but haven't determined exactly whether this is a bug. ULS logs never show any errors when this occurs so it appears to be "by-design". Ugh.

    There may be a tidier way to fix this, but for now, I used SharePoint Designer 2013 to copy an XsltListViewWebPart from a working "Composed Looks" list, AllItems.aspx page and replaced the ListViewWebPart in the broken Composed Looks list, AllItems.aspx page with it. There is also some additional post copy-paste tidy up to do on the pasted-in XsltListViewWebPart HTML to get it to work within the context of the site it is now in as it will contain GUIDs and URLs that are only relevant within the site that you copied it from and these need to be replaced with the GUIDs/URLs from the replaced ListViewWebPart - paste it in a notepad session before deleting/overwriting it so you can grab those bits.

    I'll write a more detailed step-by-step if anyone wants it, but this doesn't seem to fix the broken "Change the Look" wizard still, only the "Composed Looks" list default view. I'll look into that now and post back more complete solution if I can find a fix.

    Edit: Found a fix. see my next post below.

    Edit Edit: One more thing - on some Composed Looks lists we are seeing empty lists once the default view webPart is fixed up. To correct this, you can copy selected Composed Looks from a working site with a full set.

    Before you do that, edit the default view in both the source and destination Composed Looks lists and include the Title field as it is a required field.

    Then, you can use Datasheet View (just click the edit list link to put it in Datasheet View mode) to bulk copy/paste Composed Looks between the source and destination lists.

    Do a little post-paste tidy up on the URLs as above to make sure that they are correct for their new location and then click on over to your Change the Look wizard.

    You should see all of your Composed Looks displayed nicely on the page.

    Note that the Current Look might not represent the sites actual appearance as it's settings will reflect the source sites appearance, but you can tweak it with the Wizard now.

    Regards,

    Glenn

    • Edited by Glenn Laugesen Monday, April 1, 2013 1:14 AM
    • Marked as answer by Qiao Wei Sunday, April 7, 2013 7:21 AM
    Saturday, March 30, 2013 11:32 PM

All replies

  • Anyone has an idea about this, really need help!

    Friday, March 15, 2013 7:20 AM
  • Could you provide some more information on how to recreate this?  What template are you starting from and what is the process you are going through for saving the site? 

    John Ross
    SharePoint Server MVP | Sr. Consultant Rackspace: SharePoint Consulting
    Blog: http://johnrossjr.wordpress.com
    Twitter: @JohnRossJr

    SharePoint 2013 Branding and User Interface Design
    Professional SharePoint 2010 Branding and User Interface Design (Wrox Programmer to Programmer)

    Friday, March 15, 2013 12:48 PM
  • Hi John,

    Well it is very simple to create, anyway on our farm, and thanks for you interest..

    1. Create a Site (A) with default "Team Site"

    2. On the new created site (A), go to site settings and save site as template

    3. Create new Site (B)  with the template just created

    4. go to settings and try "Change Look" on the new created site (B).

    Please let me know if you need more information

    regards

    Martin

    Friday, March 15, 2013 12:54 PM
  • I have the same problem.
    If I can contribute any additional information, please let me know.

    Hi John,

    Well it is very simple to create, anyway on our farm, and thanks for you interest..

    1. Create a Site (A) with default "Team Site"

    2. On the new created site (A), go to site settings and save site as template

    3. Create new Site (B)  with the template just created

    4. go to settings and try "Change Look" on the new created site (B).

    Please let me know if you need more information

    regards

    Martin


    Friday, March 22, 2013 10:38 AM
  • I've just seen this exact problem on a SharePoint 2013 farm as well this morning, but have managed to fix the blank "Composed Looks" list issue, although am still working on the "Change the look" wizard pages. Edit: found a fix for this too now. See my next post below.

    It appears that the process of saving a site as a template and then creating a new site from that template causes the original XsltListViewWebPart used to display the default view of the "Composed Looks" list, to be replaced with a ListViewWebPart, which appears to be broken.

    Edit: have also seen this behaviour on sites created from the built-in templates but haven't determined exactly whether this is a bug. ULS logs never show any errors when this occurs so it appears to be "by-design". Ugh.

    There may be a tidier way to fix this, but for now, I used SharePoint Designer 2013 to copy an XsltListViewWebPart from a working "Composed Looks" list, AllItems.aspx page and replaced the ListViewWebPart in the broken Composed Looks list, AllItems.aspx page with it. There is also some additional post copy-paste tidy up to do on the pasted-in XsltListViewWebPart HTML to get it to work within the context of the site it is now in as it will contain GUIDs and URLs that are only relevant within the site that you copied it from and these need to be replaced with the GUIDs/URLs from the replaced ListViewWebPart - paste it in a notepad session before deleting/overwriting it so you can grab those bits.

    I'll write a more detailed step-by-step if anyone wants it, but this doesn't seem to fix the broken "Change the Look" wizard still, only the "Composed Looks" list default view. I'll look into that now and post back more complete solution if I can find a fix.

    Edit: Found a fix. see my next post below.

    Edit Edit: One more thing - on some Composed Looks lists we are seeing empty lists once the default view webPart is fixed up. To correct this, you can copy selected Composed Looks from a working site with a full set.

    Before you do that, edit the default view in both the source and destination Composed Looks lists and include the Title field as it is a required field.

    Then, you can use Datasheet View (just click the edit list link to put it in Datasheet View mode) to bulk copy/paste Composed Looks between the source and destination lists.

    Do a little post-paste tidy up on the URLs as above to make sure that they are correct for their new location and then click on over to your Change the Look wizard.

    You should see all of your Composed Looks displayed nicely on the page.

    Note that the Current Look might not represent the sites actual appearance as it's settings will reflect the source sites appearance, but you can tweak it with the Wizard now.

    Regards,

    Glenn

    • Edited by Glenn Laugesen Monday, April 1, 2013 1:14 AM
    • Marked as answer by Qiao Wei Sunday, April 7, 2013 7:21 AM
    Saturday, March 30, 2013 11:32 PM
  • OK, I've worked out a fix for the problem of the Composed Looks not appearing in the Change the look wizard pages.

    The cause appears to be malformed URLs in the paths to each of the files that make up a Composed Look. In one example on our farm, the Theme URL in a working site is a site collection relative path in this form: /_catalogs/theme/15/Palette032.spcolor.

    But in a non-working site, the URL has had the sub-site name appended to the front of the URL, e.g. /somesitename/_catalogs/theme/15/Palette032.spcolor which isn't valid as there is no Theme Gallery at that URL (The Theme gallery is in the root site of the Site Collection).

    And, it seems that if one or more of these URLs are invalid, then that Composed Look isn't displayed in the Change the Look wizard page (which is fair enough - broken links equals a broken theme and who would want that).

    The fix is simple but tedious, in addition to fixing the broken default view WebPart in the Composed Looks list, you will also need to edit the following URL fields for each Composed Look in the list and shorten them back to clean Site Collection relative links if they are messed up:-

    Theme URL

    Image URL

    Font Scheme URL

    Note that I didn't include the Master Page URL in that list. It is supposed to have the site name appended to the front of the URL as SharePoint creates a Master pages library at that URL and populates it with the necessary files.

    Note that I am unable to create an e-mail alert to this post so I won't know if anyone replies with a question but I'll try to check in on it over the next few days or so.

    Regards,

    Glenn.






    • Edited by Glenn Laugesen Monday, April 1, 2013 1:05 AM
    • Proposed as answer by ezadler Saturday, April 6, 2013 9:20 PM
    • Unproposed as answer by ezadler Saturday, April 6, 2013 9:20 PM
    • Marked as answer by Qiao Wei Sunday, April 7, 2013 7:21 AM
    Sunday, March 31, 2013 1:18 AM
  • Open the elements.xml inside the listinstances folder within the wsp

    and change the entries like below replace fqdns with ~Sitecollection/

    Repackage the wsp and it works.

    <Field Name="ThemeUrl">~SiteCollection/_catalogs/theme/15/palette007.spcolor, /sites/HG/_catalogs/theme/15/palette007.spcolor</Field>
    <Field Name="ImageUrl">/_layouts/15/images/image_bg007.jpg, /_layouts/15/images/image_bg007.jpg</Field>
    <Field Name="FontSchemeUrl">~SiteCollection/_catalogs/theme/15/fontscheme002.spfont, /sites/HG/_catalogs/theme/15/fontscheme002.spfont</Field>

    Thursday, September 19, 2013 3:53 PM
  • Same problem here. A quick workaround is to create a spreadsheet view, set it as the default public view and edit the items (remove the invalid path or hostname)

    d.


    • Edited by dinos.kon Tuesday, October 8, 2013 3:26 PM
    Tuesday, October 8, 2013 3:18 PM
  • I've just seen this exact problem on a SharePoint 2013 farm as well this morning, but have managed to fix the blank "Composed Looks" list issue, although am still working on the "Change the look" wizard pages. Edit: found a fix for this too now. See my next post below.

    It appears that the process of saving a site as a template and then creating a new site from that template causes the original XsltListViewWebPart used to display the default view of the "Composed Looks" list, to be replaced with a ListViewWebPart, which appears to be broken.

    Edit: have also seen this behaviour on sites created from the built-in templates but haven't determined exactly whether this is a bug. ULS logs never show any errors when this occurs so it appears to be "by-design". Ugh.

    There may be a tidier way to fix this, but for now, I used SharePoint Designer 2013 to copy an XsltListViewWebPart from a working "Composed Looks" list, AllItems.aspx page and replaced the ListViewWebPart in the broken Composed Looks list, AllItems.aspx page with it. There is also some additional post copy-paste tidy up to do on the pasted-in XsltListViewWebPart HTML to get it to work within the context of the site it is now in as it will contain GUIDs and URLs that are only relevant within the site that you copied it from and these need to be replaced with the GUIDs/URLs from the replaced ListViewWebPart - paste it in a notepad session before deleting/overwriting it so you can grab those bits.

    I'll write a more detailed step-by-step if anyone wants it, but this doesn't seem to fix the broken "Change the Look" wizard still, only the "Composed Looks" list default view. I'll look into that now and post back more complete solution if I can find a fix.

    Edit: Found a fix. see my next post below.

    Edit Edit: One more thing - on some Composed Looks lists we are seeing empty lists once the default view webPart is fixed up. To correct this, you can copy selected Composed Looks from a working site with a full set.

    Before you do that, edit the default view in both the source and destination Composed Looks lists and include the Title field as it is a required field.

    Then, you can use Datasheet View (just click the edit list link to put it in Datasheet View mode) to bulk copy/paste Composed Looks between the source and destination lists.

    Do a little post-paste tidy up on the URLs as above to make sure that they are correct for their new location and then click on over to your Change the Look wizard.

    You should see all of your Composed Looks displayed nicely on the page.

    Note that the Current Look might not represent the sites actual appearance as it's settings will reflect the source sites appearance, but you can tweak it with the Wizard now.

    Regards,

    Glenn

    Can you confirm your sharepoint patch level?
    Monday, October 21, 2013 5:21 PM
  • Open the elements.xml inside the listinstances folder within the wsp

    and change the entries like below replace fqdns with ~Sitecollection/

    Repackage the wsp and it works.

    <Field Name="ThemeUrl">~SiteCollection/_catalogs/theme/15/palette007.spcolor, /sites/HG/_catalogs/theme/15/palette007.spcolor</Field>
    <Field Name="ImageUrl">/_layouts/15/images/image_bg007.jpg, /_layouts/15/images/image_bg007.jpg</Field>
    <Field Name="FontSchemeUrl">~SiteCollection/_catalogs/theme/15/fontscheme002.spfont, /sites/HG/_catalogs/theme/15/fontscheme002.spfont</Field>


    wasn't able to find any of these properties in the elements.xml or any file in the wsp.
    Monday, October 21, 2013 6:30 PM
  • Here is what we did to do to make this work:

    1. We create a root site
    2. We create a Masterpage
    3. We create a theme
    4. We create a team subsite (SiteTemplate) for the purposes of creating a custom site template.
    5. We add Lists & libraries to the team site, and tune it appropriately.
    6. We apply the theme created above to the team site.
    7. We have our master page (.master, .html and .preview) living in a folder at the root site http://site/_catalogs/masterpage/Customer.  The folder (and therefore the files) must be copied to the template site.  http://site/SiteTemplate/_catalogs/masterpage/Customer (The template takes the master locally, but the .spcolor file from the root, go figure).
    8. We “Save Site as a Template” – MAKE Sure you select “Include Content” because the hidden “Composed Looks” list has the theme templates which are not copied if you do not “Include Content”.
    9. Once the site template is created you can create sites from it…
    10. However:  On the subsite that you just created, if you try to look at the “Composed Looks” list it is T-Boned because the “All Items” list is probably not pointing to the right guid.  So create a new view, “All Items2” based on the Standard View and make it the default view, delete the “All Items” view, and rename “All Items2” to “All Items”
    • Proposed as answer by Nirikshita Wednesday, May 28, 2014 5:58 AM
    Monday, October 21, 2013 9:44 PM
  • I have opened the elements.xmp file as you have suggested and I see the url hardcoded in these fields. The URL is from the site where I created th template, it is not the url of the destination of the new site. Are you indicating that we should literally replace the url with "~SiteCollection"? or do we enter the new URL?

    also, in the same lines as you have shown above, there is another url shown in your case /sites/HG/ - should those also be changed? again, in my file, this seems to be pointing to an incorrect place.

    Eagerly anticipating an answer to this.

    Thanks,

    DP

    Thursday, November 14, 2013 4:03 PM
  • Obviously its a bug.

    But there is an easy solution to fix it: while saving the site template, just use "include content" checkbox. When you save the site with contents, it also saves the "Composed looks" list contents. And then everything works. :)


    Kamil Jurik SharePoint Server MVP WBI Systems a.s.


    Thursday, November 14, 2013 9:15 PM
  • Hi,

    using "Incluse content" doesnt fix the issue.  Did you plz installed the last cumulative update?

    I tested also changing Image, theme  urls. I steel have the same issue.

    Thanky you for your help.


    Rafik - Consultant Sharepoint

    Tuesday, December 10, 2013 2:04 PM
  • I'm experience the same issue.  I can't save Site as a Template w/Content when templates are larger than 50 MB and apparently mine was.  So I had to create template from a site W/O content. 

    Is there simple solution?  Could I copy the Composed Look files from the working site to the newly created template site?

    Thanks

    Kim


    Kim.Williams

    Monday, April 21, 2014 1:21 PM
  • If you do not feel comfortable making any changes to code, be it copying and pasting and then modifying working page code then I would suggest using Dinos approach, it worked for me and is a completely acceptable workaround. Perhaps a CU or SP will fix this problem in the future.

    To elaborate on Dinos approach:

    1. Go to the Composed Looks page from Site Collection settings;
    2. Click on the List tab in the ribbon;
    3. Click on Create View;
    4. Select Datasheet view, name your view and click Save;
    5. You can now see all the data and make changes here.

    Quick, safe, supported and easy.

    • Proposed as answer by sp_admin Thursday, May 22, 2014 2:20 PM
    • Unproposed as answer by sp_admin Thursday, May 22, 2014 2:20 PM
    • Proposed as answer by sp_admin Thursday, May 22, 2014 2:21 PM
    • Unproposed as answer by sp_admin Thursday, May 22, 2014 2:21 PM
    • Proposed as answer by sp_admin Thursday, May 22, 2014 2:24 PM
    • Unproposed as answer by sp_admin Thursday, May 22, 2014 2:24 PM
    Tuesday, May 13, 2014 9:51 AM
  • I found a simpler answer that worked for my situation:

    Go to Site Actions > Site Settings

    Site Actions > Manage Site Features

    Enable "SharePoint Server Publishing" Feature

    Disable "SharePoint Server Publishing" Feature

    Enable "SharePoint Server Publishing" Feature

    (This caused the template to inherit from the parent)

    Thursday, May 22, 2014 2:34 PM
  • Thanks Andy Coyle for solution... Worked for me... after the 10th step, just had to replace the URL's in new created "All Items" view.
    • Edited by Nirikshita Wednesday, May 28, 2014 5:59 AM
    Wednesday, May 28, 2014 5:58 AM
  • Cumulative update package for SharePoint Server 2013 (SharePoint server-package): May 7, 2014

    Issues that this cumulative update package fixes:

    When you create a site by using a custom site template, the composed looks list is empty.

    http://support.microsoft.com/kb/2878240

    Have you tried this. Is this issue got fixed on this Cumulative ?

    Regards

    • Edited by Vikram Ganti Tuesday, September 16, 2014 7:31 PM
    Tuesday, September 16, 2014 7:27 PM
  • I'm experiencing the exact same thing with SharePoint Online Plan 2.  Any solutions for this?  More annoyingly, any site I create from a template (solution) that I create is created with no theme applied, even though the template (solution) had been customized with "Change the Look".  Any help much appreciated.
    Thursday, October 30, 2014 4:57 PM
  • Glenn's solution is the correct fix and I have seen that it works. However, I had a situation with hundreds of sites already created using a site template that had this problem and so was looking at the prospect of having to apply Glenn's fix involving SPD and fixing the XSLT List View web part on every one of hundreds of sites. Yuck.

    So I took a step back as all I really needed was a color theme to be applied to brand all my hundreds of sites. Just a change to the color theme does not necessarily require that I fix the blank "Composed looks" list.

    I worked out a straight-forward work around to the issue of the blank Composed Looks list. This is the option I recommended to my client.

    1. I created a custom CSS style sheet named NBPBLUE.css that specifies particular blue color (003B5C) we need for our brand rather than Office blue (0072C6) in all the appropriate places.
    2. I installed this NBPBLUE.css file on the file system on the SharePoint server in the \layouts\1033\styles\themable folder. This means that this one copy of the file can be used by all sites and site collections in the farm.
    3. I used SharePoint designer to edit the  seattle.master file that controls one specific site and added the following one line that instructs SharePoint to load NBPBLUE.css after all the other CSS files.

    <SharePoint:CssRegistration Name="Themable/NBPBLUE.css" runat="server" />

    The result is that one site displays the special blue color in all the right places even though the Composed looks list is still broken.  Steps 1 and 2 above only need to be done once per server. Step 3 must be repeated for each new site created with the template that was created via Save As Template, but step 3 only takes 1 minute per site, down from 15 minutes per site for Glenn's full XSLT List View Web part fix.


    M. Cox

    Monday, April 20, 2015 10:45 PM
  • Just signed in to vote up :)
    Thursday, October 15, 2015 12:45 PM
  • GLENN!!

    You are a life saver.. Took a bit of doing to figure out the allitems.aspx edits that were required, but got it to come back.. And yes, this is tedious. Wonder if MS will ever fix this, cause I stamped out like 50 Subites across my entire collection and everyone of them is like this.. So as people want to "change" things, I'll have to edit the site each time.

    Cheers!

    Brian


    Brian A Bohanna

    Thursday, May 12, 2016 5:58 PM
  • Worked a treat Glenn. Many thanks!


    Thursday, September 22, 2016 7:24 PM
  • Broken since prior to March 2013 and this issue still exists? Nice.
    Monday, October 30, 2017 1:50 PM