none
User Sync Issues RRS feed

  • Question

  • My AD environment consists of One forest and two domains under it -domainA and domainB. Sharepoint is 2013.

    We are experiencing issues where a lot of the recently created users (like within the last year or two) do not have their attributes populated in the user settings when we look up the https://mydomain.com/_layouts/15/userdisp.aspx?ID=abcdef link.The attributes are present in AD but for some reason the sync (?) hasn't propagated it through these applications.

    New to sharepoint and trying to troubleshoot the user sync issue here. Any guidance will be highly appreciated.

    Thanks!

    Tuesday, September 17, 2019 3:24 PM

All replies

  • Thanks Krishna. The issue here is not with the sync to user profiles. When I look up the user in "manage user profiles" and edit option, I can see the email address populated for the user.

    However, I think it is the web application (not sure if you call it this but the link shows up as https://mydomain.com/_layouts/15/userdisp.aspx?ID=abcdef)  that is not being synced with the user information.

    So, everything is populated in AD. I can see the email populated when viewed through manage user profiles which tells me sync is working fine between sharepoint and AD. However, the application or the workflow list don't seem to get synced with the new information.

    Tuesday, September 17, 2019 4:36 PM
  • Thanks Krishna. The issue here is not with the sync to user profiles. When I look up the user in "manage user profiles" and edit option, I can see the email address populated for the user.

    However, I think it is the web application (not sure if you call it this but the link shows up as https://mydomain.com/_layouts/15/userdisp.aspx?ID=abcdef)  that is not being synced with the user information.

    So, everything is populated in AD. I can see the email populated when viewed through manage user profiles which tells me sync is working fine between sharepoint and AD. However, the application or the workflow list don't seem to get synced with the new information.

    Hi,

    if that is the case try this below with one user account and let me know the output:
    You can use the Set-SPUser cmdlet with the -SyncFromAD switch to update a particular user in a particular site collection:

    Ex: Set-SPUser -Identity 'Contoso\jdoe' -Web https://intranet.contoso.com -SyncFromAD

    The original article: http://technet.microsoft.com/en-us/library/ff607827(v=office.14).aspx

    This will tell it is at that site collection or not.

    Hope this helps.

    Regards,

    Krishna

    Tuesday, September 17, 2019 5:41 PM
  • I had tried below in the past and that did not populate the user attributes. So, ended up updating the attribute manually. Again, the attributes are visible in user profile but not at the web app/site collection level.

    set-spuser -web $web -Identity $usr -SyncFromAD where $web is the url and $usr contained the user identity

    The link below sounds similar and I am going through it now.

    https://blogs.technet.microsoft.com/nishants/2010/08/23/troubleshooting-user-profile-sync-issues-in-office-sharepoint-server-2007/

    • Edited by Xchromosome Tuesday, September 17, 2019 6:46 PM
    Tuesday, September 17, 2019 6:44 PM
  • I will give this a try tomorrow

    https://donalconlon.wordpress.com/2012/03/02/sharepoint-user-information-list-is-not-being-updated/

    While the User Profile Service Application - User profile to sharepoint Quick Synchronization has succeeded status in the job status, i see a N/A for User Profile Service Application - user profile to sharepoint full synchronization.

    Also, one of the content databases table databaseinformation showed the last profile sync time of quite some time ago. And, the stsadm -o sync -listolddatabases 0 showed two guids with sync date from jan 2019.

    So, clearly user profile has some sync issues with the site.

    Tuesday, September 17, 2019 9:48 PM
  • Hi Xchromosome,

    You can use miisclient to monitor synchronization.

    It returns the content of this sync, which you can use to confirm if there is a problem with your sync service.

    It is stored in here:

    C:\Program Files\Common Files\Microsoft Office Servers\15.0\Synchronization Service\UIShell\miisclient.exe

    If you confirm that there is a problem with your user profile service, you can recreate a new service and then test again.

    Looking forward to your update on this issue.

    Best regards

    Itch Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    • Proposed as answer by Michael Han6 Thursday, September 19, 2019 8:55 AM
    Wednesday, September 18, 2019 7:26 AM
  • In my case the client is located at C:\Program Files\Microsoft Office Servers\15.0\Synchronization Service\UIShell.

    There are MOSSAD sync with Deltasync that completes with success. The MOSS-UserProfile deltasync completes with success. The MOSS-userprofile moss_export has 'completed-export-errors'. There are a few errors for some account that has "More than one DN specified for the same profile" messages.

    I would think these are specific to those accounts that has duplicate dn and not related to the sync issue that I mention? There are way more than 35 accounts that have the attributes missing in the site.

    Thursday, September 19, 2019 6:30 PM
  • Hi ,

    I'm sorry I didn't reply in time.

    For this error information, you can refer to this similar situation below

    https://social.technet.microsoft.com/Forums/office/en-US/4de08107-8686-46d8-8184-d7916ece7ad2/mim-synchronization-fails-with-quotmore-than-one-dn-specified-for-the-same-profilequot?forum=SP2016

    https://blogs.technet.microsoft.com/sajiths/2014/12/03/sp2013-adimport-more-than-one-dn-specified-for-the-same-profile/

    Best regards

    Itch Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Tuesday, September 24, 2019 9:05 AM