none
Full Cube Process Script sets Attribute to "Unknown" and when i do a process full on dimension attribute afterwards the attribute is correct RRS feed

  • Question

  • Hi,

    I do a full process on cube in job agent script but then a dimension attribute is set "Unknown'

    Then afterwards I do a dimensional process full then the attribute value is correct.

    How do I fix, every time I do a process the attribute is lost

    I tried two steps in job where full process > dimensional process full but it does not seem to work

    Please help

    Thursday, November 14, 2019 9:05 AM

All replies

  • Hello Ismail ,

    Could it be you have a code that update this value ? ( Imean at the calculation tab at SSDT)


    Regards, David .

    Thursday, November 14, 2019 2:12 PM
  • hi

    its dimension attribute, no mdx or calculations in cube

    regards

    Thursday, November 14, 2019 2:43 PM
  • Hi

    This is wierd .. Could it be that agent job parameters holding a different data source  than the solution ?


    Regards, David .

    Thursday, November 14, 2019 3:29 PM
  • Hi,

    Im using the script from the ssas process full "script to window" and paste into job step SSAS command

    Thursday, November 14, 2019 7:03 PM
  • Are you using any views with ROW_NUMBER() to dynamically generate an ID column? This is the only time I've seen this sort of issue as the IDs can then change from one process operation to the next. If this is your issue the solution is to create an identity column in your dimension table so that the IDs do not change.

    http://darren.gosbell.com - please mark correct answers

    Friday, November 15, 2019 12:14 AM
    Moderator
  • Hi lsmailc1,

    Thanks for your question.

    Maybe values of dimension attribute are not in the values of matched column from fact table. In my opinion, it is caused by new update data.

    Best Regards,

    Will


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, November 15, 2019 2:39 AM
  • Hi,

    So how do I go about it?

    Regards

    Friday, November 15, 2019 8:02 AM
  • Not using Row_Number but a compositekey is built in view

    example: period+'-'+company+'-'+customer

    ?

    Friday, November 15, 2019 8:20 AM
  • Hi,

    So how do I go about it?

    Regards

    If that is the case, you need to maintain the dimension table data of data source, make sure the matched column data of fact table are all in the dimension table.

    Best Regards,

    Will


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Monday, November 18, 2019 6:25 AM