Office Web Apps is not working RRS feed

  • Question

  •      Hi,

         We have deployed Lync 2013 and Office Web Apps Server but, after a number of tests, we haven't been able to share PowerPoint presentations. We tested "everything" but it didn't work.

         Finally, to simplify and focus the problem, we just deployed Office Web Apps Server "on its own", that is: just Internal URL, HTTP, Open From URL Enabled and sharing docs from a shared folder in the same server. So we have:

         \\wacserver\share\<Docs> (Excel, Word and PowerPoint)


         They work both "/hosting/discovery" and "/op/generate.aspx".

         If we try to view Excel doc, it works. If we try to view Word or PowerPoint, id doesn't work.

         For PowerPoint, it appears the PowerPoint Web Apps frame (FILE, START SLIDE SHOW, SLIDE - OF -, NOTES...) and, in the center, an animation  "PowerPoint Web App .....". After a couple of minutes, it stops with "Either you've lost network connectivity or our server is to busy to handle your request".

         What we have seen from different sources:



         /op/view.aspx?... Response 200

         /p/PowerPointFrame.aspx?... Response 200

         /p/imagehandler.ashx?... Response 202

         13 petitions to /p/ppt/view.svc/jsonAnonymous/GetPresentation Response 200



         There were some folders and registry keys Network Service was trying to access with ACCESS DENIED response. We gave it permissions and they disappeared.

         SYSTEM is trying to access some registry keys (SpellingWcfprovider.exe => HKU\S-1-5-18, ImagingService.exe => HKLM\Software\Microsoft\Windows NT\CurrentVersion\Image File Execution Options, and 2 or 3 more). It gets an ACCESS DENIED but SYSTEM, we have checked, has "Full control" permissions in those keys or folders.

         These errors appear by Office Web Server running itself, although we are not making a PowrPoint file request.



         Several times, it tries to find the PowerPoint presentation in the caché, doesn't find it, manage to get it but, when trying to put it in the cache, it receives a disk space error:

    Determined file name [PowerPoint.pptx] from [\\wacserver\share\PowerPoint.pptx]
    AFileFetcher: Starting Unc download at [\\wacserver\share\PowerPoint.pptx]
    Begining UNC Download for [\\wacserver\share\PowerPoint.pptx]
    Reading next block of bytes for [\\wacserver\share\PowerPoint.pptx]
    End reading block of bytes for [\\wacserver\share\PowerPoint.pptx]
    Reading next block of bytes for [\\wacserver\share\PowerPoint.pptx]
    End reading block of bytes for [\\wacserver\share\PowerPoint.pptx]
    AFileFetcher: Done downloading file. [\\wacserver\share\PowerPoint.pptx]
    Downloaded file from final URL [\\wacserver\share\PowerPoint.pptx] with SHA256 [Y/whX0EzCZJQdHym/OPrMdrNVg0h8SwrC0TehaKIQdU=]
    AFileFetcher: Will cache web file info to memory cache. [\\wacserver\share\PowerPoint.pptx]
    Starting WriteStreamToDiskCache
    Creating channel to DiskCache: http://wacserver:809/diskcache/DiskCache.svc
    MachineTransfer [SourceMachine:wacserver, SourceMachineVersion:15.0.4543.1000, TargetMachine:wacserver, TargetMachineVersion:15.0.4551.1011, Method:DiskCacheService.PutCacheData]
    PutCacheData: [167F6AC792AE9B53BEA7CD135A35C18F0710CF5916C49DD5804C9E29CF9149CA55D1C8D1AD526B45B91801E1502B2BCD, d1c8d155-52ad-456b-b918-01e1502b2bcd, 50758, wacserver]
    PutCacheData: Writing to C:\ProgramData\Microsoft\OfficeWebApps\Working\d\1CA\167F6AC792AE9B53BEA7CD135A35C18F0710CF5916C49DD5804C9E29CF9149CA55D1C8D1AD526B45B91801E1502B2BCD
    Not enough disk space to write.  Sleeping once.
    Not enough disk space to write.  Giving up.
    PutCacheData Response: [False]

         The cache folder has enough disk size and PowerPoint.pptx file is just 30 KB.

         It repeats this flow 3 times (as for the first HTTP requests).

         During the 2 minutes test (until it fails) there are 14 traces like:

    Failed to create process object for pid 7780 with exception System.ArgumentException: Process with an Id of 7780 is not running.     at System.Diagnostics.Process.GetProcessById(Int32 processId)     at Microsoft.Office.Web.Common.RequestPipe.ProcessManager.TryGetProcessObject(Int32 pid).

         We have tried a number of things but none has worked. The farm has just one server and it says ist's unhealthy. We have Windows Server 2008 R2 SP1. We have read some ways to fix the health, like HTTP Activation feature, but it only works for Windows Server 2012 as fas as we know.

         Has anybody experienced something like this or have a posible solution? Office Web Apps Server should be so easy to deploy but we have spent a lot of time with this.

         Thank you very much. Your help will be very appreciated.

         Kind regards.

    Thursday, February 20, 2014 4:58 PM


  • In the end it was due to the security policies. There were some permissions change to a number of registry keys and some folders, so Office Web Apps server hadn't enough access privileges for working.

    Once we found the keys and folders affected and changed the policies, it ran smoothly.

    • Marked as answer by John Niente Tuesday, October 28, 2014 12:59 PM
    Tuesday, October 28, 2014 12:59 PM

All replies

  • The office web app server is normal eaysy to install, but sometimes it will not work if have done some wrong configuration.

    Hee is a good link for all steps


    You can also try to remove WAC form topology, publish topology, add WAC to topology.

    regards Holger Technical Specialist UC

    Saturday, February 22, 2014 10:38 AM
  • Hi John,

    What is being logged in the Lync Server Event log?  Are you seeing the WAC discovery and the spin up and/or the error when you try to run a powerpoint?

    I always deploy Web Apps with certificates as it never reliably works without, if necessary then you can change the farm properties to allow HTTP.



    Saturday, February 22, 2014 11:03 AM

         Hi Holger,

         Thank you for your answer.

         Actually we followed those steps (from official Microsoft deployment but also from some other links). The only difference is we have Windows 2008 R2 SP1.

         We removed WAC from topology, publish and add again several times. We changed the certificate and stated there wasn't a certificate problem. We reinstalled WAC several times. Then, we ended up focusing just in WAC, trying to open documents in order to discover where the problem was... and we are still there.

         As you said, installation is easy. There is something strange we cannot find.

         Kind regards.

    Sunday, February 23, 2014 12:40 AM
  •      Hi Matt,

         Thank you for your answer.

         In the beginning, we created WAC Farm's logs and cache folders in not-default folders and we couldn't view PowerPoint presentations. Then we changed them leaving the default folders and the error I related appeared (Not enough disk space to write). Although there is enough space, we have changed them again to the former location because there are more space. Now, "disk erro" is not appearing and we receive the first error we had.

         WAC discovery works. /op/generate.aspx works. When we try to view a PowerPoint, it appears the PowerPoint frame and, in the center of the page, "PowerPoint Web App" loading but it ends up failing within 1.5 to 2 minutes.

         The error we are getting right now (the first we had) says "A request appears to be stuck in the queue".

         If we restart the server and try to view a PowerPoint, we can read in the logs traces that WAC gets it from the shared folder and writes it in the cache (we have seen it there). But then it begins Conversion service and, somehow, doesn't finish and it appears (in logs) an "InProgress" error.


    02/21/2014 13:05:24.00 w3wp.exe (0x22D4)                       0x239C Office Web Apps               PowerPoint Front End           a22x Medium   WacItemRetrievalResultErrorInfo; ItemRetrivalStatus: InProgress; ErrorCode: ErrorInProgress; 2a5362cb-d143-43bb-83b8-745c80a3394b


         After that, if we try it again, it happens something similar but it ends up with an error we can also view in the Event Viewer:


    Office Web Apps Monitoring, 1159 and 2259

    <?xml version="1.0" encoding="utf-16"?>
    <HealthReport xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <HealthMessage>PowerPointViewingServicesWatchdog_App reported status for PPTConversionService in category '0'. Reported status: AppManager: A request appears to be stuck in the queue. [State: ReadyToWork] [Start Time: 02/21/2014 13:12:02] [CorrelationId: 417b5a71-3d07-4e53-bd56-4da254456856] [DocId: <Doc_ID>] [ClusterId: 0] [RequestId: 76af2071-9431-4e98-84cc-9b3df566c894] [Current InProgress Queue Length: 1]</HealthMessage>


         If we try to view more files, the queue grows.

         As for ULS logs it seems to be something related to Conversion or Viewing services (once the file is writen in the cache). It seems that it takes too much time to convert it or it fails or something like that. It remains in "InProgress" state and finally we get an error.

         We haven't been able to discover how to view that queue or check for Conversion service and so on. It seems that the problem is in the final phase of the process but we haven't got any other clue.

         Does it makes sense to you? Any idea?

         Do you think we should try to re-create the farm with certificate although we are just trying to HTTP view files with WAC? (and then integrate with Lync again) That didn't work but we could try again if it made sense...

         Thank you in advance.

         Kind regards.

    Sunday, February 23, 2014 1:07 AM
  • Have you installed the latest updates?

    Because Lync 2013 has problems with windows 8.1 to show the powerpoint.

    You have to remove the server from the webfarm, before you apply the latest update.

    regards Holger Technical Specialist UC

    Sunday, February 23, 2014 6:59 AM
  •      Hi Holger,

         We read about that problem. Anyway, we are working with Windows 7 + Internet Explorer 9 in our PCs and Windows Server 2008 R2 SP1 + Internet Explorer 9 in the WAC.

         As we have re-installed several times, last times we have followed this process:

         1. Pre-requisites and Office Web Apps Server as Microsoft states

         2. KB2810007

         3. KB2837634

         4. KB2910228

         5. Language Pack English

         6. Farm creation

         Kind regards.

    Monday, February 24, 2014 1:03 AM
  • Please check you install the prerequisite Platform update for Windows 7 SP1 and Windows Server 2008 R2 SP1 (KB2670838) on Windows Server 2008 R2.

    For the details, check http://technet.microsoft.com/en-us/library/jj219455.aspx

    Lisa Zheng
    TechNet Community Support

    Wednesday, February 26, 2014 11:18 AM
  •      Hi Lisa,

         Thank you for your answer.

         Yes, we followed those directions, so we installed:

         - Windows Server 2008 R2 SP1

         - .NET Framework 4.5

         - Windows Management Framework 3.0

         - KB2670838

         - Office Web Apps Server Setup

         - KB2810007

         - KB2837634

         - KB2910228

         - Language Pack English

         - Farm creation

         Kind regards.

    Wednesday, February 26, 2014 11:31 AM
  • Hi John

    It sounds like that your owa server not working internally actually. Would you be able to check on your front end in event viewer if there is a event id 41032 which indicates that the front  end has successfully discovered owa server?If https://yourowaserver fqdn/hosting/discovery could be displayed successfully internally and owa server has been found in front end event viewer logs. It should work without any problems.


    Wednesday, February 26, 2014 9:27 PM
  •      Hi WenFei,

         Thank you for your answer.

         Yes, Lync Front End had events 41032 and 41034. In addition, /hosting/discovery was working. Nevertheless, PowerPoint presentations were not working.

         That's why I focused in WAC Server, creating a new farm without certificate, enabling open files from URL and UNC, and allowing HTTP. This way I could find which the problem was without other servers or network issues. Once this works, Lync will also.

         Excel files work. PowerPoint and Word don't. They are located in a shared folder in the WAC Server, with full permissions por Everyone, and I'm trying to open them with an Internet Explorer from the same WAC Server. 

         As you can read in my answer to Matt (Sunday, February 23, 2014 1:07 AM), it seems that Conversion Service is failing somehow, leaving files in an "InProgress" state but not ending. I haven't found the solution yet. I'm trying.

         Kind regards.

    Thursday, February 27, 2014 12:02 AM
  • In the end it was due to the security policies. There were some permissions change to a number of registry keys and some folders, so Office Web Apps server hadn't enough access privileges for working.

    Once we found the keys and folders affected and changed the policies, it ran smoothly.

    • Marked as answer by John Niente Tuesday, October 28, 2014 12:59 PM
    Tuesday, October 28, 2014 12:59 PM
  • John, would you mind sharing the registry keys and permissions you granted.  We are running into the exact same issues you were seeing.  Thank you.


    Friday, November 21, 2014 12:55 PM
  • Hi Steve,

    There were a number of registry keys which were given Read permissions for AU (Authenticated Users). When we gave Read permissions to BU (Builtin\Users) instead, it worked.

    It also happened with the WINSXS file folder.

    Some registry folders were:






    Thursday, November 27, 2014 3:23 PM
  • For what it's worth...we had the issue described above, the answer for us was to leave Office Web Components on the C: drive.  Had to remove the OWA connection, uninstall OWA, reinstall it, patch it to the version of SP we're using, redo the binding, and it worked for Word, Excel and PPT.
    Wednesday, February 8, 2017 6:56 PM