[DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.





    I managed to install SQL Server 2000 Standard Edition 32 bit on Windows Server 2003 64 bit OS. I also managed to Install Service Pack 4 on it.


    The problem is now connecting with my production server. The new Server connects with all other SQL Servers in the network.But cannot connect to the production server.The production server can connect to the new server.


    I tried to ping the production server from new server and I could ping it.


    When I tried to telnet using port 1433, the connection failed.


    I tried connecting through Query Analyzer, DTS but it does not Connect:

    I  get the following error:


    [DBNETLIB][ConnectionOpen (Connect()).]SQL Server does not exist or access denied.


    I have already looked through google and microsoft knowledge base but could not find a valid reason.

    There are no DSN's setup yet.


    I tried to look into the HKEY_LOCAL_MACHINE for tcp port setting and it is set to blank. When I check my other SQL Servers, the other servers are also configured the same way and they are connecting fine.


    Can somebody tell me if this was a problem because a 32 bit app is installed on a 64 bit OS. I installed SQL Server from setupsql.exe rather then from the regular setup.


    Is there any setting or any other point that I am missing out because of which i am not able to connect to production server.


    I also asked my network admin to see if there was an firewall issue.But there is not firewall issue involved here as well.

     Please help me asap..I need to have this server up and running asap.


    Thursday, January 17, 2008 5:32 AM

All replies


    Hi .. Bijal.. i found a problem same as you.. have you found out ur problem? if yes.. would mind to post the steps.. thx
    Thursday, January 31, 2008 9:12 AM
  • I found multiple reasons for this error.


    1) My new server is not on the domain and somewhere on my old server at the windows level there might be a policy set to allow servers only in the domain to connect.


     I found this out when I added the new server to the domain and then tried to connect


    2) the client computer is trying to connect through a different port.


    In this case. Check the sql server errorlog for the new server - it will have the port on which your server is listening.


    Then go to the client network utility, and add the server and the port and then try to connect


    3) IF your server is set to assign ports dynamically to the client computer, in that case as well this problem can arise.


    4) Also check if the server resolves to the dns created for the IP address


    If you still encounter problem, then let me know.


    I have'nt fixed problem with all the servers and I am still working on it. But with the solutions mentioned above I was able to make most of the computers connect to the new server






    Friday, February 01, 2008 12:15 AM
  • Bijal if it sin't too much to ask for, could yuo check the link pasted below. I'm facing a similar problem and I just can't seem to figure out the cause.




    Monday, March 03, 2008 12:25 PM
  • hi i clicked on the link above and it says the page expired.

    I am member on sql server central. What info do you need about this error?

    I managed to resolve it in my environment. So let me know if you need help
    Tuesday, March 04, 2008 9:18 PM
  • you can email me on
    Tuesday, March 04, 2008 9:19 PM

    Did you alread verify if the SQL Server are using a dinamic port?

    When SQL use dinamic port, some time they can change it.


    Wednesday, March 05, 2008 1:31 PM