none
How to Delete List "List does not Exist" RRS feed

  • Question

  • Hi,

    In a SP 2010 site, when I go to Site Contents and click on the list name I get an error that the "List does not Exist. The page you selected contains a list that does not exist.  It may have been deleted by another user." I need to delete the list, but I can't open the list to delete it. I tried using Powershell to delete it but got the same error message "List does not Exist". My main task is to migrate the entire site to SP 2013 but when using ShareGate I get the error "List does not Exist" and migration is cancelled. I've tried to find the list in SP Designer but when I click on 'Lists and Libraries' section it returns "There are no items to show in this view." When I click on 'All Files' it shows all the lists and libraries except this one list in question.

    Has anyone seen this issue before? How do I delete this list?

    Thanks in advance for any help with this issue!

    Wednesday, July 17, 2019 4:47 PM

All replies

  • Did you tried to browse the list internally or externally ? If you are able to browse internally fine and your getting this error in externally only then follow the below article.

    https://shareyourpoint.wordpress.com/2012/04/12/list-does-not-exist-the-page-you-selected-contains-a-list-that-does-not-exist-it-may-have-been-deleted-by-another-user-sharepoint-2010-error/

    Try the steps for more troubleshooting go to the list, check the permission settings, make sure you have permission to the list.
    Can you access the list directly using the URL?
    You can find the list using the list GUID, type the this URL in browser: http://yourserver/_layouts/listedit.aspx?List={ceb31d57-dea6-4524-ba47-bf15f6f73d4a}, it will go to the list settings page and you can check the list settings.

    Make sure you try after clearing the browser cache & also SP Cache from below article.

    https://github.com/DwayneSelsig/spcachecleaner/blob/master/SPCacheCleaner.ps1

    Thanks & Regards,


    sharath aluri

    Wednesday, July 17, 2019 4:57 PM
  • I can't browse to the list at all, so I can't go to list settings. I have tried using the list GUID URL as well and it did not work either.

    • Edited by FireFly444 Wednesday, July 17, 2019 6:00 PM
    Wednesday, July 17, 2019 5:49 PM
  • Try to browse that Site Url in IE and try to see if you are able to open with explorer of that list or not.


    sharath aluri

    Wednesday, July 17, 2019 7:38 PM
  • Hi FireFly444,

    To troubleshoot the issue, check things below:

    1. Detach the content DB and attach again.

    2. Detect orphaned items by the following command line.

    stsadm -o databaserepair -url http://Web-App-URL -databasename <database Name>


    3. Delete orphaned items by the following command line.

    stsadm -o databaserepair -url http://Web-App-URL -databasename <database Name> -deletecorruption


    More reference:

    Find and Delete Orphaned Site Collections, Items in SharePoint.

    Best regards,

    Sara Fan


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.


    Thursday, July 18, 2019 7:58 AM
    Moderator
  • Hi FireFly444,

    How is everything going?

    Is there anything update about this issue?

    If the reply is helpful to you, you could mark the reply as answer. Thanks for your understanding.

    Best regards,

    Sara Fan

    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Friday, July 19, 2019 8:46 AM
    Moderator
  • Hi FireFly444,

    I am checking to see how things are going there on this issue. Please let us know if you would like further assistance.

    If the issue was resolved, you can mark the helpful post as answer to help other community members find the helpful information quickly. 

    Best regards,

    Sara Fan

    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Tuesday, July 30, 2019 8:16 AM
    Moderator