none
SSDT for VS2012 installation fails with "Same architecture installation" error

Answers

  • hi Ted

    you need to choose "new instance" instead of the installed instance otherwise the installation fails with "architecture mismatch".

    Personally I think the package is incorrectly authored as it should be able to install SSDT BI only without this glitches.


    Please use Mark as Answer if my post solved your problem and use Vote As Helpful if a post was useful.

    • Marked as answer by Ted Monday, March 11, 2013 6:22 AM
    Saturday, March 09, 2013 8:17 PM

All replies

  • hi Ted

    you need to choose "new instance" instead of the installed instance otherwise the installation fails with "architecture mismatch".

    Personally I think the package is incorrectly authored as it should be able to install SSDT BI only without this glitches.


    Please use Mark as Answer if my post solved your problem and use Vote As Helpful if a post was useful.

    • Marked as answer by Ted Monday, March 11, 2013 6:22 AM
    Saturday, March 09, 2013 8:17 PM
  • hi Ted

    you need to choose "new instance" instead of the installed instance otherwise the installation fails with "architecture mismatch".

    Personally I think the package is incorrectly authored as it should be able to install SSDT BI only without this glitches.


    Please use Mark as Answer if my post solved your problem and use Vote As Helpful if a post was useful.

    That solution also works when you're trying to install SSDT with SQL Server 2014 CTP1.
    Saturday, August 17, 2013 5:16 PM
  • I stumbled up on this issue as well, when I choose new installation it worked. 

    In my thoughts, I did not want to install SQL Server Again... so I quit installation and look for different architecture. I hope Microsoft Folks correct this misleading failure.


    AbuTaareq

    Thursday, August 22, 2013 4:55 PM
  • Is this problem solved yet ?
    Tuesday, November 12, 2013 1:07 PM
  • It's not. Shame.
    Monday, December 02, 2013 6:25 PM
  • Still not fixed in latest (today 2013-12-18) downloaded version, SQL 2012 that is.

    Merry Christmas! :)


    JB

    Wednesday, December 18, 2013 9:32 AM
  • It worked for me mate. Thanks
    Wednesday, January 29, 2014 9:35 PM
  • The 5:th march, 365 days later. Still not fixed.
    Wednesday, March 05, 2014 5:25 PM
  • And another 6 months later - "the beat goes on!" :(
    Thursday, October 02, 2014 1:59 PM
  • Still not working Nov 4th
    Tuesday, November 04, 2014 7:00 PM
  • Install for 2014 still remains...........

    Monday, May 18, 2015 8:29 PM
  • Seconded that!  It is ridiculous MS doesn't fix this.

    Thanks, Brian

    Wednesday, June 03, 2015 1:10 PM
  • Thanks Daniel, rebuilding my laptop and this was just the answer I needed. :)


    John Lowther

    Friday, August 28, 2015 6:31 PM
  • Still not fixed or made clearer after 2.5 years, on SQL2014 SP1 and VS2013! Can't even install SSDT on current VS2015!

    Installing SSDT generally (aka "hunt and try the exact environment combination machine") is a time-wasting joke, does not instill confidence in SSRS solutions.

    Anyway, at least the unintuitive necessary option doesn't actually "Perform a new installation of SQL Server 2012/2014" and does just install the tools with existing instance. Phew.


    • Edited by EuroPhilC Monday, October 05, 2015 3:27 PM clarify successful installation.
    • Proposed as answer by NoPressure Wednesday, December 09, 2015 10:30 PM
    • Unproposed as answer by NoPressure Wednesday, December 09, 2015 10:30 PM
    Monday, October 05, 2015 2:59 PM
  • 12/9/2015 - Still no fix. This just reinforces my long held opinion that the Sql Server installer is the worst installer I've ever had to use.
    Wednesday, December 09, 2015 10:37 PM
  • 1/19/2016 and STILL not fixed. 

    Hector Tosado Xrm Developer

    Tuesday, January 19, 2016 10:14 PM
  • Thank you its working for me

    Sunday, January 24, 2016 9:35 AM
  • Happy Chinese New Year 2016, I encountered the same problem and your post helped, thanks.
    Sunday, February 07, 2016 5:23 PM