Cannot see the CUBES in the excel report


  • Hi All

    I have a report in excel which uses the CUBE's from the SSAS, but for some reason for the past few days whenever i open the report, it gives me a message saying

    "Excel cannot find the OLAP Cubes, either the OLAP database has been changed or you do not have premissions to connect to the CUBE. Consult your DBA".

    When i tried to open a new excel and tried to connect to the SSAS, i cannot see any CUBES. Please need help, any advice is greatly appreciated.


    Bhargav Kandala

    Friday, June 01, 2012 2:17 PM


All replies

  • it never happened to me but I am just putting some guesses out there...

    can you ping the target server through DOS ? seems like you can, since you don't see the cube after connecting...

    you can restart SSAs service and see if that fixes but before doing so run the profiler to check out "existing connections" to see is anyone can connect !

    Friday, June 01, 2012 2:35 PM
  • After you enter the server name in Excel, do you get the databases?

    In my experience if I can connect to the server, but can't see any cubes it is a permissions issue within the cube roles.

    Friday, June 01, 2012 3:39 PM
  • Thanks Randi. I can access the database but canot see the CUBES. I opened the database in BIDS and in BIDS from the tool bar i clicked on the Project Tab and clicked on ADD NEW ROLE, but what ROLES should i look for and what roles should i add to? Please need some advice.


    Friday, June 01, 2012 4:30 PM
  • Hello,

    Please refer to the following articles to connect Excel to SQL Server Analysis Services:

    Bin Long

    Bin Long

    TechNet Community Support

    Thursday, June 14, 2012 11:00 AM