locked
Unable to deploy SSIS package due to A required Prvilage not held by the client RRS feed

  • Question

  • I have an instance of SQL Server 2016 and I'm using SSDT VS 2017. I've created a simple package that loads data from a flat file source and loads it to a database. I have full administrative rights to the machine and SQL Server and the package runs fine in the designer. I have already created a catalogue however when I come to deploy the package i get the following error:

    TITLE: SQL Server Integration Services
    ------------------------------

    A .NET Framework error occurred during execution of user-defined routine or aggregate "deploy_project_internal": 
    System.ComponentModel.Win32Exception: A required privilege is not held by the client
    System.ComponentModel.Win32Exception: 
       at Microsoft.SqlServer.IntegrationServices.Server.ISServerProcess.StartProcess(Boolean bSuspendThread)
       at Microsoft.SqlServer.IntegrationServices.Server.ServerApi.DeployProjectInternal(SqlInt64 deployId, SqlInt64 versionId, SqlInt64 projectId, SqlString projectName)
    . (Microsoft SQL Server, Error: 6522)

    For help, click: http://go.microsoft.com/fwlink?ProdName=Microsoft%20SQL%20Server&ProdVer=13.00.5081&EvtSrc=MSSQLServer&EvtID=6522&LinkId=20476

    ------------------------------
    BUTTONS:

    OK
    ------------------------------

    I even tried to export the package and create an agent job to run it that way but that errors out too, although I can't find the reason why and it's not something I am familiar with. I've searched the internet far and wide but no matter what I try I cannot seem to get any SSIS job working. Any ideas where to begin?

    thanks in advance

    Thursday, May 23, 2019 3:46 PM

All replies

  • Hi SQL_Chris_,

    "...however when I come to deploy the package i get the following error:..."

    First of all, I hope you are deploying the entire SSIS project, not a single SSIS package, in a 'Project Deployment' mode to the SSISDB catalog. And you manually created a Folder there.

    Please share how you are deploying:

    • Directly in VS2017.
    • In SSMS with *.ispac file.



    Thursday, May 23, 2019 3:52 PM
  • Forgive me, I am very new to SSIS, I am deploying like I would a an SSRS report. In the solution explorer I am right clicking on the Project then choosing deploy. I use the wizard to specify the catalogue. I am going to research this process right now in case I am doing something wrong.

    EDIT: Also I am saving the file as a .DTSX file not ispac

    EDIT

    VS deployment

    just to be more clear here: The project is in a "Project deployment Model" mode and I am deploying a full project, not a package within the model. MNy SSISDB has a catalogue which I have created manualy. I am deploying by using Windows authentication which has full admin rights to the Server.

    ISPAC Deployment

    I am building the project then going to the bin folder to extract the ISPAC. I'm then going into SSMS, expanding the "Integration Services Catalogue" node > SSISDB > Folder > then i right click on Projects and deploy, following the guide as mentioned in  MonaLVs comment 
    • Edited by SQL_Chris_ Friday, May 24, 2019 9:16 AM addition
    Thursday, May 23, 2019 3:55 PM
  • Hi SQL_Chris_,

    As a prerequisite, you need to go to the SSMS and manually create a Folder there.

    Just after try to deploy the entire project in VS.

    Please share a screen shot of your SSMS' SSISDB with all plus symbols expanded.


    Helpful link: Deploying Packages to SQL Server Integration Services Catalog (SSISDB)
    Thursday, May 23, 2019 4:15 PM
  • Hi SQL_Chris_,

    The following links will be helpful.

    System.ComponentModel.Win32Exception: A required privilege is not held by the client while Deploying SSIS Project

    SSIS 2012 Projects: Setup, Project Creation and Deployment

    Best Regards,

    Mona Lv


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, May 24, 2019 2:44 AM
  • Hi SQL_Chris_,

    As a prerequisite, you need to go to the SSMS and manually create a Folder there.

    Just after try to deploy the entire project in VS.

    Please share a screen shot of your SSMS' SSISDB with all plus symbols expanded.


    Helpful link: Deploying Packages to SQL Server Integration Services Catalog (SSISDB)

    Thank you, There was a Folder there already that I created however I tried creating a couple of new folders just to test it however I'm still getting the same issue. Screen shot below as requested


    Friday, May 24, 2019 8:52 AM
  • Hi SQL_Chris_,

    As a prerequisite, you need to go to the SSMS and manually create a Folder there.

    Just after try to deploy the entire project in VS.

    Please share a screen shot of your SSMS' SSISDB with all plus symbols expanded.


    Helpful link: Deploying Packages to SQL Server Integration Services Catalog (SSISDB)

    Thank you for the links. I have tried to deploy the project as an ISPAC as directed in the second link but I get the same error. I also tried to follow the first step by adding permissions in the DCOM menu however this has not resolved the issue, even after restarting the SSIS service. Following up on this, how do I know which account it's trying to deploy under? in SQL configuration manager I can see the SSIS service has a "log on as" NT Service\MsDtsServer130. But which is the account that has insufficient privilages?



    • Edited by SQL_Chris_ Friday, May 24, 2019 9:08 AM addition
    Friday, May 24, 2019 8:53 AM
  • I have also tried creating a blank project and deploying that just to make sure there isn't something inside the project that's causing issues however I am getting the same error as shown below:

    Friday, May 24, 2019 9:05 AM
  • Hi SQL_Chris_,

    May I know if the account to log in SSMS has the sufficient privilages?

    May I know if you start the SSIS service?

    Best Regards,

    Mona Lv


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, May 27, 2019 10:00 AM
  • Hi SQL_Chris_,

    May I know if the account to log in SSMS has the sufficient privilages?

    May I know if you start the SSIS service?

    Best Regards,

    Mona Lv


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Hi, 

    I can confirm that the SQL account I am using has sufficient privileges to the SQl server. It is a windows AD account with sys admin ole, I have also been to the SSIS DB and assigned this user to it, with the SSIS_Admin database role too. I can also confirm the SSIS service is running as below. could the issue be something to do with the NT Service\MsDtsServer130 we see here?

    Tuesday, May 28, 2019 8:18 AM
  • I have also been in Component Services and given full access to Everyone for all instances of Integration Services in the DCOM Config just to try narrow down the issue, however I am still getting this error message

    Tuesday, May 28, 2019 8:49 AM
  • Hi SQL_Chris_,

    Please refer to Permissions Required to Deploy SSIS Projects and Packages.

    Best Regards,

    Mona Lv


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Tuesday, May 28, 2019 10:00 AM
  • Hi SQL_Chris_,

    Please refer to Permissions Required to Deploy SSIS Projects and Packages.

    Best Regards,

    Mona Lv


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Thank you I have read the article, this is referring to if I am not using the default account, however I am using the default account. Also as stated above; I have customised the DCOM Config settings and set everyone to full access. Can you let me know what the name of the default account is? as I've not changed it, it should be the same as the screenshot above

    regards

    Tuesday, May 28, 2019 12:22 PM
  • Hi SQL_Chris_,

    Please check the following article, including its Comments section:

    A required privilege is not held by the client

    Tuesday, May 28, 2019 3:02 PM
  • Correct me if I am wrong - but it sounds like you are trying to deploy using SSMS.

    If so - can you confirm the version of SSMS that you are using is the same version as the destination SQL Server?

    Or - another option.  Make sure the project properties are set to the appropriate target and deploy from VS.


    Jeff Williams

    Tuesday, May 28, 2019 9:35 PM
  • Chris,

    I have gone thru the priv and added it to the com I have tried importing the ipsec file as well as deploying from VS and everytime I get the deploy_project_internal error.

    Please help!! Need new ideas

    Eric

    Tuesday, February 25, 2020 7:24 PM
  • I am facing same issue, with SQL 2019 version. Tried several things like adding user to Admin group, repair SSIS, etc., but no luck.

    A .NET Framework error occurred during execution of user-defined routine or aggregate "deploy_project_internal": 
    System.ComponentModel.Win32Exception: A required privilege is not held by the client
    System.ComponentModel.Win32Exception: 
       at Microsoft.SqlServer.IntegrationServices.Server.ISServerProcess.StartProcess(Boolean bSuspendThread)
       at Microsoft.SqlServer.IntegrationServices.Server.ServerApi.DeployProjectInternal(SqlInt64 deployId, SqlInt64 versionId, SqlInt64 projectId, SqlString projectName)
    . (Microsoft SQL Server, Error: 6522)


    Mahesh

    Monday, August 10, 2020 5:11 PM
  • Hi Mahesh,

    It is a good idea to open a new post for your issue.

    Monday, August 10, 2020 6:51 PM