none
Error client rendering. The remote server returned an error: (403) Forbidden.

    Question

  • Hello,
    i tried anything to resolve the error i found when i'm trying to open a report from Reporting Services 2008 integrated in a Windows Sharepoint Services 3.0 site.
    I have downloaded the RS Add-in and i have configured it.
    Please help me to resolve this issue.
    I have already search for a solution in many forums but nothing helped me.

    Thank you in advance,
    Angelo.

    Angelo B.
    Tuesday, February 16, 2010 12:52 PM

All replies

  • Any suggestion?

    Thanks.
    Angelo B.
    Wednesday, February 17, 2010 10:35 AM
  • Hi Angelo,

    Generally, the issue is caused by the web.config for the Sharepoint site was not correctly modified by the Reporting Services Addin for Sharepoint. This caused the mappings that correctly assigned the "_vti_bin/ReportServer" folder to bring up the Report. Instead we received a 403.14 error because it was trying to browse the folder instead of launching the
    ReportViewer.

    To fix the 403 Forbidden exception we had to modify the web.config file for the Sharepoint site that had the failing report. The following changes needed to be made to it to work:
    1. Go to the Folder C:\inetpub\wwwroot\wss\virtualdirectories\### (all folders)
    2. Do a backup of that web.config file
    3. Make the following modifications:
    Under <Safe Assemblies> put this:
    <SafeControl Assembly="Microsoft.ReportingServices.SharePoint.UI.ServerPages, Version=9.0.242.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91" Namespace="Microsoft.ReportingServices.SharePoint.UI" TypeName="*" Safe="True" />
    <SafeControl Assembly="Microsoft.ReportingServices.SharePoint.UI.WebParts, Version=9.0.242.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91" Namespace="Microsoft.ReportingServices.SharePoint.UI.WebParts" TypeName="*" Safe="True" />

    Under <http handlers> put this:
    <add verb="*" path="_vti_bin/ReportServer" type="Microsoft.ReportingServices.SharePoint.Soap.RSProxyHttpHandler, RSSharePointSoapProxy, Version=9.0.242.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91" />

    Under <appSettings> put:
    <add key="ReportViewerMessages" value="Microsoft.SharePoint.Portal.Analytics.UI.ReportViewerMessages, Microsoft.SharePoint.Portal, Version=12.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />

    Under </system.net> put this:
    <location path="_vti_bin/ReportServer/ReportServiceAuthentication.asmx">
    <location path="_vti_bin/ReportServer/ReportServiceAuthentication.asmx">
    <system.web>
    <authorization>
    <allow users="*" />
    </authorization>
    </system.web>
    </location>

    Please feel free to ask, if you have any more questions.

    Thanks,
    Jin Chen


    Jin Chen - MSFT
    Thursday, February 18, 2010 7:31 AM
    Moderator
  • Hi Jin,

    i will try to apply the changes you suggested me as soon as i will be back in office tomorrow.
    Also i will let you know the results.

    Thank you very very much,

    Angelo.
    Angelo B.
    Thursday, February 18, 2010 8:24 PM
  • Hello Jin,

    sorry for the late....

    Only today i was able to test your proposed solution as i had to resolve other issues before.

    I've got a problem when i try to insert into the web.config file the line relative to the section <http handlers>:

    <add verb="*" path="_vti_bin/ReportServer" type="Microsoft.ReportingServices.SharePoint.Soap.RSProxyHttpHandler, RSSharePointSoapProxy, Version=9.0.242.0, Culture=neutral, PublicKeyToken=89845dcd8080cc91" />

    I think cause the web.config cannot find the specified dll in the gac, infact there isn't.....
    Maybe an Italian 64 bit version of sharpoint got a problem with the rs add in?

    Please help me

    Thanks in advance,

    Angelo.

    Angelo B.
    Wednesday, March 03, 2010 3:27 PM
  • Hi Angelo,

    The possible cause may be the one you have mentioned.

    Microsoft SQL Server 2008 Reporting Services Add-in for Microsoft SharePoint Technologies only has two versions X86 and X64. There is no IA64 version.

    Thanks,
    Jin Chen
    Jin Chen - MSFT
    Monday, March 08, 2010 2:42 AM
    Moderator
  • Hi Jinchun, is there any update to your web.config settings for SQL Server 2008 R2?  We are trying to launch reports from a webapp using the ReportViewer control and Reporting Services is in Sharepoint Integration Mode.  We only get the 403 if the Reporting Server is on a different server than Sharpoint Server.  When both are on the same box it works (?)  Thanks, -M

    • Edited by M Hibberd Thursday, May 03, 2012 6:37 PM
    Thursday, May 03, 2012 6:21 PM
  • I also have same issue, i tried everything, still not working

    free classified

    Thursday, May 03, 2012 8:49 PM
  • Is this correction to any specific version.

    I have not been able to URL access the report server in SharePoint Integrated mode. There appears to be too many corrections to this file, how come? Is this going to be fixed, or future users have to live with it. I am using SharePoint Servr 2010.

    Thanks for contributing to this important thread.


    mysorian

    Thursday, March 28, 2013 1:23 AM
    Answerer
  • I made the suggested changes to the web site Sharepoint-80 on my IIS 7.0. I still get the same error.

    There was no section <http handlers>. There was <httpHandlers/>. I suppose you meant this.

    I did not have to change <appSettings> it was aleady present, the version was 14.0.0.0 instead of 12.0.0.0 as you suggested. however, it did not matter for the errorneous outcome.

    Any suggestions?

    surely, MSFT should have an answer to this.

    I have not made any changes to the wbe.config in the site whose folder is marked, 18050 (this is the CA site)


    mysorian

    Monday, April 01, 2013 1:18 AM
    Answerer
  • Hi Jin,

    I tried the following the instructions but still getting the forbidden error issue.

    Would you please reply to this thread again of there is more to do.

    My scenario is-

    1. SSRS on SharePoint mode

    2. RS Addin was failing now it is installed properly.

    3. Web.Config still missing the items as mentioned in your thread.

    4. Replacing them with correct items and doing an app pool reset.

    Result-Getting the same error.404 forbidden when I click on the Report builder option on the ribbon under the New menu.

    Appreciate any reply or advice.

    Regards

    Sakti

    Monday, July 27, 2015 2:05 AM
  • Hi Milan,

    Thanks for the reply. I followed the approach and the issue remains the same.

    "This error (HTTP 404 Not Found) means that Internet Explorer was able to connect to the website, but the page you wanted was not found. It’s possible that the webpage is temporarily unavailable. Alternatively, the website might have changed or removed the webpage.

    For more information about HTTP errors, see Help."

    Regards

    Sakti

    Monday, July 27, 2015 12:25 PM
  • Sorry Sakti you are mistaken, I answered for  the original post.

    Is the error something  related to when you are trying to access the report server ? If so  then please follow the below steps and restart the the report service.

    1SQL Server 2008 > Configuration Tools > Reporting Service Configuration Manager

    2- Under Web Service URL > Configure the service URL as you want but most importantly is to change the port from 80 (default for web server) to any free port such as 8080 > Apply changes and check the URL given to you

    3- Under Report Manager URL > Click Advanced > Change the port to what you configured in previous step > Apply changes and check


    Please Dont forget to mark helpful posts, and answers. It helps others to find relevant posts to the same question. Milan Das

    Monday, July 27, 2015 1:13 PM
  •  

    Milan- Here is my scenario:

    1. SSRS installed on SharePoint mode

    2. RS Addin was failing now it is installed properly.

    3. Web.Config still missing the items and it is updated now with correct items and doing an app pool reset.

    Error-Getting the error 404 forbidden when I click on the Report builder option on the ribbon under the New menu.

    "

    This error (HTTP 404 Not Found) means that Internet Explorer was able to connect to the website, but the page you wanted was not found. It’s possible that the webpage is temporarily unavailable. Alternatively, the website might have changed or removed the webpage.

    For more information about HTTP errors, see Help."

    Appreciate any help in this behalf

    Monday, July 27, 2015 2:21 PM
  • Hey Sakti,

    This seems to be an issue with SSRS in sharepoint mode.Please try the workaround in the below link

    https://social.msdn.microsoft.com/Forums/sqlserver/en-US/78a93ce4-b230-4c36-ace8-6663dbdf9e8e/sql-server-2012-reporting-services-report-builder-clickonce-in-sharepoint-integrated-mode?forum=sqlreportingservices


    Please Dont forget to mark helpful posts, and answers. It helps others to find relevant posts to the same question. Milan Das

    Monday, July 27, 2015 2:53 PM
  • Hi,

    I could able to resolve the "404 -Forbidden Error" on my case scenario.

    Following items were missing in the GAC (C:\windows\assembly) in WFE and I had to re run the "ReportViewer.msi" and the following items are now seen in the GAC.

    Microsoft.ReportViewer.Common
    Microsoft.ReportViewer.DataVisualization
    Microsoft.ReportViewer.Design
    Microsoft.ReportViewer.ProcessingObjectModel
    Microsoft.ReportViewer.WebDesign
    Microsoft.ReportViewer.WebForms
    Microsoft.ReportViewer.WinForms

    Note- You may face issue while running "ReportViewer.msi" if Microsoft System CLR Types for Microsoft SQL Server 2012 is not installed. You can down load the "SQLSysClrTypes" and then install install the "ReportViewer.msi"

    Regards

    Sakti

    Tuesday, July 28, 2015 11:24 AM