none
SQL Server 2014 Linked Server error RRS feed

  • Question

  • The linked server is a SAGE 100 database (MAS90). It has been working for a year. The remote server was moved to a new location. Same server, but new IP address. The OBDC DSN tests successful. But any attempt to get the linked server to work results in Error 7303

    An exception occurred while executing a Transact-SQL statement or batch. (Microsoft.SqlServer.ConnectionInfo)

    ------------------------------

    Cannot initialize the data source object of OLE DB provider "MSDASQL" for linked server "SAGEDATA".
    OLE DB provider "MSDASQL" for linked server "SAGEDATA" returned message "[Microsoft][ODBC Driver Manager] Driver's SQLSetConnectAttr failed".
    OLE DB provider "MSDASQL" for linked server "SAGEDATA" returned message "[ProvideX][ODBC Driver][ISAM]ISAM communication error". (Microsoft SQL Server, Error: 7303)

    -----------------------------

    Tuesday, June 25, 2019 1:24 AM

All replies

  • Hi Arrow483,

    According to your error message, this error might be related that the TCP port number is either not known, or is not the correct port number, or is blocked by a firewall.

     

    There is a professional document about Troubleshoot Connecting to the SQL Server Database Engine, and you can refer it: https://docs.microsoft.com/en-us/sql/database-engine/configure-windows/troubleshoot-connecting-to-the-sql-server-database-engine?view=sql-server-2017

     

    The possible reasons are described below, please check them.

    1) MSSQL Server is not started.

    2) Firewall is blocking port 1433. TCP port 1433 is usually the port used by the Database Engine. Only one instance of SQL Server can use a port, so if there is more than one instance of SQL Server installed, some instances must use other port numbers.

    3) TCP/IP protocol is disabled for MSSQL protocols.

    4) Make sure your database engine is configured to accept remote connections.

    5) If you are using a named SQL Server instance, make sure you are using that instance name in your connection strings.

    6) Make sure your login account has access permission on the database you used during login.

     

    Hope it will help you.

     

    Best Regards,

    Rachel


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Tuesday, June 25, 2019 7:00 AM
  • Thanks for the response, but his does not apply.  The target server is NOT a SQL server, so I cannot follow these  steps.  The configuration was working, so I should have all the right drivers, just the IP has changed.  The DSN does work.   I am checking firewall rules to see if they have changed.
    Tuesday, June 25, 2019 11:46 AM
  • Hi Arrow483,

     

    We will wait for your check result and update information.  If you have solved your issue ,please kindly mark the helpful replies as answers. By doing so, it will benefit all community members who are having this similar issue.  Your contribution is highly appreciated.

     

    Best Regards,

    Rachel


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, June 26, 2019 9:13 AM