Ascmd: Execution failed: Exception of type 'System.OutOfMemoryException' was thrown.


  • when i execute a mdx-command via ascmd.exe on a very large cube, i'll get the following error message:

    Ascmd: Execution failed: Exception of type 'System.OutOfMemoryException' was thrown.

    what's the reason for this behaviour?

    • Edited by gesys Friday, June 15, 2012 12:03 PM
    Friday, June 15, 2012 8:50 AM

All replies

  • Hi Gesys,

    Try to Execute the same MDX Query from SSMS(Management studio). Let me know you are getting the same error or else from SSMS.

    Then try to execute the Simple MDX from ASCMD Utility.

    Suhas Kudekar

    Mark as Answer if this resolves your problem or "Vote as Helpful" if you find it helpful.

    My Blog
    Follow @SuhasKudekar

    Friday, June 15, 2012 1:46 PM
  • hi suhas!

    thx for your reply, i already executed the mdx query from ssms. i'll get the same error

    what i wanna do next is to compile the ascmd.exe in a 64-bit environment, because the result set is really big

    do u think it would help or ist this error fired by the analysis server itself?


    Tuesday, June 19, 2012 9:20 AM
  • dear all!

    in the meantime i have compiled ascmd on 64bit. now i'm getting the error after 4gb memory usage!

    any ideas?


    Monday, June 25, 2012 10:43 AM