none
[SOLVED]error while .csv import to MS SQL Server 2014 RRS feed

  • Question

  • Hi,

    I've got an issue here while importing a .csv file to MS SQL Server 2014: I want to transfer data from an Ecxel worksheet (MS Excel 2010) to an SQL database. The worksheet consists of 2 tables, so I safed them separately to 2 .csv files. Import of the first was easy as pie, no troubles here. But unlike the second file: although identical in structure and from the same source, it always brought only an error (original in German, my translation: 'Error 0xc02020a1: 1-data flow task: error during data conversion.' and later 'Error 0xc0047038: 1-data flow task: SSIS-Errorcode 'DTS_E_PRIMEOUTPUTFAILED'.' After that, I end up with column names, but no data. In the preview everything looked fine, but no matter what separator I try or which program, I always get the same error. Even changing the codepade won't help, although the first error points to that.

    Any ideas where I can look for an solution?

    With kind regards, Markus


    Tuesday, June 18, 2019 12:33 PM

All replies

  • Oh, what a shame: it was rather easy - all I had to do was expanding the width of the data column, aaand: it works! So it could be marked as [SOLVED]...
    Tuesday, June 18, 2019 12:59 PM
  • The Import/Export wizard estimates the data types by reading the first 100 rows and then in row 101 comes data with a larger size, the Import fails, so you have to manually modify data type & size.

    Olaf Helper

    [ Blog] [ Xing] [ MVP]

    Tuesday, June 18, 2019 1:22 PM