Install SQL Server 2012 on Windows 8 (X64)


  • I'm trying to install SQL Server 2012 (X64) on Windows 8 but it fails the configuration check with a claim that the account doesn't have administrator privileges on the machine.  The log shows that the administrator check was failed because sqlsccn.dll couldn't be found.  I used control panel to ensure that .net fwk 3.5 was installed (all components), forced updates until no more could be found, ran the .Net Framework repair tool released on 18.10.2012,  rebooted, looked for updates again (none found) and retried the install.  It still gives the same failure, and the log still shows that the cause is that that sqlsccn.dll can't be found.

    Does the fwk repair tool actually work on Windows 8? (it claimed to have worked when I ran it, but maybe it just thought it did) - if not, is there a version that does work on windows 8? 

    Is the missing dll part of the .net framework, or something else?  Whatever it is, how can I acquire it and install it on a windows 8 (X64) machine?

    Friday, May 17, 2013 1:32 AM


All replies