none
An Exception occured while enqueueing a message in the target queue. Error 15404....

    Question

  • 2010-06-30 11:40:01.94 spid18s     An exception occurred while enqueueing a message in the target queue. Error: 15404, State: 19. Could not obtain information about Windows NT group/user 'DOMAIN\SomeAdminAccount', error code 0x5.
    2010-06-30 11:40:05.93 spid18s     Error: 28005, Severity: 16, State: 2.

    The above error keeps repeating every 5 seconds in my error log. (C:\Program Files\M$ SQL Server\MSSQL10.SERVERINSTANCE\MSSQL\Log\ERRORLOG.

    It doesn't break anything but its filling up my error log. What gives with the above code? I've tried everything - i've addeed the user object to Pre-Windows 2000 Active Directory, i gave it Read Group Permissions and Read Group PermissionsSAM, i even gave it super high level acces in the administration groups. But still, no luck... Whats up with this admin account?

    Searchin the web has given no good results.

     

    Wednesday, June 30, 2010 9:41 PM

Answers

All replies

  • Can you check if the user which is used to run the agent job has the db_owner permission!!
    Hemantgiri S. Goswami | http://www.sql-server-citation.com/ | http://www.surat-user-group.org/ -- Surat SQL Server User Group
    Thursday, July 01, 2010 10:28 AM
    Moderator
  • Yep, the login user DOMAIN\SomeAdminAccount has db_owner permission on all databases in my sql environment. I'll keep looking for an answer...

     

    Thanks for the input though! Most appreciated! :)

    Thursday, July 01, 2010 1:25 PM
  • I even tried doing this: http://support.microsoft.com/kb/938994 and stopping the SQL Agent Service and it still reports the error....

     

    Thursday, July 01, 2010 2:14 PM
  • Change the job owner to be the sa account.

    The problem is SQL server can't authenticate the job owner.


    looking for a book on SQL Server 2008 Administration? http://www.amazon.com/Microsoft-Server-2008-Management-Administration/dp/067233044X looking for a book on SQL Server 2008 Full-Text Search? http://www.amazon.com/Pro-Full-Text-Search-Server-2008/dp/1430215941
    Thursday, July 01, 2010 2:28 PM
    Moderator
  • Short Version: I'd like to change the job owner -- how do i go about doing this??

    Long Version: I believe the job was started initially by my SharePoint 2010 installation. I believe that it continues to run until it succeeds. How can i see a list of jobs so that i can identify which job is giving this error and how to stop it and change its owner?

     

    Thanks again!

     

    Thursday, July 01, 2010 2:36 PM
  • Thursday, July 01, 2010 2:44 PM
  • Issue has been solved:

    The domain/superadminaccount had lost its identity -somehow- with my sharepoint 2010 installation. Using sp_changedbowner and the following link http://social.msdn.microsoft.com/forums/en-US/sqlservicebroker/thread/28699c94-4d1b-43f2-bcfb-a95152ca226b/ - helped solved my problem. 

     

    Looks like it was just SQL server trying to find out a domain account so i switched everything to a local account and its working fine...

     

    Thanks all for your help!

    • Marked as answer by SamK9 Friday, July 02, 2010 2:04 PM
    Friday, July 02, 2010 2:04 PM
  • hi,

    i have the same error.

    i have changed some services from the sql to a local admin account.

    but i still recieve the errors.

    witch services hvae you changed?

    regards

    Friday, November 05, 2010 8:07 AM
  • I solved this by adding my SQL Server service account to the AD "BuiltIn/Pre-Windows 2000 Compatible Access" security group.

     

     

    Monday, November 29, 2010 9:22 PM
  • I've also run into this issue.

    I solved it the other way around. that is, instead of running the service under a local admin account, i've changed it to run under a domain account. Now it is able to authenticate other domain users as well.

     

    Regards,

    Herre

    Monday, February 28, 2011 3:10 PM
  • We solved this problem by changing the Service Account for the SQL Server instance from NT Authority\NetworkService to a domain account and then back to NT Authority\NetworkService. 
    Thursday, August 09, 2012 2:05 PM
  • Using a sharepoint 2010 installation with Sql Server 2012 and having a FARM installation (hence a domain account), the solution above worked for me. Namely, I changed the dbowner of every database to 'sa'

    Tuesday, October 23, 2012 9:57 PM
  • Hello SamK9,

    Did you use as local account the "NT Authority\Local Service" account?

    Wednesday, December 05, 2012 8:35 AM