none
[DBNETLIB][ConnectionOpen (SECDoClientHandshake()).]SSL Security error. RRS feed

  • Question

  • While connecting SQL server(Version 2016) from application server to configure the application, the below error is occuring.
    This SQL server instance is cluster instance(2 Node cluster). 

    [DBNETLIB][ConnectionOpen (SECDoClientHandshake()).]SSL Security error.

    TLS1.0 is disabled due to security reasons.TLS1.1 and TLS 1.2 is enabled on the servers. 

    Any one call tell how to fix the issue?
    Friday, August 2, 2019 12:06 PM

Answers

  • Hi Vigneshvp,

    Could you try to enable TLS1.0 to see if the error is gone and disable it after you completed the task? Please refer to [DBNETLIB] [ConnectionOpen (SECDoClientHandshake()).] SSL Security Error – How to Resolve.

    Best regards,
    Cathy Ji

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to  MSDN Support, feel free to contact MSDNFSF@microsoft.com

    • Marked as answer by Vigneshvp Monday, August 5, 2019 1:17 PM
    Monday, August 5, 2019 9:09 AM
  • After enabling TLS1.0 , the issue got resolved. Thank you.
    • Marked as answer by Vigneshvp Monday, August 5, 2019 1:26 PM
    Monday, August 5, 2019 1:18 PM

All replies

  • Hi Vigneshvp,

    Could you try to enable TLS1.0 to see if the error is gone and disable it after you completed the task? Please refer to [DBNETLIB] [ConnectionOpen (SECDoClientHandshake()).] SSL Security Error – How to Resolve.

    Best regards,
    Cathy Ji

    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to  MSDN Support, feel free to contact MSDNFSF@microsoft.com

    • Marked as answer by Vigneshvp Monday, August 5, 2019 1:17 PM
    Monday, August 5, 2019 9:09 AM
  • After enabling TLS1.0 , the issue got resolved. Thank you.
    • Marked as answer by Vigneshvp Monday, August 5, 2019 1:26 PM
    Monday, August 5, 2019 1:18 PM
  • Hi Cathy,

    May i know the reason why connectivity is not established in TLS1.2? Could you please give the reason?

    Friday, August 9, 2019 8:12 AM