none
Cannot distribute package to DP because DistMgr is trying to delete it. RRS feed

  • Question

  • A Software Updates Deployment Package is distributed to the "All-DP-Group", which contains all our DPs.

     

    Recently I went into the Deployment Package properties and removed Bad-DP from the list on the Content Locations tab. "Bad-DP" is the name for the DP that is causing me problems now. Apparently this is bad practice. I know this now :)

     

    Now I want to Distribute the Deployment Package back to Bad-DP. I do the following:

     

    In admin console, go to: Deployment Package > Distribute Content wizard. When I Add > Distribution Point, the displayed list shows only Bad-DP. Makes sense as it’s the only one I removed from the list. I tick the box and complete the wizard. I then go to Content Locations for the Deployment Package properties and Bad-DP is missing from the list.

     

    I check distmgr.log:

     

    Start deleting package [MyDeploymentPackage] from server ["Display=\\[Bad-DP.fqdn]\"]MSWNET:["SMS_SITE=PRI"]\\[Bad-DP.fqdn]\...        SMS_DISTRIBUTION_MANAGER        28/07/2017 9:22:33 AM        4336 (0x10F0)
    Created DP processing thread 14728 for removal of package [MyDeploymentPackage] on server ["Display=\\[Bad-DP.fqdn]\"]MSWNET:["SMS_SITE=PRI"]\\[Bad-DP.fqdn]\        SMS_DISTRIBUTION_MANAGER        28/07/2017 9:22:33 AM        4336 (0x10F0)
    Attempting to remove package [MyDeploymentPackage] from distribution point ["Display=\\[Bad-DP.fqdn]\"]MSWNET:["SMS_SITE=PRI"]\\[Bad-DP.fqdn]\        SMS_DISTRIBUTION_MANAGER        28/07/2017 9:22:33 AM        14728 (0x3988)
    ["Display=\\[Bad-DP.fqdn]\"]MSWNET:["SMS_SITE=PRI"]\\[Bad-DP.fqdn]\ doesn't have the package installed yet as no pkgstatus entry found        SMS_DISTRIBUTION_MANAGER        28/07/2017 9:22:33 AM        14728 (0x3988)
    Successfully removed the package [MyDeploymentPackage] from server ["Display=\\[Bad-DP.fqdn]\"]MSWNET:["SMS_SITE=PRI"]\\[Bad-DP.fqdn]\        SMS_DISTRIBUTION_MANAGER        28/07/2017 9:22:33 AM        14728 (0x3988)
    STATMSG: ID=2331 SEV=I LEV=M SOURCE="SMS Server" COMP="SMS_DISTRIBUTION_MANAGER" SYS=[PrimarySiteServer.fqdn] SITE=PRI PID=14620 TID=14728 GMTDATE=Fri Jul 28 01:22:33.133 2017 ISTR0="[MyDeploymentPackage]" ISTR1="["Display=\\[Bad-DP.fqdn]\"]MSWNET:["SMS_SITE=PRI"]\\[Bad-DP.fqdn]\" ISTR2="" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=2 AID0=400 AVAL0="[MyDeploymentPackage]" AID1=404 AVAL1="["Display=\\[Bad-DP.fqdn]\"]MSWNET:["SMS_SITE=PRI"]\\[Bad-DP.fqdn]\"        SMS_DISTRIBUTION_MANAGER        28/07/2017 9:22:33 AM        14728 (0x3988)

    This above log snippet re-appears every time the package is being processed by distmgr. For example, another DP has insufficient space and therefore this thread retries until it hits the limit of retries. Each time it retries the above snippet appears.

    • If I repeat the Distribute Content wizard, for the package, Bad-DP appears in the list again as if it were never added.
    • The Distribution Point Status summary pie chart shows n-1 servers, where n is the number of servers in my All-DP-Group.
    • I tried waiting one day. Eventually package processing thread for the package reaches our specified timeout and stops retrying.
    • I created a new Test-DP-Group and added Bad-DP and Good-DP that is a DP which contains the content and is correctly reporting it in the console. I then Distribute Content for the Deployment Package to Test-DP-Group and confirm that in the Test-DP-Group Content Location properties the package is listed. Distmgr.log shows same behavior: The above log snippet re-appears.
    • Same as above but tried "redistribute" action instead. The above log snippet re-appears.
    • I tried deleting SMS_DistributionPoint WHERE SiteCode='PRI' AND PackageID='MyDeploymentPackage'. There was no existing object for Bad-DP.
     

    I read the (excellent) article: https://support.microsoft.com/en-us/help/4000401/content-distribution-in-mcm and with its guidance traced through the log files. When I look at the PkgServers table filtered to my Package:

    SELECT * FROM PkgServers WHERE PkgID = 'MyDeploymentPackage'

    I see that all rows have an action of 0 apart from Bad-DP which has an action of 3. I assume 3 means remove.

    At this point I'm thinking that to fix it I need to either create a PkgStatus entry for the package, or delete or change the Action for the entry in the PkgServers table, but I've stopped because modifying the DB directly puts you in an unsupported state.

    Friday, July 28, 2017 1:50 AM

All replies

  • Hi, 

    Yes, as you said, directly modify Configuration Manager DB is not supported. So please don't modify it unless with the help of Microsoft Support engineer.

    When a new distribution point is added to a DP group, it receives all content that has been previously distributed to the group. So please try to remove the 'Bad-DP' from 'All DP Group', after hours, add it back to the Group to see if this helps. 


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Saturday, July 29, 2017 12:55 AM
    Moderator
  • I tried this and it did not fix the issue.

    The package re-processed and the same delete messages appeared in distmgr.log.

    Monday, July 31, 2017 1:20 AM
  • I am having this exact issue, including the "Apparently this is bad practice.  Now I know" bit.

    I have a Deployment Package that targets N-1 servers because I deleted a DP from the Content Locations tab of the Deployment Package (WHY does this button EXIST?).  After waiting for the retry period to time out, if I distribute that deployment package to the DP again, SCCM will try to distribute it - briefly I caught the content in the DP's content tab under Administration!  But the package is rapidly deleted. 

    Trying Update Distribution Points provides identical results.  Removing and re-adding the DP To the DP group targeted does not fix, nor does creating a new DP group and targeting that group with a Distribute or Update Distribution Points fix it.

    Anyone ever come up with a solution?

    Wednesday, January 24, 2018 12:02 AM
  • I actually am posting my solution, although I admit I do not know why this solution worked.

    I waited a week before trying to Distribute the deployment package again - and as before, it appeared.  But, it stayed, and is still present on the DP the next day, and is now listed in the number of targeted servers for that deployment package (now N instead of N-1). 

    My assumption is that at some point in time or on some trigger, the delete request goes away, so that the next time the distribution happens, it is successful.  I made no other changes.

    Previously I had waited as long as three days.  This time it included a weekend, and we did reboot our SQL cluster over that weekend.  Maybe that fixed it?  I can't say.  but it is good to know that there is some built in method by which the delete request seems to go away.

    If anyone has an idea why it worked now, but not before, I'd be really interested.

    • Proposed as answer by Ryan Kolter Monday, May 21, 2018 5:21 PM
    Wednesday, January 24, 2018 3:19 PM
  • Hello,

    we are experiencing the same Problem. is there any Workaround?

    Best Regards

    Robert

    Thursday, July 5, 2018 12:39 PM
  • I am seeing this in Current Branch 1810 with all Hotfixes and Rollups Installed. It just sits there and loops. Nasty Bug. it is doing this for packages that were Removed and then redistributed. The Query above does show it. But I won't modify the table.

    David Baur

    Friday, May 3, 2019 2:09 PM
  • Hello together,

    any updates here? I experiening the issue with CB 1906.

    Thank you in advance & Best Regards
    Christoph

    Wednesday, January 22, 2020 4:43 PM