none
[80244007] Sync of Drivers failed (Software succeeded) RRS feed

  • Question

  • Hey i have had no end of problems with my WSUS / sccm installation in regards to patch management.

    The root of the problem appears to have been started by installing the dell third party catalog for software updates. It caused all sorts of problems over the last year. I thought I had them all solved, but trying to push feature update (1903) to clients, i have hit a stuck place. This thread will document the progress.

    Windows Update log error

    So firstly, I examine the logs for windows update to see whats up with my feature update. I also notice (from the "check for updates" widget in windows) that it has not successfully downloaded updates in months. The only error i see is an error like:

    2020/01/21 09:14:03.0098946 13648 9820  ProtocolTalker  *FAILED* [80244007] Sync of Drivers failed (Software succeeded)
    

    The complete error chain from windows update log:

    2020/01/21 09:14:03.0095289 13648 9820  WebServices     WS error: The body of the received message contained a fault.
    2020/01/21 09:14:03.0095321 13648 9820  WebServices     WS error: Fault occurred
    2020/01/21 09:14:03.0095346 13648 9820  WebServices     WS Error code: Server
    2020/01/21 09:14:03.0095911 13648 9820  WebServices     WS error: <detail><ErrorCode>InternalServerError</ErrorCode><Message></Message><ID>da826afe-e690-420a-a752-e48af7fce27c</ID><Method>http://www.microsoft.com/SoftwareDistribution/Server/ClientWebService/SyncUpdates"</Method></detail>"
    2020/01/21 09:14:03.0098805 13648 9820  ProtocolTalker  *FAILED* [80244007] SyncUpdates_WithRecovery failed
    2020/01/21 09:14:03.0098861 13648 9820  IdleTimer       WU operation (CAgentProtocolTalker::SyncUpdates_WithRecover, operation # 13) stopped; does use network; is at background priority
    2020/01/21 09:14:03.0098905 13648 9820  ProtocolTalker  SyncUpdates round trips: 2
    2020/01/21 09:14:03.0098946 13648 9820  ProtocolTalker  *FAILED* [80244007] Sync of Drivers failed (Software succeeded)
    

    I had disabled the drivers setting in WSUS. We don't deploy drivers this way and so I thought it was safe to disable. I have now re-enabled it and have initiated a wsus sync task to sync them back up. I figure that i can just disable in the software update point. My ADR's also do not include drivers. I wonder if this was the cause of the issue...

    I had run some cleaning scripts to try and clean up wsus as well in dec, so i was hoping to keep the drivers out of there, but if it breaks everything then i am putting them back now.

    Will post back with updates as they occur till the problem is solved.

    Tuesday, January 21, 2020 6:50 PM

All replies