none
Processing error after partition creation for a SSAS Tabular model with AMO

    Domanda

  • Hi,

    in my script task of a pkg I'm using AMO to create and process SSAS Tabular partition. I can create a partition successfully, but then as the next step I write

    MyPartition.Process(ProcessType.ProcessDefault) or My_Partition.Process(ProcessType.ProcessAdd) raising an exception.

    Any suggests to me to solve this issue, please? Thanks

    giovedì 21 febbraio 2013 17:02

Risposte

  • Ok, I solved to specify my domain credentials for the dwh connection inside SSAS Tabular database on SSAS Tabular instance.

    Before I've tried to follow this link: http://aniruddhathengadi.blogspot.ca/2012/12/ssas-tabular-with-error-ole-db-or-odbc.html

    adding the NT Service\MSOLAP$SQL2012TABMODE login to the SQL Server 2012 instance and assigning it to my dwh as db_owner. The NT Service\MSOLAP$SQL2012TABMODE is the running account of my SSAS service. In the dwh connection of my SSAS Tabular db was specified ImpersonateServiceAccount as ImpersonationInfo.

    Now, I've ImpersonateAccount as ImpersonationInfo and my domain credentials.

    It shoul be interesting to run the process also with the running account of SSAS service.

    Thanks

    venerdì 22 febbraio 2013 12:17

Tutte le risposte

  • Using MyPartition.Process(ProcessType.ProcessDefault) the debug shows this message:

    OLE DB or ODBC error: Login failed for user 'my_domain\SQL2012$'.; 28000.
    A connection could not be made to the data source with the DataSourceID of '18123cf5-24d7-40fa-ad3b-3c0ba5efdf11', Name of 'SqlServer SQL2012 my_dwh'.
    An error occurred while processing the partition 'my_Fact_201301' in table 'my_Fact_09bd1961-07d0-49e4-b3b5-0077565e2b64'.
    The current operation was cancelled because another operation in the transaction failed.

    Any suggests to me, please?

    Thanks

    venerdì 22 febbraio 2013 11:17
  • Ok, I solved to specify my domain credentials for the dwh connection inside SSAS Tabular database on SSAS Tabular instance.

    Before I've tried to follow this link: http://aniruddhathengadi.blogspot.ca/2012/12/ssas-tabular-with-error-ole-db-or-odbc.html

    adding the NT Service\MSOLAP$SQL2012TABMODE login to the SQL Server 2012 instance and assigning it to my dwh as db_owner. The NT Service\MSOLAP$SQL2012TABMODE is the running account of my SSAS service. In the dwh connection of my SSAS Tabular db was specified ImpersonateServiceAccount as ImpersonationInfo.

    Now, I've ImpersonateAccount as ImpersonationInfo and my domain credentials.

    It shoul be interesting to run the process also with the running account of SSAS service.

    Thanks

    venerdì 22 febbraio 2013 12:17