none
Erro no join da replica no AlwaysOn AG RRS feed

  • Pergunta

  • Pessoal, estou com o erro abaixo. 

    Ao tentar fazer o join do servidor no AG dar o erro abaixo:

    ALTER AVAILABILITY GROUP [AG-EMPRESA] JOIN;
    GO

    Msg 41158, Level 16, State 3, Line 3
    Failed to join local availability replica to availability group 'AG-EMPRESA'.  The operation encountered SQL Server error 41106 and has been rolled back.  Check the SQL Server error log for more details.  When the cause of the error has been resolved, retry the ALTER AVAILABILITY GROUP JOIN command.

    Tentar configurar o AG e no momento de fazer o join apresentou também o erro abaixo:

    O que poderia estar acontecendo de errado? Configurei o banco no secundário fazendo o restore bak full, diff e log deixando pronto pra ser replicado, porém creio que não justifica do servidor secundário manter desconectado. As contas  de domínio configuradas nos serviços do SQL Server dos dois servidores estão com permissões de connect nos endpoints. 

    Tem o seguinte erro no manager cluster:

    The computer object associated with cluster network name resource '' could not be updated.

    The text for the associated error code is: Unable to protect the Virtual Computer Object (VCO) from accidental deletion
     
    The cluster identity 'CLUSTER-EMPRESA$' may lack permissions required to update the object. Please work with your domain administrator to ensure that the cluster identity can update computer objects in the domain.

    Agradeço desde já!


    quinta-feira, 25 de julho de 2019 01:18

Respostas

  • Jerfeson,

    O serviço de DNS esta rodando? 

    O que esta sendo registrado no Event Viewer relacionado ao Windows Server Cluster?

    Você já tentou reparar a interface de rede deste nó de réplica no Windows Server Cluster?

    Veja se este link te ajuda: http://technet.microsoft.com/en-us/library/dn466519.aspx


    Pedro Antonio Galvão Junior [MVP | MCC | MSTC | MIE | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados Relacional e Data Warehouse | Professor Universitário | @JuniorGalvaoMVP | http://pedrogalvaojunior.wordpress.com]

    quinta-feira, 25 de julho de 2019 16:49
    Moderador

Todas as Respostas

  • Jerfeson,

    O serviço de DNS esta rodando? 

    O que esta sendo registrado no Event Viewer relacionado ao Windows Server Cluster?

    Você já tentou reparar a interface de rede deste nó de réplica no Windows Server Cluster?

    Veja se este link te ajuda: http://technet.microsoft.com/en-us/library/dn466519.aspx


    Pedro Antonio Galvão Junior [MVP | MCC | MSTC | MIE | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados Relacional e Data Warehouse | Professor Universitário | @JuniorGalvaoMVP | http://pedrogalvaojunior.wordpress.com]

    quinta-feira, 25 de julho de 2019 16:49
    Moderador
  • Grande Galvão, obrigado pela dica e foi justamente nesse link que conseguimos solucionar o problema, porém o nosso amigo Edvaldo Castro nos deu a dica no grupo que participamos. 

    Abraços!

    quinta-feira, 25 de julho de 2019 21:23
  • Jerfeson,

    Ok, obrigado pelo retorno, opa, manda uma abraço para o Edvaldo.

    Por gentileza, mesmo assim, marque a resposta se ela te ajudou.


    Pedro Antonio Galvão Junior [MVP | MCC | MSTC | MIE | Microsoft Evangelist | Microsoft Partner | Engenheiro de Softwares | Especialista em Banco de Dados Relacional e Data Warehouse | Professor Universitário | @JuniorGalvaoMVP | http://pedrogalvaojunior.wordpress.com]

    quinta-feira, 25 de julho de 2019 22:08
    Moderador