none
SCCM reporting not working on W2K8 R2 64-bit

    Question

  • Hi,

    I have SCCM installed on a single server, running W2K8 R2 64-bit.  Everything is working (discovery, client deployment, software deployment) except reporting.

    I have installed a reporting point, have added my users to the "SMS Reporting Users" group, given the users read permissions on the Reporting object class in the console and have even set a higher ASP buffer limit (as per directions in other postings) for the smsreporting virtual directory in IIS (7.5).  Nothing seems to work.

    On the server, when browsing the URL using http://localhost/SMSReporting_MySiteCode the basic page displays, but in the left hand side I get an error message "An error occurred on the server when processing the URL. Please contact the system administrator."  Clicking on the IE "error on page" icon reveals:

      Webpage error details

      User Agent: Mozilla/4.0 (compatible; MSIE 8.0; Windows NT 6.1; WOW64; Trident/4.0; SLCC2; .NET CLR 2.0.50727; .NET CLR 3.5.30729; .NET CLR 3.0.30729)
      Timestamp: Tue, 9 Feb 2010 00:02:25 UTC


      Message: Object required: 'XMLReports'
      Line: 894
      Char: 2
      Code: 0
      URI: http://localhost/smsreporting_MySiteCode/ReportsNav.asp?ReportID=&DashboardID=&ShowTree=True


    When browsing from another machine, going to http://MyServerName/smsreporting_MySiteCode, and entering the credentials of my user account (added to the "SMS Reporting Users" group, which also happens to be a domain admin and an administrator of the SCCM server) I simply get:  You do not have permission to view this directory or page.

    Removed and added the reporting point role a couple of times as well and that does not work.  RSetup.log shows it installed correctly (returned 0).

    Any ideas what to try next?

    Thanks,
    Richard
    Tuesday, February 09, 2010 12:09 AM

Answers

  • Have you checked your IIS 7.5 role features? Reporting server requires that Application Development --> ASP is enabled. ASP is not required for MP or BITS enabled DP roles, so you might have missed that.

    • Marked as answer by Eric Zhang CHN Thursday, February 25, 2010 9:35 AM
    Wednesday, February 10, 2010 8:30 AM

All replies

  • Hi Richard,

    Could you please check the proxy setting on IE, and bypass this computer name, then acess the URL again and check whether SCCM report ing is working.
    Tuesday, February 09, 2010 10:48 AM
  • Hi Eric,

    I had no proxy settings but your comment made me think of using the IP address instead of the host name.  If I put in the IP address, it works.  If I use the hostname, either alone or with the FQDN, it does not work.  I get "You do not have permission to view this directory or page".  

    I have checked that our DNS is setup correctly - it is.  The hostname of the SCCM server has the correct IP address entry.

    So why if I use the hostname do I get "You do not have permission to view this directory or page".

    Thanks,
    Richard
    Tuesday, February 09, 2010 9:07 PM
  • Hi,

    When you try to browsing the URL, the error that you receive is exactly "HTTP Error 401.1" or "HTTP Error 401.3" ?

    See :

    HTTP Error 401.1 : http://support.microsoft.com/kb/942044/en-us

    HTTP Error 401.3 http://support.microsoft.com/kb/942042/en-us


    Thank's.
    Bechir Gharbi. MCSA, MCSE M+S, MCITP Server/Enterprise Administrator, MCT, MCTS ConfigMgr
    Tuesday, February 09, 2010 9:27 PM
  • Hi Bechir,

    It does not have the exact wording to either of those definitions.  It is simply a white page that says:  "You do not have permission to view this directory or page."  

    Closet to the 401.1 wording, but not the same. 

    I looked at the security log on on the server.  When I used the host name in the URL it is trying to use for Kerberos authentication ("Logon Process: Kerberos") , and I see a "Logon" (event 4624) and then immediately a "Logoff" (4634) event.  When I use the IP address it uses NTLM ("Logon Process: NtLmSsp") and I only see a Logon event (4624).

    I wonder why it is trying to use Kerberos?  Is this the default setup?

    Regards,
    Richard
    Wednesday, February 10, 2010 3:43 AM
  • Have you checked your IIS 7.5 role features? Reporting server requires that Application Development --> ASP is enabled. ASP is not required for MP or BITS enabled DP roles, so you might have missed that.

    • Marked as answer by Eric Zhang CHN Thursday, February 25, 2010 9:35 AM
    Wednesday, February 10, 2010 8:30 AM
  • I have a similar issue when I try to run the reports locally on the server, but if I run the IE as administrator everthing is fine.
    Do I really have to disable the UAC?
    • Proposed as answer by hoobuba Wednesday, May 26, 2010 7:26 PM
    Thursday, April 01, 2010 4:23 PM
  • Sorry I meant to hit reply - anyway - for me the fix was to install Basic and Windows authentication in IIS and  took me about 2 hours to find out...
    Wednesday, May 26, 2010 7:28 PM
  • Where exactly do I put the AD Security group I created to run reports?  I keep looking for configuration settings for security that will enablel  this group to run and view reports and nothing is looking to intuitive.
    Thursday, July 01, 2010 4:19 PM
  • Add it to the local SMS Reporting User group and grant ConfigMgr security rights to run reports.

    Friday, July 02, 2010 6:59 AM
    Moderator
  • This is what worked for me (I'm using SCCM 2007 R2 w/ SP2 running on W2k8R2 server) -

    1.  Open the IIS Manager and go to your SCCM site (mine is Default Web Site) expand that and find "SMSReporting_***"
    2. Double click Authentication under IIS
    3. Click on Windows Authentication and then choose "Providers..." under Actions
    4. Add NTLM if it isn't there and move it to the top.
    5. Click OK
    6. Reboot World Wide Web Publishing Service

    I'm now able to open reports from the SCCM Console that is installed on my Windows 7 client computer.

    • Proposed as answer by Madan Mohan A Wednesday, January 12, 2011 7:16 AM
    Friday, December 10, 2010 6:13 PM
  • This is what worked for me (I'm using SCCM 2007 R2 w/ SP2 running on W2k8R2 server) -

    1.  Open the IIS Manager and go to your SCCM site (mine is Default Web Site) expand that and find "SMSReporting_***"
    2. Double click Authentication under IIS
    3. Click on Windows Authentication and then choose "Providers..." under Actions
    4. Add NTLM if it isn't there and move it to the top.
    5. Click OK
    6. Reboot World Wide Web Publishing Service

    I'm now able to open reports from the SCCM Console that is installed on my Windows 7 client computer.


    Thanks Tyson...you saved my butt.  I had installed WSUS which screwed my reporting up.  I had NTLM but it was not at the top.  Once I moved it to the top, and restarted that service, I was golden.  Thank you much.
    Wednesday, January 12, 2011 3:49 AM
  • Thanks Tyson_M.... it worked.

    mike

    Tuesday, March 22, 2011 6:52 AM
  • This worked for me as well, thank you!
    Friday, April 08, 2011 2:46 PM
  • Cool tnx works like a charm,
    Wednesday, April 27, 2011 12:11 PM
  • Tank you, works fine! Very Helpful.
    Att. Rodrigo Krug
    Friday, August 26, 2011 4:52 PM
  • @Tyson: I had recently installed WSUS on Configuration Manager also, and moving NTLM to the top fixes this issue. Thanks very much. Saved me a lot of time! 
    Kyler
    Tuesday, September 06, 2011 7:36 PM
  • sorted for me as well thanks
    Monday, October 24, 2011 8:08 AM
  • Worked for me as well.

    I'm more curious what caused this to break. We've been running fine for over 2 years and I don't know what changed to suddenly need this fix in the first place. Thanks again for the help!

    Friday, October 05, 2012 7:19 PM
  • Nice solution...

    Abhijit

    • Proposed as answer by Abhijit 19 Friday, January 25, 2013 2:48 PM
    Friday, January 25, 2013 2:48 PM