none
Upgrade from WSUS to SCE 2010 fails, cannot move wsus db RRS feed

  • Question

  • Hi

    I am trying to upgrade a WSUS installation on a Server 2008 R2 machine to System Center Essentials 2010 RC. When I statr the installation, i get an error stating that the installation failed. The system cannot create a folder for backup of WSUS. I have tried to give the Network Service role that runs the SQL Server service accessrights to \wsus folder and \Microsoft SQL Server folders, but I cannot get this upgrade going. Any tips for me? Below is the last part of the log i get after the install fails. Please let me know if more information is needed

    ---------

    12:12:05:PrerequisiteState = Warning
    12:12:05:SQLInstanceName = WSUS-TEST\ESSENTIALS
    12:12:05:sqldbfiles = C:\Program Files\Microsoft SQL Server\MSSQL10.ESSENTIALS\MSSQL\DATA\
    12:12:05:USER = ****
    12:12:05:PASSWORD = Due to data security, we will not print the value of the property bag key PASSWORD
    12:12:05:DOMAIN = ****
    12:12:05:Collection ItemsToInstall (System.Collections.ArrayList):
    12:12:05: [0] = System Center Essentials (Microsoft.SystemCenter.Essentials.SetupFramework.InstallItemsInstallDataItem)
    12:12:05: [1] = Virtualization Management Client (Microsoft.SystemCenter.Essentials.SetupFramework.InstallItemsInstallDataItem)
    12:12:05: [2] = Final Configuration (Microsoft.SystemCenter.Essentials.SetupFramework.InstallItemsInstallDataItem)
    12:12:05:End: Property bag dump.
    12:12:06:LoadQuickFixEngineeringFile: File D:\SCE2010\SCE\Setup\AMD64\qfelist.xaml not found.  We will not apply any QFE's
    12:12:06:Doing Preinstall task for SCE
    12:12:06:SystemCenterEssentialsPreinstallProcessor: WSUS is installed on the internal database.  We will move it to the SCE database server.
    12:12:06:WMI call to Win32_Share.Create() returned 22
    12:12:06:CreateShareForBackup: Failed to create the share for the WSUS backup.: Threw Exception.Type: Microsoft.SystemCenter.Essentials.Configuration.Common.EssentialsShareException, Exception Error Code: 0x80131500, Exception.Message: Failed to create the share.
    12:12:07:StackTrace:   at Microsoft.SystemCenter.Essentials.Configuration.Common.ReadOnlyTemporaryShare..ctor(String shareName)
       at Microsoft.SystemCenter.Essentials.SetupFramework.HelperClasses.MoveUpdateServicesDatabase.CreateShareForBackup.Execute(MoveUpdateServicesDatabaseItem item)
    12:12:07:SystemCenterEssentialsPreinstallProcessor: SUSDB move failed.
    12:12:07:ProcessInstalls: Running the PreprocessDelegate for SCE failed.... This is a fatal item.  Setting rollback.

    Wednesday, February 10, 2010 12:47 PM

Answers

  • Hi

    Thank you for answering, but I found the problem! It seems that a share that the installation was trying to create, was already created on the server. When it tried to recreate it, it failed. I removed the share, and the installation continued as it should.

    Btw, this is an upgrade from WSUS 3.0 to SCE 2010 RC, and now everything seems to be working fine :-)
    Friday, February 12, 2010 9:57 AM

All replies

  • Hi Thomas,


    Only Fresh installation of RC is Supported.

    Please refer the SCE 2010 RC Release Notes,.


    http://social.technet.microsoft.com/Forums/en-US/systemcenteressentials/thread/87805764-8e7a-4638-b35e-14d3d0e10a8b

    Once you have downloaded the RC and extracted the installation image, double click on the SetupSCE.exe and install.

    Note 1: If you currently have the Beta of Essentials 2010 installed you will need to uninstall the Beta before installing the RC.

    Note 2: If you currently use Essentials 2007 you will not be able to upgrade to Essentials 2010 RC.


    Thanks
    Ranjith A
    SCE 2010 TAP Support

    Wednesday, February 10, 2010 9:29 PM
    Moderator
  • Hello Thomas- Can you please provide more details on the scenario you are trying to run? 

    1)Is this fresh SCE 2010 install scenario?

    2) You are trying to upgrade your WSUS installation? What version of WSUS you have on this machine?  WSUS 3.0 SP1 or WSUS 3.0 SP2?
       If WSUS 3.0 SP1, how did you install this on Win2K8R2, as WSUS 3.0 SP1 is not supported on Win2K8R2 unless you have upgrade the OS on the machine

    3) Where is your SUSDB located before SCE install on Windows Internal Database ? or SCE DB? or other remote DB?


    please send us Setup logs to scedata@microsoft.com pointing to this issue.

    Location of log files:
    SetupSCE<#>.log:  %AppData%\Local \SCE\LOGS for Windows Server 2008

    <LocalApplicationData> \SCE\LOGs for Windows Server 2003

    SCESetupWizard.log

    %AppData%\Local \SCE\LOGS for Windows Server 2008

    <LocalApplicationData> \SCE\LOGs for Windows Server 2003

    SCEMSI.log  -same as above location

    WSUSSetup.log  - %temp%

    Please see the below blog for complete list of log files and the location

    http://blogs.technet.com/systemcenteressentials/archive/2009/12/05/essentials-2010-troubleshooting-guide.aspx

    Thursday, February 11, 2010 7:00 PM
  • Hi

    Thank you for answering, but I found the problem! It seems that a share that the installation was trying to create, was already created on the server. When it tried to recreate it, it failed. I removed the share, and the installation continued as it should.

    Btw, this is an upgrade from WSUS 3.0 to SCE 2010 RC, and now everything seems to be working fine :-)
    Friday, February 12, 2010 9:57 AM
  • I experienced this same problem after retrying a previously failed fresh install of SCE 2010 RTM (initial failure was due to the SQL Browser service being disabled). It seems that the rollback at the end of the first failed install did not remove the share, so I had to remove it myself.
    Friday, July 30, 2010 12:41 PM
  • Can you please tell me which share you had to manually remove?

    I am experiencing the same issue with System Center 2010 installation.  Here is my log data:

    05:38:55:SCE - Start
    05:38:55:ApplyQuickFixEngineeringUpdates: Processing pre install data for SCE
    05:38:55:SCE - Doing Preinstall task
    05:38:55:WSUS is installed on the internal database.  We will move it to the Essentials database server.
    05:38:55:WMI call to Win32_Share.Create() returned 22
    05:38:55:CreateShareForBackup: c.: Threw Exception.Type: Microsoft.SystemCenter.Essentials.Configuration.Common.EssentialsShareException, Exception Error Code: 0x80131500, Exception.Message: Failed to create the share.
    05:38:55:StackTrace:   at Microsoft.SystemCenter.Essentials.Configuration.Common.ReadOnlyTemporaryShare..ctor(String shareName)
       at Microsoft.SystemCenter.Essentials.SetupFramework.HelperClasses.MoveUpdateServicesDatabase.CreateShareForBackup.Execute(MoveUpdateServicesDatabaseItem item)
    05:38:55:SUSDB move failed.
    05:38:55:ProcessInstalls: Running the PreprocessDelegate for SCE failed.... This is a fatal item.  Setting rollback.
    05:38:55:VMMCLIENT - Start

     

    Thanks!

    Saturday, April 23, 2011 10:59 PM
  • The share I had to remove was named sceWsusBackupShare, so try that. However, if your experience is anything like mine, you may find that even after removing it it will fail again (with a timeout error). See my post here for my experience in recovering from this and what I had to do to get it to work.
    Sunday, April 24, 2011 9:45 AM