locked
Importing a sealed management pack. RRS feed

  • Question

  •  

     

    Hi,

     Can I import a sealed management pack with the same name but a different version number into SCOM?

    This is what I am trying to accomplish:

    I created a new management pack in SCOM for Web applications.

    I then exported the unsealed management pack, sealed it, deleted the unsealed Management pack in SCOM and imported the sealed management pack.

    Currently, I would like to add more web apps into this sealed management pack. I performed the following:

    Exported the sealed management pack.

    Imported the unsealed management pack into my sandbox environment of SCOM.

    Created my new Web application.

    Exported the unsealed MP.

    Opened the Unseal MP with an XML editor and incremented the version from 1.0.0.0 to 1.0.0.1

    Sealed the management pack.

    I then tried to import the management pack back into my environment, but I received: " Naming Conflict: Cannot import the {my management pack}. A management pack with the same ID {my management pack} currently installed.

    Thanks in advance for your help/George

     

    Thursday, June 3, 2010 6:26 PM

Answers

All replies

  • Yes, you can.  This is called an upgrade.  But you need to reseal it with the same key every time.  If you reseal a MP with a different key, you'll get the errors you're observing above.


    HTH, Jonathan Almquist - MSFT
    Thursday, June 3, 2010 10:39 PM
  • Hi Jonathan,

    I used the same key to reseal it.

    Friday, June 4, 2010 12:13 PM
  • When you import this mp do you get message immediately? or does it recognise you have another version of this mp and you can press upgrade.

    Are you sure you've edited the  manifest and not just a "display string"?

      <Identity>
        <ID>exampleID</ID>
        <Version>1.0.0.1</Version>
      </Identity>


    Rob Korving
    http://jama00.wordpress.com/
    • Proposed as answer by Vivian Xing Tuesday, June 8, 2010 3:18 AM
    Friday, June 4, 2010 2:01 PM
  • Any news on this thread, George?  Otherwise we'll close it.

    There's really not much more to say.  Sealing an updated MP is common and completely supported.  Please refer to this post for a more information.

    http://blogs.technet.com/b/jonathanalmquist/archive/2008/08/19/seal-a-management-pack.aspx


    HTH, Jonathan Almquist - MSFT
    Tuesday, June 8, 2010 3:42 AM
  • Please go ahead and close it.

     

    When I tried re-importing the mp it worked. Not sure why it was failing the 1st time around.

     

    Thanks for your help /George

    Tuesday, June 8, 2010 4:02 PM