none
SCVMM 2012 RTM Setup Fails with Error 1603 on SQLSysClrTypes

    Question

  • After multiple attempts I cannot get SCVMM 2012 RTM to install on my Server 2008 R2 machine.  Error reported by the installation dialog is:

    Installing C:\Downloads\VirtualMachineManager\amd64\setup\msi\DACFramework\1033\SQLSysClrTypes.msi failed with Windows Installer error 1603.See C:\ProgramData\VMMLogs\SQLSysClrTypes.log for more information. After resolving the problem, retry setup.

    Checking the designated logfile reveals:

    Property(S): OriginalDatabase = C:\Downloads\VirtualMachineManager\amd64\setup\msi\DACFramework\1033\SQLSysClrTypes.msi
    Property(S): UILevel = 2
    Property(S): ACTION = INSTALL
    Property(S): ROOTDRIVE = I:\
    Property(S): CostingComplete = 1
    Property(S): OutOfDiskSpace = 0
    Property(S): OutOfNoRbDiskSpace = 0
    Property(S): PrimaryVolumeSpaceAvailable = 0
    Property(S): PrimaryVolumeSpaceRequired = 0
    Property(S): PrimaryVolumeSpaceRemaining = 0
    Property(S): DOTNET20OR30OR35OR40COREPATH = 1
    Property(S): SOURCEDIR = C:\Downloads\VirtualMachineManager\amd64\setup\msi\DACFramework\1033\
    Property(S): SourcedirProduct = {1E6ED082-E32D-4B2B-8B6A-70B094815135}
    MSI (s) (70:E0) [16:59:20:014]: Windows Installer reconfigured the product. Product Name: Microsoft SQL Server System CLR Types (x64). Product Version: 10.50.1750.9. Product Language: 1033. Manufacturer: Microsoft Corporation. Reconfiguration success or error status: 1603.

    MSI (s) (70:E0) [16:59:20:026]: Deferring clean up of packages/files, if any exist
    MSI (s) (70:E0) [16:59:20:026]: MainEngineThread is returning 1603
    MSI (s) (70:0C) [16:59:20:050]: RESTART MANAGER: Session closed.
    MSI (s) (70:0C) [16:59:20:050]: No System Restore sequence number for this installation.
    === Logging stopped: 5/2/2012  16:59:20 ===

    Why is Windows Installer reconfiguring the product?  I specifically unchecked the box in the installation startup screen for "Get the latest updates to Virtual Machine Manager from Microsoft Updates" after the first time I got this failure.  I am starting setup.exe with "Run As Administrator".  Has anybody seen this or have any idea what the issue is?

    Thursday, May 03, 2012 12:57 AM

Answers

  • Go to your "\amd64\Setup\msi\DACFramework\1033" folder, make an extra copy of all 4 files.  Then append "_amd64_enu" to the end of the filename.  EX: You'll have both SQLSysClrTypes.msi, and SQLSysClrTypes_amd64_enu.msi.  Worked for me.  Looks like the installers have a bug.  All 4 of these files are looking for themselves with a _amd64_enu on the end of their filenames.
    • Proposed as answer by B77 Wednesday, May 30, 2012 12:25 AM
    • Marked as answer by M FawziMVP, Moderator Saturday, October 06, 2012 3:13 AM
    Thursday, May 03, 2012 5:55 AM

All replies

  • Go to your "\amd64\Setup\msi\DACFramework\1033" folder, make an extra copy of all 4 files.  Then append "_amd64_enu" to the end of the filename.  EX: You'll have both SQLSysClrTypes.msi, and SQLSysClrTypes_amd64_enu.msi.  Worked for me.  Looks like the installers have a bug.  All 4 of these files are looking for themselves with a _amd64_enu on the end of their filenames.
    • Proposed as answer by B77 Wednesday, May 30, 2012 12:25 AM
    • Marked as answer by M FawziMVP, Moderator Saturday, October 06, 2012 3:13 AM
    Thursday, May 03, 2012 5:55 AM
  • Thanks for that abstrakt, that worked a charm for me..
    Wednesday, May 30, 2012 12:25 AM
  • Worked for me too with sharp version of VMM 2012 downloaded from MS volume licenses. strange they didnt fix this problem in real release.

    Thanx


    Dulv

    Tuesday, October 02, 2012 11:38 AM