none
OS Configuration in template VS OS Configuration in GUST OS Profile

    Question

  • Experts !

    SCVMM 2012 R2 with Windows Server 2012 R2.

    I have the template created which has OS Customization selected while creating the template.

    I have also defined OS Profiles which has the run as account, local admin password and set the attribute DomainJoinOrganizationalUnit as "OU=Group1,OU=Hosting,OU=Servers,DC=domain,DC=com" using powershell.

    Here is the screen shot of the Gust OS Profile.

    If I create a VM using this template along with this OS profile, which setting will get precedence?

    I tried different combination and I always feel that only the configuration on template is getting precedence.

    I started digging into this as I couldn't never get the VM created on the OU configured on OS Profile. Computer was always getting created on the default computers OU. So I tried to change the settings in the template to join into a work-group instead of the domain. So the template is set to "WorkGroup" and the profile is set to "Join to domain" and I see that computer was not joined to the domain and was in the work group.

    Any help much appreciated !

    Cheers


    Optimism is the faith that leads to achievement. Nothing can be done without hope and confidence.


    InsideVirtualization.com


    • Edited by Shabarinath Saturday, February 01, 2014 2:38 PM
    Saturday, February 01, 2014 2:36 PM

Answers

All replies

  • Bump.  Struggling trying to sort out the same here and the TechNet guidance is definitely lacking. Also cannot get a VM to deploy from a Win 7 template without specifying some dummy account for the Administrator Password setting, which is ridiculous. I just want to set the Administrator password...

    Friday, February 14, 2014 10:48 PM
  • This issue is fixed with RU1.

    Cheers !


    Optimism is the faith that leads to achievement. Nothing can be done without hope and confidence.


    InsideVirtualization.com

    • Marked as answer by Shabarinath Friday, February 21, 2014 6:54 PM
    Friday, February 21, 2014 6:54 PM