locked
Another component has already added an HttpSessionState to the context. ERROR RRS feed

  • Question

  • I have installed Sharepoint 2010 on a new server MS Server 2008 R2 64 bit, with SQL Server 2008, the install runs fine all components seem to get created at the end of the install Central Admin tries to fire up but I get this:

    Another component has already added an HttpSessionState to the context. Please make sure only one session state module should be registered.

     

    Troubleshoot issues with Microsoft SharePoint Foundation.

    Correlation ID: be2477c7-7c4c-4b1b-9c02-d072fa2221b9

    Date and Time: 6/22/2010 4:01:19 PM

    I have a ULS Viewer, and the Correlation ID does not even come up. I have read a previous thread that says the Web.Config file may have 2 instances of httpsessionState and that a work around would be to comment the offending one out. My web.config file does not even have this entry. Any Ideas


    the Wobjab
    Tuesday, June 22, 2010 11:24 PM

Answers

  • Hi,

    Try unprovisioning CA and then reprovisioning it with the following commands:

    psconfig -cmd adminvs -unprovision

    psconfig -cmd adminvs -provision -port 8080 -windowsauthprovider onlyusentlm 

     


    Regards, Savoeurn Va Microsoft Online Community Support
    • Marked as answer by Lily Wu Tuesday, June 29, 2010 12:40 PM
    Wednesday, June 23, 2010 8:40 PM

All replies

  • Hi,

    Try unprovisioning CA and then reprovisioning it with the following commands:

    psconfig -cmd adminvs -unprovision

    psconfig -cmd adminvs -provision -port 8080 -windowsauthprovider onlyusentlm 

     


    Regards, Savoeurn Va Microsoft Online Community Support
    • Marked as answer by Lily Wu Tuesday, June 29, 2010 12:40 PM
    Wednesday, June 23, 2010 8:40 PM
  • Savoeurn Va's trick didn't work for me.  I was able to get this working by removing the following line:

    <add name="Session" type="System.Web.SessionState.SessionStateModule" />

    From my central admin web.config (C:\inetpub\wwwroot\wss\VirtualDirectories\45527\web.config).  So the final version looks like this:

     

    <system.webserver>
            ...
            <modules runAllManagedModulesForAllRequests="true">

          <remove name="AnonymousIdentification" />

          <remove name="FileAuthorization" />

          <remove name="Profile" />

          <remove name="WebDAVModule" />

          <remove name="Session" />

          <add name="SPRequestModule" preCondition="integratedMode" type="Microsoft.SharePoint.ApplicationRuntime.SPRequestModule, Microsoft.SharePoint, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />

          <add name="ScriptModule" preCondition="integratedMode" type="System.Web.Handlers.ScriptModule, System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />

          <add name="SharePoint14Module" preCondition="integratedMode" />

          <add name="StateServiceModule" type="Microsoft.Office.Server.Administration.StateModule, Microsoft.Office.Server, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />

          <add name="PublishingHttpModule" type="Microsoft.SharePoint.Publishing.PublishingHttpModule, Microsoft.SharePoint.Publishing, Version=14.0.0.0, Culture=neutral, PublicKeyToken=71e9bce111e9429c" />

          <!-- <add name="Session" type="System.Web.SessionState.SessionStateModule" /> -->

        </modules>



    http://rapidapplicationdevelopment.blogspot.com
    • Proposed as answer by Lee Richardson Monday, August 16, 2010 8:10 PM
    Monday, August 16, 2010 8:05 PM
  • Hi Lee,

     Very good information. It solved the issue and now my central administration is up and running. Thank you very much for your comment. I had been trying to solve this problem since morning. Thanks.

    Please can you help me fix this error too "To use the observer role session state must be enabled for the web application"

    Thank you

    Julady1.

    Tuesday, August 7, 2012 4:22 PM
  • Hey Julady86,

    So glad it helped.  Sorry I can't help with your other issue I've been out of the SharePoint world for too long now.


    http://rapidapplicationdevelopment.blogspot.com

    Wednesday, August 8, 2012 7:10 PM