none
Management pack import slow during install (and after) 2+ mins. avrg.

    Question

  • I just started reinstalling my System Center test-environment@home  with a single dedicated SQL-server. At first when trying to install Service Manager the installation would timeout at the first attempt at importing a management pack (system.library.mp) - it says something like "Setting SDK service account" in the installer, but the install logs told me otherwise.

    After abit of pondering and looking at various blog and forum posts I found that maybe if I upped the default database size from 2000 mb the MP import may just succeed. I set it to 5000 mb and it worked!!!, only to find out that each import would take from on average 2 minutes (never less than 60 seconds and only a very few was in the 4-5 minute range). The installation took many hours to complete, which it did eventually. A quick test shows that creating an (empty) MP in the console ranges between 15 and 25 seconds.
    Creating an incident (or other work item) takes a 2-3 seconds (initial one took around 10 seconds). Opening the form also only takes a few seconds.

    Host:

    Core i5-3350P (@3.1GHz)
    32 GB RAM
    250 GB SSD (contains virtual disks - formatted in 64KB block sizes)

    SQL server guest:

    2 VCPUs
    12 GB RAM (dynamic)
    30 GB disk for DB and log files (also formatted in 64KB block sizes) / OS on seperate drive

    Any suggestions on how to improve this horrible MP import performance?

    Install log here: Dropbox

    Saturday, December 07, 2013 11:32 AM

Answers