none
OSD issue on PXE-T04 and PXE-E36 errors

    Question

  •  

     

    Hi All,  I hope some has seen this problem before and can let me what to check.

    I am doing some testing on SCCM 2007 and installed SCCM 2007 SP1 on Windows 2008 with DC, DHCP and DNS, all on a vpc 2007. Trying to do a PXE boot on a vpc 2007 client, after it gets IP address, it says: 

     

    PXE-T04: Access violation

    PXE-E36: Error received from TFTP server.   

     

    No errors in smspxe.log.  Any suggestions?

     

    Thanks for the help!

     

    Thursday, April 10, 2008 8:26 AM

Answers

  • I got my PXE to work, finally.

     

    I had forgotten about NOT configuring the WDS before installing the PXE role on the SCCM server.

    Here is the list of actions to be taken (Thanks destr0yr_)

     

    1. Remove the SMS PXE role. Look at the PXESetup.log file to verify that the uninstall is complete and successful.
    2. Uninstall the WDS server.
    3. Reboot the machine.
    4. Re-install the WDS server, but “do not configure it”. Do nothing at all other than installing WDS.
    5. Add the SMS PXE role. Look at the PXESetup.log file to verify that the installation is complete and successful.
    6. Add the boot images to the SMS PXE DP share. Look at the distmgr.log file to verify that the replication of the boot image to the DP is complete and successful.
    7. Try booting a PXE client.

     

    Hope this helps someone else.

     

    Wednesday, September 17, 2008 8:27 PM

All replies

  • same error here!

    any suggestions would be appreciated!!

    Wednesday, April 30, 2008 12:32 PM
  •  

     

     

    I'm also running into this issue.

     

    I just recently upgraded a Server 2003 SCCM primary site to Server 2008 and the OSD functionality has stopped working.

     

    When I PXE boot I receive the following:

     

    Code Snippet

    TFTP.

    PXE-T04: Access Violation

    PXE-E36: Error received from TFTP Server.

    PXE-M0F: Exiting Intel Boot Agent.

     

     

     

     

    If I use a Boot disk to try and connect I receive the following:

     

    Code Snippet

    Failed to Run Task Sequence

    An error occurred while retrieving policy for this computer

    (0x80004005) For more information...etc., etc.

     

     

    I have uninstalled the SCCM PXE module, then uninstalled WDS, rebooted reinstalled WDS, configured it, verified that it works, installed the SCCM PXE role, and moved the boot images to the PXEDistribution point.

     

    What I have found is this:

    When WDS is installed but not SCCM PXE, then my computer connects to WDS fine, but has no boot image to use.

    When PXE role is installed but boot images are not pushed to the dist point, then it complains that there is no boot image.

    When I push the boot images out, THEN it gets the Access Violation errors.

     

    I thought it was an ACL issue, so I checked the permissions on the foler.  WDS creates a share called RemoteInstall and the SCCM PXE role creates a share in that directore called SMSPXEBOOT$.  When I tried to open that folder I was told that I didn't have permission (I was signed on as a Domain Admin) so I played with the permissions and finally gave the "everyone" group "Read/Execute" permissions from the RemoteInstall directory down.  That still had no effect.

     

    Anyone have any other ideas?

    Wednesday, September 17, 2008 7:40 PM
  • I got my PXE to work, finally.

     

    I had forgotten about NOT configuring the WDS before installing the PXE role on the SCCM server.

    Here is the list of actions to be taken (Thanks destr0yr_)

     

    1. Remove the SMS PXE role. Look at the PXESetup.log file to verify that the uninstall is complete and successful.
    2. Uninstall the WDS server.
    3. Reboot the machine.
    4. Re-install the WDS server, but “do not configure it”. Do nothing at all other than installing WDS.
    5. Add the SMS PXE role. Look at the PXESetup.log file to verify that the installation is complete and successful.
    6. Add the boot images to the SMS PXE DP share. Look at the distmgr.log file to verify that the replication of the boot image to the DP is complete and successful.
    7. Try booting a PXE client.

     

    Hope this helps someone else.

     

    Wednesday, September 17, 2008 8:27 PM
  • Thanks for sharing...

     

    I just want to let you know I had to do the exact opposite on a few customer systems to get it working... that is actually configure WDS first, and then install the PSP Role... In fact I always get it to work when pre-configuring WDS first Smile

     

    I recommend the following steps...

     

    1. Install WDS, configure it and add a WinPE 2.1 boot image...

    2. Verify that it works (DHCP config, VLAN IP helpers etc.)

    3. Then remove the boot image, and install the PSP Role.

     

    This way you don't have to troubleshoot everything at one time...

    Wednesday, September 17, 2008 8:54 PM
  • hello
    i think this artical is helpful for me.
    plz tell me how to add sms pxe role
    Sunday, September 20, 2009 10:54 AM
  • here you go
    my SCCM step by step Guides > http://www.windows-noob.com/forums/index.php?showtopic=1064
    Sunday, September 20, 2009 2:36 PM
    Moderator
  • Had the exact same problem. I Finally figured out that I needed to change the path (slashes) in DHCP option 067 from \ to /(example: OSchooser\i386\startrom.com to OSchooser/i386/startrom.com). You'll need to restart the dhcp service after making this change.

     

    Scott.

    Monday, April 19, 2010 7:24 AM
  • Had the exact same problem. I Finally figured out that I needed to change the path (slashes) in DHCP option 067 from \ to /(example: OSchooser\i386\startrom.com to OSchooser/i386/startrom.com). You'll need to restart the dhcp service after making this change.

     

    Scott.

    Monday, April 19, 2010 7:24 AM
  • may anybody states why these errors appears other than steps of rebuilding everything from scratch...

     

    appreciate your assistance

    Wednesday, June 16, 2010 11:55 AM
  • most likely it's permissions issues with server 2008 or even UAC,

    My step by step SCCM Guides
    I'm on Twitter > ncbrady
    Wednesday, June 16, 2010 10:38 PM
    Moderator
  • Are this still valid with R2?
    Thursday, June 24, 2010 10:55 PM
  • Do you think wds work different under windows 2008 then it does under windows 2003,. Once you did it this way , did the workstation connected the wds way or the sccm way.
    Tuesday, April 26, 2011 7:27 PM
  • We got rid of the errors by adding System (Read/Write) and Network Service (Read/Write) to the Remote Install directory. Those permissions were missing and adding them got us to the pre-boot folder. 
    Thursday, September 6, 2012 8:50 PM
  • scope options --> option 066 did you enter ip or fqdn?

    had same problem because i entered ip instead of fqdn.


    • Edited by KevinVS01 Saturday, May 16, 2015 11:33 AM
    Saturday, May 16, 2015 11:32 AM