none
Query to remove management group in datawarehouse RRS feed

  • Question

  • Hi

    I have problems with registration/un-registration of data warehouse in from the servicemanager console. I tried to re-register the warehouse and now I'm not able get the connection to work. When I try to add I get error "A management groupe with the same name (xxxx) is already registerted to data warehouse management group XXXX. When I tries to unregistert the warehouse I get error msg "You must first register with a data warehouse installation".

    The connection was working find before I tried to Register the Warehouse a second time.

    Please advice how to solve this problem.

     

    Thanks

     

    Jon

     

     

    Tuesday, April 20, 2010 2:13 PM

Answers

  • Please create a back-up before trying!

    I tested this in my lab environment. Delete the SCSM server from the table I mentioned above. I this case you have to remove the entire entry containing D-OSLDIRSCSM01. Then you should be able to re-register to the warehouse.

    Hope this works for you...


    Maarten Damen -> www.maartendamen.com
    • Marked as answer by Jon R. Berg Friday, April 23, 2010 12:12 PM
    Thursday, April 22, 2010 8:44 PM

All replies

  • I did some SQL tracing work for you, when a register/unregister takes place the following table is touched:

    dbo.[MT_Microsoft$SystemCenter$ResourceAccessLayer$DwSdkResourceStore] within the DWStagingAndConfig database.
    Can you post a select * from that table here?

    Maybe some leftovers are located here from the old registration...


    Maarten Damen -> http://www.maartendamen.com
    Wednesday, April 21, 2010 9:09 PM
  • Hi

    /*------------------------
    SELECT *
      FROM [DWStagingAndConfig].[dbo].[MT_Microsoft$SystemCenter$ResourceAccessLayer$SdkResourceStore]
    GO
    ------------------------*/
    BaseManagedEntityId                  Description_A325A478_5930_35EC_C32A_5C2ECC3A2318                                                                                                                                                                                                                DataService_98B2DDF9_D9FD_9297_85D3_FCF36F1D016B                                                                                 Name_188E1D94_94DB_6A6B_3897_D7C2F6DFDBB6                                                                                                                                                                                                                       ManagementGroupId_09CD1EB1_A4DD_FCB3_F689_EFA9717EA95E DisplayName                                                                                                                                                                                                                                                      Server_48B308F9_CF0E_0F74_83E1_0AEB1B58E2FA
    ------------------------------------ --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------- -------------------------------------------------------------------------------------------------------------------------------- --------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------- ------------------------------------------------------ ---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------- --------------------------------------------------------------------------------------------------------------------------------
    43D526F6-C817-F02B-ED8B-213AE1C5CEED NULL                                                                                                                                                                                                                                                            NULL                                                                                                                             SCSMUDMG.Sdk                                                                                                                                                                                                                                                    A9146D29-F560-B0FC-721C-DF70A793AA74                   NULL                                                                                                                                                                                                                                                             D-OSLDIRSCSM01
    E8259ED8-1D2D-9F9E-F4FE-2813B71C2401 NULL                                                                                                                                                                                                                                                            Sdk                                                                                                                              Ral.SdkResourceStore.Sdk                                                                                                                                                                                                                                        AAB4667A-6433-727A-0A11-761BAD500B4E                   NULL                                                                                                                                                                                                                                                             D-OSLDIRSCSM02
    9C8801C8-553D-8AFF-AC65-CB92234ADA7D NULL                                                                                                                                                                                                                                                            NULL                                                                                                                             DW_SCSMUD.Sdk                                                                                                                                                                                                                                                   AAB4667A-6433-727A-0A11-761BAD500B4E                   NULL                                                                                                                                                                                                                                                             D-OSLDIRSCSM02

    (3 row(s) affected)

     

     

    • Proposed as answer by entityx Thursday, April 21, 2011 7:28 AM
    • Unproposed as answer by entityx Thursday, April 21, 2011 7:29 AM
    Thursday, April 22, 2010 7:51 AM
  • Please create a back-up before trying!

    I tested this in my lab environment. Delete the SCSM server from the table I mentioned above. I this case you have to remove the entire entry containing D-OSLDIRSCSM01. Then you should be able to re-register to the warehouse.

    Hope this works for you...


    Maarten Damen -> www.maartendamen.com
    • Marked as answer by Jon R. Berg Friday, April 23, 2010 12:12 PM
    Thursday, April 22, 2010 8:44 PM
  • Hi

    Thanks, have re-installed to solve this problem. But it seem like a solution to this issue.

     

    Jon

     

    Friday, April 23, 2010 12:12 PM
  • Thank you for the advice... I have deleted all 3 rows and finally can create the connection again, but unfortunately I receive an error after it attempts to register the installation with Data Warehouse

    Unable to register Service Manager installation with Data Warehouse installation.
     Data Warehouse Server: DW_SCSM
     Service Manager Management Server: SCSM_MG

     Exception: System.NullReferenceException: Object reference not set to an instance of an object.
       at Microsoft.EnterpriseManagement.SdkUtilities.SdkUtilitiesCommon.GetDBInfo(EnterpriseManagementGroup mg, String& dbservername, String& dbname, String& sdkservername)
       at Microsoft.EnterpriseManagement.SdkUtilities.WarehouseRegistration.Register()
       at Microsoft.EnterpriseManagement.UI.SdkDataAccess.DataAdapters.DWRegistrationAdapter.DoAction(DataQueryBase query, IList`1 dataSources, IDictionary`2 parameters, IList`1 inputs, String outputCollectionName)

    Any suggestions?



    civitas hall
    Thursday, April 21, 2011 7:28 AM
  • I ran into this problem when I tried to Unregister with the service manager data warehouse and then reconnect.

    Deleteing these rows allowed me to continue, but at the end it still fails with this error:

    DataSource is already registered with the datawarehouse


    Ed Hammond - System Admin

    Tuesday, May 22, 2012 1:58 PM
  • After following these steps, I am also getting 'DataSource is already registered with the datawarehouse' error.
    Sunday, May 27, 2012 8:15 AM
  • Using powershell, the Unregister-SCDWSource cmdlet unregisters a data source from the data warehouse. Any jobs that extract data from the unregistered data source are deleted. Any management packs that are synchronized from the unregistered data source are uninstalled. Any data that has already been retrieved from the data warehouse for the unregistered data source remains.

    UnRegister-SCDWSource –ComputerName serverDW –DataSourceTypeName "ServiceManager" –DataSourceName "Contoso_2"

    • Proposed as answer by Seth Coussens Wednesday, October 3, 2012 2:39 PM
    Monday, September 10, 2012 9:11 AM
  • You can use the next command

    Remove-SCDWMgmtGroup -SourceComputerName SCSMmgmt server -ComputerName DWMgmt Server

    Tuesday, December 18, 2012 5:06 AM
  • I have executed UnRegister-SCDWSource and confirmed the Data Source was removed using Get-SCDWSource cmdlet. However, I was still unable to register the Data Warehouse. Is there any suggestions ?


    • Edited by WyattWong Tuesday, February 26, 2013 1:56 AM
    Monday, February 25, 2013 10:08 AM
  • You can use the next command

    Remove-SCDWMgmtGroup -SourceComputerName SCSMmgmt server -ComputerName DWMgmt Server


    There is no "Remove-SCDWMgmtGroup" in SCSM 2012 cmdlet. Do you mean the "Remove-SCSMManagementGroupConnection" cmdlet ?

    However, I executed "Get-SCSMManagementGroupConnection" and only see the connection Management Server and there is no connection to the Data Warehouse Management Server (maybe because after I executed the Unregister-SCDWSource cmdlet ?) Does that mean I don't need to execute the Remove-SCSMManagementGroupConnection cmdlet then ?

    Tuesday, February 26, 2013 1:57 AM
  • Dear Mr. Ed how did you resolved your issue? I have exactly the same.

    On one day the connection with my datawarehouse has totally unexpectedly ended, so  I have unregistered it, and tried to register again - then got error about group, I havedeleted those 3 rows but still have the "DataSource is already registered with the datawarehouse" issue at the end of that wizzard, I am dying to find out how did you resolved your issue?

    Pawel

    Saturday, April 6, 2013 12:51 PM
  • Hi all,

    I made up final decision to uninstall the SCDW server. But still I wasn't sure it would help, but no risk no fun.

    After removing it, I started the installation wizzard.

    I was considering to install it with the old database's names, or give new ones. The second choice was better, in fact, if I would left the old names, the field with management group was grayed out, so basically I don't think that would help with "A group is in use..." problem, because I would use the same group during registering, and I wanted to change that group name. The wizzard made it for me - for each database name it added "_1", so I simply accepted it.

    From last time I remembered that the SCDW installation process it is easy as pie, so I was very astonished when on "Configure Analysis Services for OLAP cubes" I have received error "A server in unavailable" - "what the hack" - the wizzard has perfectly worked with databases in previous steps - as wrote, it discovered that I have done it before and databases persists - it has added the "_1" sign after each DB name. Why it cannot connect to DB server in this step?!

    First thought was to checked the Analysis Service on my SQL server - a good old service restart :) but it didn't helped, so maybe the permissions? I have changed the user on which I was installing the SCDW server (those fields where you give username and password in wizzard), but no luck.

    With a help of that post:

    http://social.technet.microsoft.com/Forums/en-US/setup/thread/33c307a7-5ad9-430b-939c-bf3931495677/

    I have discovered the log file, and guess what was in file?:

    Error:GetSqlInstanceList(), Exception Type: Microsoft.AnalysisServices.OperationException, Exception Message: File system error: The following file is corrupted: Physical file: ...\Data\DWASDataBase.0.db\ReviewActivityDim.0.dim\5.ApprovalCondition_ReviewActivityApprovalId.(All).sstore. Logical file.

    That would make sence - because as the wizzard changed the databases names in previous steps - adding "_1", it hasn't done it in this step! It was weird because I have checked "create new database" and It didn't find the old one - but what it has common with connecting to the database server?! I mean the file name :/

    The same was happening when I have checked "use existing database", so apparently, the wizzard just didn't changed the database name because it couldn't connect to DB server. I have changed the DB name by adding "_1" and clicked "next", and guess what? "A server in unavailable"...

    What the hell!!! What is common in connection to server and corrupted OLD!!!  database file name.

    I have looked at the log file - the error was exactly the same!!! So apparently the SCSM wizzard has a bug, and even having inputed a new name, it tries to install OLAP cubes under one name "DWASDataBase" in the same old folder "DWASDataBase.0.db".

    I have logged on the DB server, stopped the Analysis Service, renamed the folder to "DWASDataBase.0.db_BAK", rerun the service, and... guess what :) The wizzard pass the step to the end, the installation was finalized successfully.

    I have logged to my SCSM server and tried to register the SCDW server - WORKED LIKE A CHARM!

    Sunday, April 7, 2013 8:56 PM
  • I fixed this error by doing a unregister, this is my blog where I explain it. http://daanweda.wordpress.com/?p=15&preview=true

    • Proposed as answer by OlafurS Wednesday, June 12, 2013 11:26 AM
    Monday, June 3, 2013 12:58 PM
  • Thank you DaanW, It worked. I am a happy camper.

    Best Regards OlafurS


    Icelandic DBA admin

    Wednesday, June 12, 2013 11:28 AM