none
Failed to Sql Query data XEvent collector on sqldbserver. The error is Object reference not set to an instance of an object. And other SQL related errors in SharePoint 2013 RRS feed

  • Question

  • I am trying to log some events in the SharePoint logs. But I cannot see any of those logs. While looking at the ULS logs i found that there are a few SQL related errors.

    "Failed to Sql Query data XEvent collector on 'SP_CFG'. The error is Object reference not set to an instance of an object."

    I get this of error frequently for all the aliases that I have used. The SharePoint site seems to work fine even with all these errors.

    When I look at the Event Viewer, i find some SQL related errors and some other SharePoint errors. All are listed below.

    SQL Errors:

    "Database 'Master' on SQL Server instance 'SP_CFG' is not empty and does not match current database schema."

    "Unknown SQL Exception 297 occurred. Additional error information from SQL Server is included below. The user does not have permission to perform this action."

    "Unknown SQL Exception -2146893055 occurred. Additional error information from SQL Server is included below. A connection was successfully established with the server, but then an error occurred during the pre-login handshake. (provider: SSL Provider, error: 0 - The handle specified is invalid)"

    "The Execute method of job definition Microsoft.SharePoint.Administration.SPConfigurationRefreshJobDefinition (ID 52919854-4dd7-4422-b649-93c8a3c98135) threw an exception. More information is included below.A connection was successfully established with the server, but then an error occurred during the pre-login handshake. (provider: SSL Provider, error: 0 - The handle specified is invalid)"


    Other Errors:

    "The Execute method of job definition Microsoft.Office.Server.UserProfiles.LMTRepopulationJob (ID 894935c4-9662-418f-a2e2-d04e48122268) threw an exception. More information is included below. Unexpected exception in FeedCacheService.BulkLMTUpdate: Region not found "

    I have checked the farm account premissions on the SQL server. It has the right permissions (dbcreator and security admin). I have checked that all the services are running correctly. I have re-started the AppFabric service and the distributed cache service. I have tried adding host entries for the SQL aliases, but i still get the errors.

    Could anyone please let me know the cause of these errors and how to fix them?

    Thanks,

    Sabrish



    • Edited by Sabrish Tuesday, October 1, 2013 10:10 AM
    Tuesday, October 1, 2013 10:02 AM

Answers

All replies