none
Alert : Percentage of committed memory in use is too high

    Question

  • Alert Description : The threshold for the memory\committed byte in use performance counter has been exceeded. The value that exceeded the threshold  is 81.35668827192.
    I am getting this alert at my SCE Box having 3 GB of RAM. How can i resolve this issue as accourding to the alert description i have checked with the performance counters at system monitor ( perfmon) .
    Beside that can i change this alert seeting or like diable the values so i do not get this alert anymore.
    Regards

    Thursday, June 05, 2008 5:22 AM

Answers

  • Hi,

     

    Several Microsoft products including Exchange, SQL Server, and the Operations Manager ROM will use all available memory. This is especially noticeable on 64-bit platforms where memory can scale-out more effectively for the applications.

     

    Resolution: Configured the server to have a 95% threshold instead of 80%. To do it:


    1)    Navigate to authoring pane -> Management Pack Objects -> Monitors.
    2)    Find the monitor at "Windows Server 2003 Operating System"  -> Entity Health ->Performance -> "Percentage of committed Memory in Use"
    3)    Right click it and select “Overrides” -> "Override the monitor" -> "For all objects of type: Windows Server 2003 Operating System".
    4)    Specify the threshold value 95% instead 80% and click to apply.


    Hope it helps.

    Friday, June 06, 2008 9:47 AM
    Moderator

All replies

  • Hi,

     

    Several Microsoft products including Exchange, SQL Server, and the Operations Manager ROM will use all available memory. This is especially noticeable on 64-bit platforms where memory can scale-out more effectively for the applications.

     

    Resolution: Configured the server to have a 95% threshold instead of 80%. To do it:


    1)    Navigate to authoring pane -> Management Pack Objects -> Monitors.
    2)    Find the monitor at "Windows Server 2003 Operating System"  -> Entity Health ->Performance -> "Percentage of committed Memory in Use"
    3)    Right click it and select “Overrides” -> "Override the monitor" -> "For all objects of type: Windows Server 2003 Operating System".
    4)    Specify the threshold value 95% instead 80% and click to apply.


    Hope it helps.

    Friday, June 06, 2008 9:47 AM
    Moderator
  • I have done that.
    Thanks
    Monday, June 09, 2008 6:25 AM
  • I have the same issue. But would this soulution hide other non-exchange systems that are having issues?

    Monday, August 04, 2008 2:11 PM
  • We have this in our environment and determined it was the pagefile setting. Try raising the pagefile size. If you look at recommended setting and you're way below that it might be a problem. If you can spare the space, set it to system managed. See if the alert stops occurring.
    • Proposed as answer by jbn2050 Tuesday, December 15, 2009 6:19 AM
    Friday, October 02, 2009 8:13 PM
  • Read what the product knowlege in this alert says:


    Summary
    The % Committed Bytes In Use (Memory\% Committed Bytes In Use) for the system has exceeded the threshold. Overall system performance may significantly diminish which will result in poor operating system and application performance.

    The % Committed Bytes In Use performance counter represents the ratio of Memory\Committed Bytes to the Memory\Commit Limit. Committed Bytes is the amount of committed virtual memory while Commit Limit is the amount of virtual memory that can be committed without having to extend the paging file(s).

    When this performance threshold has been exceeded, it often indicates that the page file could not be expanded, or expanded fast enough, to satisfy application memory requirements.

     

    I would caution just overriding monitors to "hide" the problem. We have already solved some serious problems in our environment that probably would not have been found otherwise by the alerts generated from this monitor. In every single case, the pagefile was set way below the recommended (1.5x RAM) setting. Simply changing to "System Managed" has solved the problem.

    Monday, October 19, 2009 4:19 PM

  • I would caution just overriding monitors to "hide" the problem. We have already solved some serious problems in our environment that probably would not have been found otherwise by the alerts generated from this monitor. In every single case, the pagefile was set way below the recommended (1.5x RAM) setting. Simply changing to "System Managed" has solved the problem.


    It makes a big difference if you are talking about 32 vs. 64 bit systems with plenty of ram.  if you have a 64-bit SQL server with 64 or 128GB of ram, it will barely ever touch the page file, and having 1.5x RAM dedicated to an unused page file can be either expensive or a waste.  Or both.
    Tuesday, December 15, 2009 12:23 AM
  • You should use Perfmon and track usage to determine page file usage. I believe if you are getting this alert on a system like that, you should increase the page file until your Perfmon counters (% usage, commited bytes, etc) are under control. 1.5x is a general guideline but not a one size fits all.

    I see people increasing the threshold on this alert and some information that to me doesn't appear to be true. Like I said we solved some performance issues by increasing the pagefile on large RAM 64-bit systems due to this alert so it's quite a good setting as is in my opinion (80%).
    Tuesday, December 15, 2009 6:15 AM