none
Remote audio not played on local computer in RDP session

    Question

  • Windows 7 RDP Client to Windows 7 Host

    "Local Resources"->"Settings"->"Play on this computer" is selected in RDP configuration

    when I connect to the remote session the audio control says there are no audio devices and then I try to play a wav file Windows Media Player gives this error

    Windows Media Player cannot play the file because there is a problem with your sound device. There might not be a sound device installed on your computer, it might be in use by another program, or it might not be functioning properly.

    Audio works fine on both machines when logged into the console.

    How do I get audio on host system to play to the RDP client?

    Regards,

    CS

    Thursday, September 26, 2013 6:05 PM

Answers

  • Hi,

    Here we can check the following settings:

    1. Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Device and Resource Redirection\Allow audio and video playback redirection. Although this setting is allowed by default in windows 7, I still suggest you check if you disable it.
    2. Start the Windows Audio service.
    3. Set the maximum color depth to 32 bits per pixel.

    If you have any feedback on our support, please click here


    Alex Zhao
    TechNet Community Support

    Monday, September 30, 2013 8:09 AM
    Moderator

All replies

  • Hi,

    Please refer to the link for how to enable Audio when using RDP session below:

    http://www.wikihow.com/Hear-Audio-from-the-Remote-PC-when-Using-Remote-Desktop

    Thanks!

    Monday, September 30, 2013 1:03 AM
    Moderator
  • I tried this and the RDP client still doesn't recieve the audio that is playing on the host.  Audio works on both the host and the client and this is a high speed connection on both ends, at least 10Mbps/5Mbps.

    Any other suggestions?

    Monday, September 30, 2013 5:14 AM
  • Hi,

    Here we can check the following settings:

    1. Computer Configuration\Administrative Templates\Windows Components\Remote Desktop Services\Remote Desktop Session Host\Device and Resource Redirection\Allow audio and video playback redirection. Although this setting is allowed by default in windows 7, I still suggest you check if you disable it.
    2. Start the Windows Audio service.
    3. Set the maximum color depth to 32 bits per pixel.

    If you have any feedback on our support, please click here


    Alex Zhao
    TechNet Community Support

    Monday, September 30, 2013 8:09 AM
    Moderator