none
HP OneView 4 Integration in SCOM RRS feed

  • Question

  • Hey Together,

    we have following issue while trying to configure the HP OneView integration in SCOM 2012 R2. Everything is installed following the user guide. After importing the HP OneView Management Packs we want to discover an appliance via the Configuration Dashboard but it does not work.

    1. If i enter the DNS Name, User Name and Passwort i get an Error Code 2: Connection Failure
    2. If i enter the IP Adress, User Name and Password i get an Error Code 109: Connection Timeout

    Is anybody aware of this errors and know how to fix?

    Every help and answer appreciated.

    Best Regards,

    Udo


    News from Forum

    Tuesday, April 24, 2018 12:12 PM

Answers

  • Hello together,

    i want to let you know how i was able to solve our problem. We use a local account created on the HP Oneview appliance. The accountname is scomadmin. What i always tried was in the Configuration Dashboard set up the credentials with the username and the password. Then i always got the error. 

    What i know did was to setup the User Name in the following way: local\scomadmin and that worked for me. I now was able to add the appliance in the SCOM console.

    I hope this helps you. Give it a try.

    Best Regards,

    Udo


    News from Forum

    Tuesday, July 3, 2018 9:33 AM

All replies

  • HI Udo,

    do you have a DNS record registered for the OneView? If not, that would explain why in the first case (1.) you are getting the Connection Failure and also why you have other behavior when using the IP.

    In regards to the "Connection Timeout": Did you ensure you can connect to the OneView appliance on port 80 (or 443 if you are doing SSL)?

    This is something I missed the very first time I configure the monitoring of OneView. 

    Make sure the communication is not blocked in the respective port. From the management servers, on which the HPE OneView Event Manager Service is running, do a simple test (PowerShell)

    Test-NetConnection -ComputerName <IP of the OneView> -Port 80 

    or 

    Test-NetConnection -ComputerName <IP of the OneView> -Port 443

    if you have cnfigured certificates (are using SSL).

    Additionally, please check the events under HPE OneView Event Manager Service in the Event viewr and post back the errors or warning, which seems related. What events do you have there?

    If you want to check out what the events mean, you can find those in the HP OV User Guide, under "HPE OneView Event Manager Service NT events" on page 123:

    HP OneView v4 User Guide

    Furthermore and ver. very important, right after the section with the events there is a "Troubleshooting" section where you have also the paragraph, named "Operations Manager is not discovering HPE OneView Appliance/Enclosure/ Virtual Connect/Storage Systems/Servers "

    Please make sure you have completed all the suggested actions from it. 

    Regards,


    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!) Blog: https://blog.pohn.ch/ Twitter: @StoyanChalakov




    Tuesday, April 24, 2018 12:51 PM
    Moderator
  • Hi Udo,

    from the guide:

    also from the guide:

    • Ensure that a discovery cycle has completed since you registered the server.

    • Ensure all current active alerts in the domain of Operations Manager. Resolve all active alert issues, and then close the Active Alerts view.

    • Ensure network connectivity from the management server to the appliance is stable and the http ports are not blocked by a firewall.

    • Examine the Operations Manager Log. Review the Error and Warning entries that can cause issues with the system. Report these issues to Microsoft.

    Have you checked the OperationsManager event lgo fro related events also?


    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!) Blog: https://blog.pohn.ch/ Twitter: @StoyanChalakov

    Tuesday, April 24, 2018 1:15 PM
    Moderator
  • Hi all,

    i do have similar case here.

    with same credentials i can login to hp console view, when i add it in it says error below

    any help here is much appreciated


    swapna

    Saturday, May 12, 2018 7:18 AM
  • same credentials wored before some months in test environment, now in production is it not picking up


    swapna

    Saturday, May 12, 2018 7:20 AM

  • swapna

    Saturday, May 12, 2018 7:20 AM
  • Hi all,

    i do have similar case here.

    with same credentials i can login to hp console view, when i add it in it says error below

    any help here is much appreciated


    swapna

    Hi,

    may I ask you to open a new thread about this and describe the issue in details so that you can get the best support. Thanks!

    Regards,


    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!) Blog: https://blog.pohn.ch/ Twitter: @StoyanChalakov

    Monday, May 14, 2018 2:11 PM
    Moderator
  • Hey Together,

    we have following issue while trying to configure the HP OneView integration in SCOM 2012 R2. Everything is installed following the user guide. After importing the HP OneView Management Packs we want to discover an appliance via the Configuration Dashboard but it does not work.

    1. If i enter the DNS Name, User Name and Passwort i get an Error Code 2: Connection Failure
    2. If i enter the IP Adress, User Name and Password i get an Error Code 109: Connection Timeout

    Is anybody aware of this errors and know how to fix?

    Every help and answer appreciated.

    Best Regards,

    Udo


    News from Forum

    Hi Udo,

    any update on this? Thanks!

    Regards,


    (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!) Blog: https://blog.pohn.ch/ Twitter: @StoyanChalakov

    Monday, May 14, 2018 2:11 PM
    Moderator
  • Hello Stoyan,

    unfortunately there is no update. We now started to open a case with HP to investigate further. I will let you know if I have more information.

    Best Regards,

    Udo


    News from Forum

    Wednesday, May 16, 2018 10:11 AM
  • Hi All,

    what i have done is , i have unstalled this version of HP OneView[4] completely from all management servers.

    then i have installed older version of HP One View, then tried to add the hp appliance it worked perfectly now.

    all i am stuck is though i see health changes, i don't see alerts coming onto SCOM Console now.


    swapna

    Monday, May 21, 2018 11:21 AM
  • Hello together,

    i want to let you know how i was able to solve our problem. We use a local account created on the HP Oneview appliance. The accountname is scomadmin. What i always tried was in the Configuration Dashboard set up the credentials with the username and the password. Then i always got the error. 

    What i know did was to setup the User Name in the following way: local\scomadmin and that worked for me. I now was able to add the appliance in the SCOM console.

    I hope this helps you. Give it a try.

    Best Regards,

    Udo


    News from Forum

    Tuesday, July 3, 2018 9:33 AM
  • Hi

    We had the same problem, and our solution was to type the domain username as an e-mail address.  username@domain.com

    Regards,

    Andreas

    Tuesday, September 11, 2018 8:22 AM