none
High CPU - ParserServer.exe RRS feed

  • Question

  • High Everyone,

    We recently migrated from Exchange 2007 to Exchange 2013. Around 9:00 every morning, we are seeing CPU utilization go to 100% for between 2 and 10 minutes. We monitor processes during this time and it is parserserver.exe that is the culprit. We see an instance for the 4 DB's that reside on each server. The rest of the day the servers run normally between 30-50% CPU utilization. During this time when the CPU's are pegged, we have some client connectivity issues.

    We are running Exchange 2013 SP1 with CU7

    We have provided Perfmon information to Microsoft but wondered if anyone else has run into this?

    Friday, February 20, 2015 3:46 PM

Answers

  • Hi,

    The NodeRunner and ParserServer is FAST search system in Exchange 2013, which is used to do the indexing all emails. When there are many emails needed to do the indexing(especially there are lots of attachments), it would cause a high CPU issue.

    I suggest to use the Regedit key CtsProcessorAffinityPercentage to limit CPU utilization for the process NodeRunner or ParserServer, the following is the details:

    1. Launch registry editor
    2. Go to path HKLM\SOFTWARE\Microsoft\ExchangeServer\V15\Search\SystemParameters
    3. Create a DWORD by name CtsProcessorAffinityPercentage
    4. Configure the value to 15 (decimal)
    5. Restart Exchange Search Host Controller service and Microsoft Exchange Search service on the server.
    6. Monitor the CPU utilization on the server.

    Best Regards.

    • Marked as answer by Spazzin_2015 Friday, February 27, 2015 5:06 PM
    Tuesday, February 24, 2015 2:30 AM
    Moderator

All replies

  • Hi,

    The NodeRunner and ParserServer is FAST search system in Exchange 2013, which is used to do the indexing all emails. When there are many emails needed to do the indexing(especially there are lots of attachments), it would cause a high CPU issue.

    I suggest to use the Regedit key CtsProcessorAffinityPercentage to limit CPU utilization for the process NodeRunner or ParserServer, the following is the details:

    1. Launch registry editor
    2. Go to path HKLM\SOFTWARE\Microsoft\ExchangeServer\V15\Search\SystemParameters
    3. Create a DWORD by name CtsProcessorAffinityPercentage
    4. Configure the value to 15 (decimal)
    5. Restart Exchange Search Host Controller service and Microsoft Exchange Search service on the server.
    6. Monitor the CPU utilization on the server.

    Best Regards.

    • Marked as answer by Spazzin_2015 Friday, February 27, 2015 5:06 PM
    Tuesday, February 24, 2015 2:30 AM
    Moderator
  • Thanks Lynn-Li, that seems to have fixed the issue.
    Friday, February 27, 2015 5:06 PM
  • Hi Lynn-Li,

    We are having similar issue with a bulk email.  I am going to try this but I had a question.

    What does the value of 15 represent?  Is this the max percentage of CPU that the NodeRunner or ParserServer process is aloud to consume?

    I tried to search the net for what that key actually does and can't seem find anything on it.

    Thanks

    Friday, April 10, 2015 3:07 PM
  • Hi I would also like to know more about what  CtsProcessorAffinityPercentage does and what the values mean. Can someone give us some more details?

    Thanks


    WWT IT

    Wednesday, August 17, 2016 6:55 PM
  • One another possible option would be to "finetune" the indexer. For example you might wish to

    - Disable some File formats indexed

    - Change the maximum size file that can be indexed

    - MaxAttachmentDepth

    - ...

    You can find here more infos about the possible options.

    • Proposed as answer by Bastian_W Wednesday, November 9, 2016 12:45 PM
    Wednesday, November 9, 2016 12:45 PM