none
Outlook 2013 Instant Search not working

    Question

  • The search option in Outlook 2013 with online mode does not work. Currently, Outlook 2013 is running on a Windows 2008 terminal server and Exchange 2013 on a Windows 2012 server.

    In other environments where Exchange 2010 and Outlook 2013 are running, there are no problems to search for e-mail. The instant search in Outlook 2013 works. It seems that searching in Outlook 2013, with online mode in combination with Exchange 2013 this function is not supported.
    Later, on the Windows 2008 terminal server, the functions: Fileservices and External desktop-services have been installed. The functionservices: Fileserver and Windows-Search services are also installed. Even when this compontents are being installed, the search option in Outlook 2013 refuses to work.

    When the Windows-Search function was installed, the Outlook profiel were present in the indexlist. The indexstatus In Outlook 2013 indicates that 0 items are being indexed. Even with Outlook present in the list of the index file, the problem of searching for e-mail in Outlook still remains.

    With the configuration of cache mode on, the search option is working. But because this is a terminal server, the preference will be the online mode. I have tried to rebuild the index file, recreate a new Outlook profile and tried the solution that is given in this topic.

    Sorry for my bad english, but i hope someone is recognize this problem or knows a solution

    Thanks in advance and i will look forward to your reply's

    Friday, July 12, 2013 9:28 AM

Answers

  • The problem that i was having is now solved. This issue was related to a corrupted Exchange Search index file.

    A recreation of this file will solve this problem. To do this:

    1. Stop the following services on the server where Exchange 2013 is running: Microsoft Exchange Search and Microsoft Exchange Search Host Controller
    2. Browse to the following path #:\Program Files\Microsoft\Exchange Server\Mailbox\Mailbox Database <name of the database file (numbers)>
    3. In this folder a folder is a folder located named like: ########-####-####-####-###############.1.Single
    Rename this map. to ########-####-####-####-###############.1.Single.old

    Note: For renaming this folder its important that the services in step 1 are stopped

    4. Start the services: Microsoft Exchange Search and Microsoft Exchange Search Host Controller
    The Exchange server will now rebuild the index file. This proces could take some time. To view the status of this proces, execute the following steps:

    1. Start the Microsoft Exchange PowerShell program

    2. Use the following command: Get-MailboxDatabaseCopyStatus

    The ContentIndexState will change during this process from failed to crowling and effentially to healty. If this is not the case then a error has occured during the rebuild.

    After this steps I also have test this in OWA but there the problem still exist, but i don't believe this have to do anything with the search module. E-mail in OWA except for Inbox do not even appear. Perhaps the rebuild of the index file have something to do with this. I will have a look at it and respond if i found the issue.


    Friday, July 12, 2013 11:39 AM
  • The issue is now completely solved. It was the way of accessing the OWA directory. When I tried https instead of http, the search option was working well and the e-mail were present at the folders.

    In IIS the SSL in OWA was required.

    Friday, July 12, 2013 12:15 PM

All replies

  • The problem that i was having is now solved. This issue was related to a corrupted Exchange Search index file.

    A recreation of this file will solve this problem. To do this:

    1. Stop the following services on the server where Exchange 2013 is running: Microsoft Exchange Search and Microsoft Exchange Search Host Controller
    2. Browse to the following path #:\Program Files\Microsoft\Exchange Server\Mailbox\Mailbox Database <name of the database file (numbers)>
    3. In this folder a folder is a folder located named like: ########-####-####-####-###############.1.Single
    Rename this map. to ########-####-####-####-###############.1.Single.old

    Note: For renaming this folder its important that the services in step 1 are stopped

    4. Start the services: Microsoft Exchange Search and Microsoft Exchange Search Host Controller
    The Exchange server will now rebuild the index file. This proces could take some time. To view the status of this proces, execute the following steps:

    1. Start the Microsoft Exchange PowerShell program

    2. Use the following command: Get-MailboxDatabaseCopyStatus

    The ContentIndexState will change during this process from failed to crowling and effentially to healty. If this is not the case then a error has occured during the rebuild.

    After this steps I also have test this in OWA but there the problem still exist, but i don't believe this have to do anything with the search module. E-mail in OWA except for Inbox do not even appear. Perhaps the rebuild of the index file have something to do with this. I will have a look at it and respond if i found the issue.


    Friday, July 12, 2013 11:39 AM
  • The issue is now completely solved. It was the way of accessing the OWA directory. When I tried https instead of http, the search option was working well and the e-mail were present at the folders.

    In IIS the SSL in OWA was required.

    Friday, July 12, 2013 12:15 PM
  • Hi,

    I have the exact same issue on Exchange Server 2016. When outlook 2016 running on a RDS 2012 server in Online Mode, the instant search feature does not work. When in Cached Mode it works fine.

    This is a after a brand new installation (exchange server and RDS server) so is it a design issue or could it also be a corrupt index as well?

    Friday, March 25, 2016 12:42 PM
  • Hi Alex,

    Please check the following items:

    - Did you migrate mailboxes from a different Exchange platform?
    - How does the search function operating in OWA?

    If it is working in OWA, then the problem is not Exchange Server related and you should check your RDS 2012(R2?).

    Friday, March 25, 2016 1:22 PM
  • We exported the mailboxes from the old server as a .PST from outlook and imported them into the new 2016 exchange server via outlook as well.

    I just checked OWA and the search works for some users and not others?

    Looks like the problem relates to a mailbox and not the entire exchange database. 

    I found a KB article (945077 which highlights the same problem. Do you think it could fix the problem? 

    Saturday, March 26, 2016 2:52 AM
  • Hello Alex,

    I don't know how many mailboxes it's about or how big the mailbox database is, but could it be that Exchange is still indexing the mailboxes (IndexContentState - See marked answer)?
    Can you check whats happening when you create a new mailbox, send or import some e-mails into it and see if the search give results back?
    Did you install the Windows Search feature on your RDS?
    Does the problem only persist on mailboxes that were .pst files are imported?

    Because the search gives good results on some mailboxes I don't think the KB945077 update is going to work.

    Is Exchange operating with the latest CU?
    What happends if you force a new Exchange index on your Exchange server?

    Saturday, March 26, 2016 11:03 AM
  • We exported/imported all mailboxes from exchange 2010 to 2016 so it was strange only a few were affected? Windows search was installed on the RDS server and all mailboxes were running in online mode. We had the latest CU installed plus all updates.

    The search feature is now working as should by following the below instructions;

    • Stop the Microsoft Exchange Search and Microsoft Exchange Search Host Controller services
    • Navigate to your mail database folder, and rename the GUID folder that ends with .simple to .simple.bak
    • Start the two services again
    • Check the rebuild status with Get-MailboxDatabaseCopyStatus -Server SERVERNAME | FL Name,*Index*

    Even though prior to the rebuild the index state showed a healthy status, I ran it anyway and it has fixed the issue.

    One final question, now that the exchange search works from OWA and Outlook on the RDS server, instant search will never work in online mode will it? On our Exchange 2010 server with RDS 2008 and Outlook 2010 normal search as well as instant search was working great on both cached mode and online mode. However, I read that instant search will only work on cached mode for exchange server 2013 and later? Can anyone confirm this?

    Sunday, March 27, 2016 1:01 AM
  • It does work on a Windows 2008r2 and Windows 2012/2012R2. When you enable cache it will use the Windows Search (feature) database and Indexing your .ost file, which you have installed. It ignores the Exchange Search services and you like to use this feature. You need to disable Cache mode on your mailboxes, because you don't want .ost files on your system that filled up your disk space. When you have the Remote Desktop role installed on your RDS, Outlook automatically and has disabled cache mode by default when you create an Outlook profile. If it works in OWA we can establish that the Exchange Search engine is operating as it should. You still need to rule out if the problem persist on the side of Exchange or your RDS/Outlook configuration. Therefore you need te check or test the following:

    - Can you test a mailbox on a different machine (Windows 7/8/10) with Exchange Cache-mode off?
    - Check your EWS directory in IIS. Verify that it has the same (security) settings as OWA-directory.

    In this forum it was the other way arround. The search worked in Outlook but not in OWA. The solution was to check the SSL-settings. Since Outlook is using Autodiscover when creating an mailbox, you will need to check if all SSL-settings and Exchange URL's are correct.  

    Sunday, March 27, 2016 7:43 AM
  • Sorry I don't think I explained myself clearly. Searching now works in both online mode (server side) and cached mode (client side) so no problems there any more. The only thing not working like it used in our 2008 R2 RDS server and Exchange 2010 was when the user was typing a search string the results were appearing as you typed, now you must type in the full string and press enter for the results to display. This is only a minor problem and it does not work in online mode but does work in cached mode.

    It's the option in outlook search "when possible, display results as the query is typed".

    Sunday, March 27, 2016 12:43 PM