none
Oracle Linux 6.3 discovery cryptic failures

    Question

  • Here is my environment:

    System Center Operations Manager 2012 R2

    Adding a Oracle Linux 6.3 server (not on domain) for monitoring

    I am receiving very cryptic messages and had to turn on significant debugging to finally get a actionable error message, but I am stumped.

    It appears there is a script running that is failing to "create the secure directory" /tmp/scx-USERNAME with the permissions: 755.

    The very confusing part is after examining the GetOSVersion.sh script that is run, there is no creation of directories contained in that script.

    I have included two screenshots of the error messages that I am receiving.

    I have already tried modifying the sudo file (using visudo) but this should not be the issue as the user that I created is able to sudo without a password and without issue here as SCOM is able to SSH into the server using the credentials.

    I was forced to manually install the scx server on the Oracle Linux server and successfully generated the certificate twice, both times to no avail. (I made sure to delete all traces of the old certificate between tests)

    Any suggestions or guidance is greatly appreciated. Lunch and drinks to to whoever helps with the correct solution as this is driving me crazy.


    • Edited by Kevin54M Tuesday, April 18, 2017 11:18 PM
    Tuesday, April 18, 2017 10:49 PM

All replies

  • Hi Kevin,

    what happens if you pre-create the user's directory and ensure the user is able to access it? /tmp/scx-USER?

    And another thing: Which agent version have you installed on the Oracle Linux 6.3 system? Are you sure you have picked the proper version?

    Regards,


    Stoyan (Please take a moment to "Vote as Helpful" and/or "Mark as Answer" where applicable. This helps the community, keeps the forums tidy, and recognizes useful contributions. Thanks!)


    Wednesday, April 19, 2017 2:33 PM
  • Same result when pre-creating the directory. The line of the script first attempts to delete then create the directory, but when I type it at the terminal on the linux machine using backticks (` next to the 1 key) it states:

    opsuser: `rm -rf /tmp/scx-opsuser; mkdir -m 755 /tmp/scx-opsuser`
    rm: cannot remove `/tmp/scx-opsuser': Operation not permitted
    mkdir: cannot create directory `/tmp/scx-opsuser': File exists

    but when using single quotes the error states: 

    opsuser: 'rm -rf /tmp/scx-opsuser; mkdir -m 755 /tmp/scx-opsuser'
    -bash: rm -rf /tmp/scx-opsuser; mkdir -m 755 /tmp/scx-opsuser: No such file or directory

    The version of scx I was using was: scx-1.5.1-242.universalr.1.x86.rpm (I am running Oracle Linux Server release 6.3) However, a listing of /proc/version states Red Hat 4.4.6-3 so I am going to try the RHEL 4 scx (scx-1.5.1-242.rhel.4.x86.rpm)

    UPDATE: RHEL 4 version of scx would not install, but RHEL 6 version did. Still same error as described above. Currently running updates to see if this helps.


    Has anyone else had this same issue? How did you solve it? Any suggestions or guidance is requested. I appreciate your assistance Stoyan. Keep the guidance coming please.

    • Edited by Kevin54M Wednesday, April 19, 2017 7:40 PM
    Wednesday, April 19, 2017 7:16 PM
  • Please see if you have the correct sudoers entry :

    https://social.technet.microsoft.com/wiki/contents/articles/7375.scom-2016-and-2012-configuring-sudo-elevation-for-unix-and-linux-monitoring.aspx

    Wednesday, April 19, 2017 8:49 PM
  • I originally used: <USERNAME> ALL=(ALL) NOPASSWD: ALL

    giving this user permissions to sudo and do anything system wide. This however did not work so I believe the issue is elsewhere. I just checked the certificate, which is ok.

    Any more suggestions?

    The errors that I am seeing in the SecureUploadWriteAction log file (on the SCOM server) are:

    Failed to create the secure directory: `rm -rf /tmp/scx-USER; mkdir -m 755 /tmp/scx-USER`
    error: 127
    output >> ----------------------------------------------------------------------

    --------------------------------------------------------------------------------
    error >> -----------------------------------------------------------------------
    sed: -e expression #1, char 0: no previous regular expression
    bash: rm: No such file or directory
    bash: mkdir: No such file or directory

    --------------------------------------------------------------------------------


    • Edited by Kevin54M Wednesday, April 19, 2017 10:15 PM
    Wednesday, April 19, 2017 10:03 PM