none
Old Collections Still Showing RRS feed

  • Question

  • I recently setup a RD Web Access server with all roles on one server (RD Session Host, Connection Broker, Licensing, and Web Access) and initially as a POC published Notepad, Paint, and Internet Explorer. Later I removed that collection and created a new one with different apps however the original collection which does nto even show up in Server Manager is still being displayed as icons on my RD Web Access page and do not work. The apps on my new collection show up and do work correctly but I would like to clean up the page to remove the old collection icons. 

    Has anyone else had an issue with previously published apps icon's remaining on the RD Web Access page even though they have been removed and the collection deleted.

    Monday, April 29, 2013 6:45 PM

Answers

  • Hi,

    On your RD Connection Broker, please check the following location and remove the registry key (after backing it up) that corresponds to your old collection:

    HKLM\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ Terminal Server\ CentralPublishedResources\ PublishedFarms\ <CollectionName>

    Thanks.

    -TP

    • Marked as answer by Striker169 Wednesday, May 1, 2013 1:29 PM
    Monday, April 29, 2013 7:04 PM
    Moderator

All replies

  • Hi,

    On your RD Connection Broker, please check the following location and remove the registry key (after backing it up) that corresponds to your old collection:

    HKLM\ SOFTWARE\ Microsoft\ Windows NT\ CurrentVersion\ Terminal Server\ CentralPublishedResources\ PublishedFarms\ <CollectionName>

    Thanks.

    -TP

    • Marked as answer by Striker169 Wednesday, May 1, 2013 1:29 PM
    Monday, April 29, 2013 7:04 PM
    Moderator
  • Hi there,

    From the powershell shell, could you launch the following cmdlets :

    Get-RDVirtualDesktopCollection
    Get-RDSessionCollection

    Do you see the old collection?

    Cheers,

    Sam

    Monday, April 29, 2013 7:05 PM
  • This was it, the old collection was still in the registry! Why was it not removed when I removed the collection though?
    Wednesday, May 1, 2013 1:28 PM
  • I also am having this issue with TS 2012.  However, I do not see the keys that you are referring to.  I get as far as HKLM\SOFTWARE\Microsoft\Windows NT\CurrentVersion\Terminal Server and then I have under that: CompatibilityInstallTSAppAllowList and UnifiedApiData.  Is there something I missed?  I checked those and they don't seem to have anything of interest.

    I don't mind someone marking a post as "Proposed as answer", but DO NOT mark it as "Answered". If I am the OP, I will decide if a post actually answers my post or not. Thank you.

    Thursday, October 17, 2019 5:56 PM
  • When I tried those two commands I get:

    Get-RDVirtualDesktopCollection : A Remote Desktop Services deployment does not exist on XenApp-w2.supporttest.local. This operation can be performed after creating a deployment. For information about creating a deployment, run "Get-Help New-RDVirtualDesktopDeployment" or "Get-Help New-RDSessionDeployment".

    and

    Get-RDSessionCollection : A Remote Desktop Services deployment does not exist on XenApp-w2.supporttest.local. This operation can be performed after creating a deployment. For information about creating a deployment, run "Get-Help New-RDVirtualDesktopDeployment" or "Get-Help New-RDSessionDeployment".


    I don't mind someone marking a post as "Proposed as answer", but DO NOT mark it as "Answered". If I am the OP, I will decide if a post actually answers my post or not. Thank you.

    Thursday, October 17, 2019 6:03 PM