SCOM Discovery not working RRS feed

  • Question

  • Hello to all,

    I'm new to SCOM and I have a problem, even tought I serached the forum I couldn't find an answer; I installed SCOM R2 in a test environment (for now), fresh install; database it's on a separate box running SQL 2008 Ent SP1 x64; all servers are running 2008 R2; after the instalation I tried to discover some computers on my test network (dc, sql server, exchange 2010, and a windows 7 wsk) but the discovery progress bar it's not stopping so I had to cancel it; I used the Active Directory discovery and the "Browse for..." option, but no results (I am using the domain admin user account to scan); I cheked the sql broker using this command     SELECT is_broker_enabled FROM sys.databases WHERE name='OperationsManager'   and it's all fine; no errors in EventViewer

    So...can someone help me ?

    Thanks in advance

    Sunday, April 10, 2011 5:49 PM


All replies

  • Monday, April 11, 2011 1:31 AM
  • Thanks for the reply but none of those pages helped me; I have no erros in EventViewer and firewall is off on all servers;


    Monday, April 11, 2011 12:29 PM
  • Hi Adrian,

    in the discovery wizard go for windows discovery -> Use advanced discovery (leave the default of servers and clients and leave the last checkbox unchecked) -> next one of the following:

    - brose for and go check if you see the domain and if you see OU levels below it. For instance the domain controllers OU and after that type the first character of the server name and select check names. you should get a popup with servers or it should give you back the server you want.

    - the other option is to scan active directory. click the Configure button and without touching anything just click OK. You will see the change it makes in your screen. domain should be selected and discover.

    In both cases just to be sure use a domain admin account and password to scan, enter it manually there. You should get a list of machines to monitor there.

    If you can not see anything there, please check your servers are member of the domain and can talk to domain controllers and machines. Let us know what happens.


    Bob Cornelissen - BICTT (My BICTT Blog)
    Monday, April 11, 2011 4:59 PM
  • Hi Bob,

    I already tried those things for so many times and are working perfectly; I can see all the OUs in the domain, the check names button it's showing all the computers that starts with the letters I type. I did a couple of fresh new installs but it's the same; and like I sad, for discovery I'm using the domain/enterprise administrator (since it's a test enviroment).

    Monday, April 11, 2011 6:04 PM
  • But yet even though you can select the machines in those views and you continue the discovery you do not get the opportunity to check the checkboxes and finish the agent deployment?

    Well firewalls and stuff like that come to mind.

    The other thing that comes to mind is that if SCOM already knows the machines (in that case they will not show up in the later screens of the discovery). SO check the agent-managed and the pending management in the scom administration pane. Perhaps they are there somewhere. If they are just reject them and try discovery again.

    Bob Cornelissen - BICTT (My BICTT Blog)
    Monday, April 11, 2011 6:31 PM
  • It's not that either....the pending management and administration pane are empty.

    Anyway I started reding a book from Sybex about SCOM, maybe than I will work it out, but if someone has a clue...please let me know


    Tuesday, April 12, 2011 5:59 AM

    In addition, please also check the issue referring to the following post:


    Having trouble discovering computers using the OpsMgr 2007 Discovery Wizard?



    Hope this helps.



    Nicholas Li - MSFT
    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.
    Tuesday, April 12, 2011 8:38 AM
  • Nichloas I read the blog that you provide but those things are working for me, I dont have network, name resolution etc... problems; I just installed SCOM on Windows Server 2008 x64 (not R2 like previous example) but it's not working either. I dont get it...


    I finally made it work. All I had to do is change the SCOM database owner to SA (  http://social.technet.microsoft.com/Forums/en-US/operationsmanagergeneral/thread/0d76679f-a6ae-4b41-bae8-5477d905a160/  ); this is the Microsoft way ...

    Thaks guys for your help

    • Marked as answer by adrian.costea Wednesday, April 13, 2011 12:07 PM
    Wednesday, April 13, 2011 11:42 AM
  • Thanks for posting this. I took over administrating SCOM for our company and had been struggling with this. It worked on one server for a different group, but not on this one. They were setup by the same people, so I thought they would be setup the same. Apparently not as this resolved my issue as well. THANKS!
    Friday, June 29, 2012 6:23 PM