none
Error (2916) VMM is unable to complete the request. The connection to the agent SERVER.domain.se was lost. RRS feed

  • Question

  • OS: Window 2K8 x64

    SCVMM 2008

    SQL Server 2008 Enterprise

     

    Im trying to add a secondary Hyper-V Host to VMM 2008.

     

    Then i get:

     

    Error (2916)

    VMM is unable to complete the request. The connection to the agent SERVER.domain.se was lost.

    (Unknown error (0x80338012))

    Recommended Action

    Ensure that the WS-Management service and the agent are installed and running and that a firewall is not blocking HTTP traffic. If the error persists, reboot SERVER.domain.se and then try the operation again.

     

    Firewalls are disabled

    VMM Server is running on a machine with the first Hyper-V host and there is no problem with that one.

    WS-Management service is running

    Server restarted

     

    Problem number two.

     

    On the first Hyper-V host the VMM Manager crashes when i start it.

     

    Description:

    Stopped working

    Problem signature:

    Problem Event Name: CLR20r3

    Problem Signature 01: vmmadmin.exe

    Problem Signature 02: 1.0.523.0

    Problem Signature 03: 48e73916

    Problem Signature 04: Microsoft.SystemCenter.VirtualMachineManager

    Problem Signature 05: 1.0.523.0

    Problem Signature 06: 48e73886

    Problem Signature 07: 173

    Problem Signature 08: 2c

    Problem Signature 09: YY3RXWYE3VB0TP0KBPIS3NPQBBINDMF1

    OS Version: 6.0.6001.2.1.0.274.10

    Locale ID: 1053

    Read our privacy statement:

    http://go.microsoft.com/fwlink/?linkid=50163&clcid=0x0409

    Thursday, October 23, 2008 4:41 PM

Answers

All replies

  • For problem number one (unable to add host and connect is lost), it seems that you are having a WinRM issue:

     

    C:\Users\chengwei>winrm helpmsg 0x80338012
    The client cannot connect to the remote host specified in the request. Verify that

    the service on the remote host is running and is accepting requests. You may
    use the following command to analyze the state of the WinRM service and to

    configure the service, if necessary: "winrm quickconfig".

     

    Here is what I typically recommend people do when they hit this issue:

    o   This error indicates that the WinRM service on the host is not responding as what the VMM Server expects.

    o   Besides the basic diagnostic advices VMM team typically gives (check to make sure WinRM service is running, Listner is configured, firewall is not blocking the HTTP port, etc.), your best option is to contact WinRM team and get their expertise to exam the host to see why the WinRM service is not responding.

     

    These two blog entries may help:

    http://blogs.technet.com/chengw/archive/2008/05/02/what-to-do-when-i-have-host-in-needs-attention-state-or-my-connection-status-is-not-responding.aspx

    http://blogs.technet.com/chengw/archive/2008/07/30/what-else-can-i-do-when-my-host-is-in-not-responding-state.aspx

     

    If none of them helps, you may need to collect VMM server side AND host side traces for us to further diagnose your issue.

     

    Hope this helps.

     

    Thanks!

    Cheng

    http://blogs.technet.com/chengw
    Thursday, October 23, 2008 5:35 PM
  • Problem one solved.

     

    Host number two was listening on the wrong port.

     

    Thank you so much for your answer Cheng.

    Thursday, October 23, 2008 6:30 PM
  •  

    Problem number two solved.

     

    After I installed KB958644 and restarted the server the VMM Admin console worked. 

    • Proposed as answer by Jean M Thursday, February 13, 2014 7:28 AM
    Friday, October 24, 2008 7:22 PM
  • hi, Can you tell me how you figure out that its running on wrong port and how did you fixed it?

    Vaibhav
    vaibhav
    Wednesday, April 1, 2009 2:24 PM
  • The two blog entries:

    Could you please update?

    Thank you. 



    Always read the available doco!

    Friday, April 19, 2013 12:55 PM
  • 1.- Agent updated to versión RU 2. 3.1.6020.0.

    2.- SCVMMAgnet, WinRm and vmm services running.

    3.- One cluster, with two nodes. Node 1 and 2 are identical. The installation on both nodes are indentica. First installed Node 1, them i syspreped and cloned, with array.

    4.- The recomendatio it's, check the service status, and later restart he computer.

    5.- Here i leave some cuestions for if someone can aswer me, or help to check it.

    Cuestion number one.

    I start NetworkMonitor. Set a filter to capture http trafic betewen my vmm server and host. I obtay a http trafic.

    The VMM server try use CredSSP Authorization. and the WinRM Servicer on the host it's permited the use of CredSSP.

    but i obtain Status Code 401, Unauthorized.

    Cuestión 2.

    If i read the error from SCVMM say:

    The connection to the agent TCVIRTUAL208.servername.es  was lost.

    WinRM: URL: [http://tcvirtual208.servername.es:5985], Verb: [ENUMERATE], Resource: [http://schemas.microsoft.com/wbem/wsman/1/wmi/root/cimv2/Win32_Service], Filter: [select * from Win32_Service where Name="WinRM"]

    Unknown error (0x80338012)

    well. I use wbemtest from vmm server. And execute the query "Select * from Win32_Service Where Name="WinRM" and obtain a error RPC.

    The node that it's  right, i can make de query, and return rightly.

    Many suggestions is wellcome. thanks.

    Monday, May 27, 2013 11:34 AM