locked
Disable OWA & ActiveSync as default for new users RRS feed

  • Question

  • Hi all, can anyone tell me whether I can disable OWA and ActiveSync as default for all new users? I've had a good look around for a relavent policy but can't find anything.

    Thanks

    Monday, July 18, 2011 2:57 PM

Answers

  • Hello,

     

    To meet your requirement, you need to use the following command to create the new user:

     

    New-Mailbox xxxx  |  Set-CASMailbox -ActivesyncEnabled false -owaenabled false

     

    Thanks,

    Simon

    Wednesday, July 20, 2011 9:05 AM

All replies

  • Set-CASMailbox -Identity xxx@domain.com -ActivesyncEnabled:$false -owaenabled:$false

    There are plenty of scripts as well, if you google.

     

    • Proposed as answer by TimButts Thursday, January 17, 2013 7:22 PM
    Monday, July 18, 2011 3:02 PM
  • Thanks I have Googled it but as per your script above it's on a user by user basis, I'm looking to see whether I can disable them as default for all users via a policy. If not I'll change the default via ADSI Edit.
    Monday, July 18, 2011 3:07 PM
  • To clarify when I create a new user via EMC I want OWA and ActiveSync to be disabled as default, if possible?
    Monday, July 18, 2011 3:13 PM
  • GUI version:

    1. Open the Exchange Management Console.

    2. Under Recipient Configuration, select Mailbox.

    3. Select Properties from the action pane or right-click the user's mailbox, and then click Properties.

    4. Click the Mailbox Features tab.

    5. Select Exchange ActiveSync, and then click Disable.

    6. Click OK. ,

    7.  reapet for owa

      There is no global policy. I am assuming you want to allow owa and activesync for otehr users.If you want to disable for all users then disable in IIS. Powershell provides most flexibility. Create mailboxes with powershell and then pipe it set-casmailbox cmdlet I provided.

    Monday, July 18, 2011 3:22 PM
  • No by default its not possible, you will have to run that command given by LMurthy.


    Gulab | MCITP: Exchange 2010-2007 | Skype: Gulab.Mallah | Blog: www.ExchangeRanger.Blogspot.com
    Monday, July 18, 2011 3:24 PM
  • GUI version:

    1. Open the Exchange Management Console.

    2. Under Recipient Configuration, select Mailbox.

    3. Select Properties from the action pane or right-click the user's mailbox, and then click Properties.

    4. Click the Mailbox Features tab.

    5. Select Exchange ActiveSync, and then click Disable.

    6. Click OK. ,

    7.  reapet for owa

      There is no global policy. I am assuming you want to allow owa and activesync for otehr users.If you want to disable for all users then disable in IIS. Powershell provides most flexibility. Create mailboxes with powershell and then pipe it set-casmailbox cmdlet I provided.


    Thanks for your reply, shame it can't be done globally.
    Monday, July 18, 2011 3:24 PM
  • Hello,

     

    To meet your requirement, you need to use the following command to create the new user:

     

    New-Mailbox xxxx  |  Set-CASMailbox -ActivesyncEnabled false -owaenabled false

     

    Thanks,

    Simon

    Wednesday, July 20, 2011 9:05 AM
  • As our other friends said, I dont see any global option to disable the OWA an ActiveSync.

    If your activesync/owa published via TMG, you could restrict the access via Groups.

    You can create Domain Local group as OWA_Users and ActiveSync_Users - and you can publish the policy only for the users from these grups (by default policy publish for all users or all authenticated users.)

    if you dont have TMG, you can edit the permissions of OWA and ActiveSync Virtual Directory - By default "Authenticated Users" have read permission - you can change that to OWA_Users/ActiveSync_Users accordingly.

    Whoeever need access you can add them to those groups.

     

    To disable OWA and ActiveSync for all existing mailbox you can user powershell

    get-mailbox | set-casmailmox -activesyncenabled:$false -owaenabled:$false

     

    To enable OWA for the users in group OWA_Users..

    Get-ADGroupMember OWA_Users | %($name) {Get-Mailbox $_.name | set-casmailbox -OWAEnabled:$True

     


    Thanks & Regards, Sandheep [...:::""I can't do it" never yet accomplished anything; "I will try" has performed wonders ":::...]
    Wednesday, July 20, 2011 11:12 AM
  • Yes it is possible and it's quite easy - check Scripting Agent

    Here is an example - http://bit.ly/lZjJbU

    I did same in my environment for enabling SingeItemRecovery

    Just keep in mind that you have to copy ScriptingAgentConfig.xml (eg D:\Program Files\Microsoft\Exchange Server\V14\Bin\CmdletExtensionAgents\ScriptingAgentConfig.xml) to each Exchange Server (even if you do not run commands from all servers) because it may cause problem with updates/rollups

    Vojin

    • Proposed as answer by Vojin Lekovic Saturday, July 23, 2011 7:44 AM
    Saturday, July 23, 2011 7:44 AM
  • HI there

    Yes this is perfectly possible and very easy to do.

    There is a really very handy feature in Exchange 2010 that Microsoft have barely documented and therefore goes, for the most part, unused and forgotten, it is called the cmdlet extension agent.

    You can look at the very sparse bit of Microsoft help in the form of the following file C:\Program Files\Microsoft\Exchange Server\V14\Bin\CmdletExtensionAgents\ScriptingAgentConfig.xml.SAMPLE, which gives you basic instructions to use as a base, all of which will confirm the instructions I give below.

    To just disable Active-Sync, follow these 2 very simple steps, it should be very easy to modify this to include OWA by simply adding -owaenabled $false but I have not personally tested that so I won't add it to the code I post here, which I HAVE tested and verified myself.

    1 : Copy and paste the code below into notepad, save the file as ScriptingAgentConfig.xml into the directory mentioned above

    2 : run the following Exchange shell command. Enable-CmdletExtensionAgent "Scripting Agent"

    Thats it. Hope this helps.

    <?xml version="1.0" encoding="utf-8" ?>
    <Configuration version="1.0">
     <Feature Name="MailboxProvisioning" Cmdlets="enable-mailbox">
      <ApiCall Name="OnComplete">
       if($succeeded)
        {
        $user = (Get-User $provisioningHandler.UserSpecifiedParameters["Identity"]).distinguishedName
        Set-CASMailbox $user -ActiveSyncEnabled $false
        }
      </ApiCall>
     </Feature>
     <Feature Name="MailboxProvisioning" Cmdlets="new-mailbox">
      <ApiCall Name="OnComplete">
       if($succeeded)
       {
       $user = (Get-User $provisioningHandler.UserSpecifiedParameters["Name"]).distinguishedName
       Set-CASMailbox $user -ActiveSyncEnabled $false
       }
      </ApiCall>
     </Feature>
    </Configuration>

    • Proposed as answer by steve siyavaya Tuesday, February 14, 2012 11:42 AM
    Tuesday, February 14, 2012 11:37 AM
  • That is good information David!
    Tuesday, February 14, 2012 11:43 AM
  • No by default its not possible, you will have to run that command given by LMurthy.


    Gulab | MCITP: Exchange 2010-2007 | Skype: Gulab.Mallah | Blog: www.ExchangeRanger.Blogspot.com

    Er.. its very possible. Use CmdLet Extension Agents.

    • Proposed as answer by Jonathan Deane Monday, September 22, 2014 6:37 PM
    Friday, March 9, 2012 2:24 PM
  • This works great, but would like to also be able to 'copy' an existing AD user who might already have EAS enabled(in order to copy SG&DL's), but have the new user's EAS diasbled by default ?

    thx, ~~Robb

    Thursday, March 22, 2012 9:54 PM
  • Pitarobb, If you run this, it will disable ActiveSync for your existing users: 

    get-Mailbox | set-CASMailbox -ActiveSyncEnabled:$False

    I'd run that first, then set your defaults per David's instructions above.  Hope that helps. 

    Thursday, April 5, 2012 3:27 PM
  • Hi, I wonder if anyone can help please. I tried running the script below using the Enable-CmdletExtensionAgent command and it broke our EMC. When trying to open EMC the following error comes up:- "unexpected error 0x784F46EB while executing command Get-LogonUser"

    The only way I was able to rectify this was to delete the ScriptingAgentConfig.xml file and run Disable-CmdletExtensionAgent! Has anyone else come across this and might know what is causing it? We would really like to have the ability to disable ActiveSync for all users

    We are running Exchange 2010 SP2.

    Thanks

    HI there

    Yes this is perfectly possible and very easy to do.

    There is a really very handy feature in Exchange 2010 that Microsoft have barely documented and therefore goes, for the most part, unused and forgotten, it is called the cmdlet extension agent.

    You can look at the very sparse bit of Microsoft help in the form of the following file C:\Program Files\Microsoft\Exchange Server\V14\Bin\CmdletExtensionAgents\ScriptingAgentConfig.xml.SAMPLE, which gives you basic instructions to use as a base, all of which will confirm the instructions I give below.

    To just disable Active-Sync, follow these 2 very simple steps, it should be very easy to modify this to include OWA by simply adding -owaenabled $false but I have not personally tested that so I won't add it to the code I post here, which I HAVE tested and verified myself.

    1 : Copy and paste the code below into notepad, save the file as ScriptingAgentConfig.xml into the directory mentioned above

    2 : run the following Exchange shell command. Enable-CmdletExtensionAgent "Scripting Agent"

    Thats it. Hope this helps.

    <?xml version="1.0" encoding="utf-8" ?>
    <Configuration version="1.0">
     <Feature Name="MailboxProvisioning" Cmdlets="enable-mailbox">
      <ApiCall Name="OnComplete">
       if($succeeded)
        {
        $user = (Get-User $provisioningHandler.UserSpecifiedParameters["Identity"]).distinguishedName
        Set-CASMailbox $user -ActiveSyncEnabled $false
        }
      </ApiCall>
     </Feature>
     <Feature Name="MailboxProvisioning" Cmdlets="new-mailbox">
      <ApiCall Name="OnComplete">
       if($succeeded)
       {
       $user = (Get-User $provisioningHandler.UserSpecifiedParameters["Name"]).distinguishedName
       Set-CASMailbox $user -ActiveSyncEnabled $false
       }
      </ApiCall>
     </Feature>
    </Configuration>


    Thursday, August 2, 2012 4:23 PM
  • This has now been resolved, it appeared to be due to a corrupt xml file!

    Hi, I wonder if anyone can help please. I tried running the script below using the Enable-CmdletExtensionAgent command and it broke our EMC. When trying to open EMC the following error comes up:- "unexpected error 0x784F46EB while executing command Get-LogonUser"

    The only way I was able to rectify this was to delete the ScriptingAgentConfig.xml file and run Disable-CmdletExtensionAgent! Has anyone else come across this and might know what is causing it? We would really like to have the ability to disable ActiveSync for all users

    We are running Exchange 2010 SP2.

    Thanks

    HI there

    Yes this is perfectly possible and very easy to do.

    There is a really very handy feature in Exchange 2010 that Microsoft have barely documented and therefore goes, for the most part, unused and forgotten, it is called the cmdlet extension agent.

    You can look at the very sparse bit of Microsoft help in the form of the following file C:\Program Files\Microsoft\Exchange Server\V14\Bin\CmdletExtensionAgents\ScriptingAgentConfig.xml.SAMPLE, which gives you basic instructions to use as a base, all of which will confirm the instructions I give below.

    To just disable Active-Sync, follow these 2 very simple steps, it should be very easy to modify this to include OWA by simply adding -owaenabled $false but I have not personally tested that so I won't add it to the code I post here, which I HAVE tested and verified myself.

    1 : Copy and paste the code below into notepad, save the file as ScriptingAgentConfig.xml into the directory mentioned above

    2 : run the following Exchange shell command. Enable-CmdletExtensionAgent "Scripting Agent"

    Thats it. Hope this helps.

    <?xml version="1.0" encoding="utf-8" ?>
    <Configuration version="1.0">
     <Feature Name="MailboxProvisioning" Cmdlets="enable-mailbox">
      <ApiCall Name="OnComplete">
       if($succeeded)
        {
        $user = (Get-User $provisioningHandler.UserSpecifiedParameters["Identity"]).distinguishedName
        Set-CASMailbox $user -ActiveSyncEnabled $false
        }
      </ApiCall>
     </Feature>
     <Feature Name="MailboxProvisioning" Cmdlets="new-mailbox">
      <ApiCall Name="OnComplete">
       if($succeeded)
       {
       $user = (Get-User $provisioningHandler.UserSpecifiedParameters["Name"]).distinguishedName
       Set-CASMailbox $user -ActiveSyncEnabled $false
       }
      </ApiCall>
     </Feature>
    </Configuration>



    Friday, August 3, 2012 11:01 AM
  • HI there

    Yes this is perfectly possible and very easy to do.

    There is a really very handy feature in Exchange 2010 that Microsoft have barely documented and therefore goes, for the most part, unused and forgotten, it is called the cmdlet extension agent.

    You can look at the very sparse bit of Microsoft help in the form of the following file C:\Program Files\Microsoft\Exchange Server\V14\Bin\CmdletExtensionAgents\ScriptingAgentConfig.xml.SAMPLE, which gives you basic instructions to use as a base, all of which will confirm the instructions I give below.

    To just disable Active-Sync, follow these 2 very simple steps, it should be very easy to modify this to include OWA by simply adding -owaenabled $false but I have not personally tested that so I won't add it to the code I post here, which I HAVE tested and verified myself.

    1 : Copy and paste the code below into notepad, save the file as ScriptingAgentConfig.xml into the directory mentioned above

    2 : run the following Exchange shell command. Enable-CmdletExtensionAgent "Scripting Agent"

    Thats it. Hope this helps.

    <?xml version="1.0" encoding="utf-8" ?>
    <Configuration version="1.0">
     <Feature Name="MailboxProvisioning" Cmdlets="enable-mailbox">
      <ApiCall Name="OnComplete">
       if($succeeded)
        {
        $user = (Get-User $provisioningHandler.UserSpecifiedParameters["Identity"]).distinguishedName
        Set-CASMailbox $user -ActiveSyncEnabled $false
        }
      </ApiCall>
     </Feature>
     <Feature Name="MailboxProvisioning" Cmdlets="new-mailbox">
      <ApiCall Name="OnComplete">
       if($succeeded)
       {
       $user = (Get-User $provisioningHandler.UserSpecifiedParameters["Name"]).distinguishedName
       Set-CASMailbox $user -ActiveSyncEnabled $false
       }
      </ApiCall>
     </Feature>
    </Configuration>

    So this will set the the defaults for newly created users and their mailboxes but won't affect current users?

    I would like to setup the defaults but not affect current activesync users

    Wednesday, April 10, 2013 5:45 PM
  • So this will set the the defaults for newly created users and their mailboxes but won't affect current users?

    I would like to setup the defaults but not affect current activesync users

    Wednesday, April 10, 2013 5:46 PM
  • Correct - the scripting agent file will hook to only the cmdlets that you tell it. 

    So it will only fire for enable-mailbox as per your example above.


    Cheers,

    Rhoderick

    Microsoft Senior Exchange PFE

    Blog: http://blogs.technet.com/rmilne  Twitter:   LinkedIn:   Facebook:   XING:

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Wednesday, April 10, 2013 6:23 PM
  • Thanks for the response. But when enabled on all my mailbox servers and the CA server and I create a new user mailbox I get an error stating

    "The cmdlet extention agent has thrown an exception in onComplete":The exception is: Microsoft.Exchange.Provisioning.ProvisioningException: ScriptingAgent: Exception thrown while invoking scriptlet for OnComplete API: The operation couldn't be performed because object 'contoso.com/User Accounts/Mike Test1' couldn't be found on  dc08.contoso.com

    My enviroment has multiple domain controllers... 

    Wednesday, April 10, 2013 6:39 PM
  • Yup - likely due to hitting different DCs.   This is what I do to resolve this, I save the original DC from the create mailbox call and then pass that to all the remaining cmdlets.  This way you do not have to statically hardcode a DC.

     
                    $DC = [string]($readOnlyIConfigurable.originatingserver)
                    $newmailbox = $provisioningHandler.UserSpecifiedParameters["Name"]
                    set-mailbox -Identity $Newmailbox -SingleItemRecoveryEnabled $True -DomainController $DC.domain.com


    Cheers,

    Rhoderick

    Microsoft Senior Exchange PFE

    Blog: http://blogs.technet.com/rmilne  Twitter:   LinkedIn:   Facebook:   XING:

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Wednesday, April 10, 2013 6:55 PM
  • I should add that code to the existing xml file?
    Wednesday, April 10, 2013 7:23 PM
  • yes.

    Cheers,

    Rhoderick

    Microsoft Senior Exchange PFE

    Blog: http://blogs.technet.com/rmilne  Twitter:   LinkedIn:   Facebook:   XING:

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Wednesday, April 10, 2013 7:24 PM
  • My apologies for the trouble but I'm terrible with powershell. This is the code I have on the xml file:

    <?xml version="1.0" encoding="utf-8" ?>
    <Configuration version="1.0">
     <Feature Name="MailboxProvisioning" Cmdlets="enable-mailbox">
      <ApiCall Name="OnComplete">
       if($succeeded)
        {
        $user = (Get-User $provisioningHandler.UserSpecifiedParameters["Identity"]).distinguishedName
        Set-CASMailbox $user -ActiveSyncEnabled $false
        }
      </ApiCall>
     </Feature>
     <Feature Name="MailboxProvisioning" Cmdlets="new-mailbox">
      <ApiCall Name="OnComplete">
       if($succeeded)
       {
       $user = (Get-User $provisioningHandler.UserSpecifiedParameters["Name"]).distinguishedName
       Set-CASMailbox $user -ActiveSyncEnabled $false
       }
      </ApiCall>
     </Feature>
    </Configuration> 

    Where would I place your block of code?

    Thanks so much for your help.

    Wednesday, April 10, 2013 7:28 PM
  • Any help with this? Where would I put this block of code:

     $DC = [string]($readOnlyIConfigurable.originatingserver)
                    $newmailbox = $provisioningHandler.UserSpecifiedParameters["Name"]
                    set-mailbox -Identity $Newmailbox -SingleItemRecoveryEnabled $True -DomainController $DC.domain.com

    on the xml file above?

    Thanks


    Thursday, April 11, 2013 1:16 PM
  • Anyone ..?
    Thursday, April 11, 2013 11:06 PM
  • The following example sets singleitemrecovery and some calendar permissions:


    Be sure to change domain.com

    <?xml version="1.0" encoding="utf-8" ?>
    <Configuration version="1.0">
      <Feature Name="NewMailbox" Cmdlets="new-Mailbox">
       <ApiCall Name="OnComplete">
        if($succeeded)    {
                    Start-sleep 20
                    $DC = [string]($readOnlyIConfigurable.originatingserver)
                    $newmailbox = $provisioningHandler.UserSpecifiedParameters["Name"]
                    set-mailbox -Identity $Newmailbox -SingleItemRecoveryEnabled $True -DomainController $DC.domain.com

                    $AccessRights = "Reviewer"
                    $mailbox = Get-Mailbox $newmailbox
                    $calendar = (($mailbox.SamAccountName)+ ":\" + (Get-MailboxFolderStatistics -Identity $mailbox.SamAccountName -FolderScope Calendar | Select-Object -First 1).Name)
                    Set-MailboxFolderPermission -User "Default" -AccessRights $AccessRights -Identity $calendar -DomainController $DC.domain.com
                   
        }
       </ApiCall>
      </Feature>
      <Feature Name="EnableMailbox" Cmdlets="enable-Mailbox">
       <ApiCall Name="OnComplete">
        if($succeeded)    {
                    Start-sleep 20
                    $DC = [string]($readOnlyIConfigurable.originatingserver)
                    $newmailbox = $provisioningHandler.UserSpecifiedParameters["Identity"]
                    set-mailbox -Identity "$newmailbox" -SingleItemRecoveryEnabled $True -DomainController $DC.domain.com

                    $AccessRights = "Reviewer"
                    $mailbox = Get-Mailbox -identity "$newmailbox"
                    $calendar = (($mailbox.SamAccountName)+ ":\" + (Get-MailboxFolderStatistics -Identity $mailbox.SamAccountName -FolderScope Calendar | Select-Object -First 1).Name)
                    Set-MailboxFolderPermission -User "Default" -AccessRights $AccessRights -Identity $calendar -DomainController $DC.domain.com
        }
       </ApiCall>
      </Feature>
    </Configuration>


    Cheers,

    Rhoderick

    Microsoft Senior Exchange PFE

    Blog: http://blogs.technet.com/rmilne  Twitter:   LinkedIn:   Facebook:   XING:

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Thursday, April 11, 2013 11:41 PM
  • Note that this example is for a different purpose.

    Make sure you edit and test it !!!!


    Cheers,

    Rhoderick

    Microsoft Senior Exchange PFE

    Blog: http://blogs.technet.com/rmilne  Twitter:   LinkedIn:   Facebook:   XING:

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Thursday, April 11, 2013 11:42 PM
  • Yes, of course... Thanks a bunch .... !!! I'll test tomorrow and reply to this thread
    Friday, April 12, 2013 12:39 AM
  • I still got the error where it time out looking for the user across my multi domain controller forest

    This is my code... any errors you guys can see?

    <?xml version="1.0" encoding="utf-8" ?>
    <Configuration version="1.0">
     <Feature Name="MailboxProvisioning" Cmdlets="enable-mailbox">
      <ApiCall Name="OnComplete">
       if($succeeded)
        {
    $DC = [string]($readOnlyIConfigurable.originatingserver)
        $newmailbox = $provisioningHandler.UserSpecifiedParameters["Name"]
        set-mailbox -Identity $Newmailbox -SingleItemRecoveryEnabled $True -DomainController $DC.domain.com
        $user = (Get-User $provisioningHandler.UserSpecifiedParameters["Identity"]).distinguishedName
        Set-CASMailbox $user -ActiveSyncEnabled $false
        }
      </ApiCall>
     </Feature>
     <Feature Name="MailboxProvisioning" Cmdlets="new-mailbox">
      <ApiCall Name="OnComplete">
       if($succeeded)
       {
       $user = (Get-User $provisioningHandler.UserSpecifiedParameters["Name"]).distinguishedName
       Set-CASMailbox $user -ActiveSyncEnabled $false
       }
      </ApiCall>
     </Feature>
    </Configuration> 


    Monday, April 15, 2013 6:17 PM
  • I got it working with this script.  

    No need to add the block of code for the domain controller.  I got it working with this:

    (just adding a start delay string of 20 seconds)

    <?xml version="1.0" encoding="utf-8" ?>
    <Configuration version="1.0">
     <Feature Name="MailboxProvisioning" Cmdlets="enable-mailbox">
      <ApiCall Name="OnComplete">


    <?xml version="1.0" encoding="utf-8" ?>
    <Configuration version="1.0">
        <Feature Name="MailboxProvisioning" Cmdlets="new-mailbox,enable-mailbox">
     
             <ApiCall Name="OnComplete">
                  if($succeeded) 
      {
      Start-sleep 20
                   Set-Mailbox $provisioningHandler.UserSpecifiedParameters["Alias"] -SingleItemRecoveryEnabled $true
                   Set-CASMailbox $provisioningHandler.UserSpecifiedParameters["Alias"] -ActiveSyncEnabled $false
                   }
             </ApiCall>
         </Feature>
    </Configuration>

    Tuesday, April 16, 2013 7:01 PM
  • Yup - likely due to hitting different DCs.   This is what I do to resolve this, I save the original DC from the create mailbox call and then pass that to all the remaining cmdlets.  This way you do not have to statically hardcode a DC.

     
                    $DC = [string]($readOnlyIConfigurable.originatingserver)
                    $newmailbox = $provisioningHandler.UserSpecifiedParameters["Name"]
                    set-mailbox -Identity $Newmailbox -SingleItemRecoveryEnabled $True -DomainController $DC.domain.com


    Cheers,

    Rhoderick

    Microsoft Senior Exchange PFE

    Blog: http://blogs.technet.com/rmilne  Twitter:   LinkedIn:   Facebook:   XING:

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    I wrote a blog post subsequent to this.

    Post is here for future reference

    http://blogs.technet.com/b/rmilne/archive/2014/06/24/exchange-scripting-agent-_2d00_-the-power-of-script.aspx


    Cheers,

    Rhoderick

    Microsoft Senior Exchange PFE

    Blog: http://blogs.technet.com/rmilne  Twitter:   LinkedIn:   Facebook:   XING:

    Note: Posts are provided “AS IS” without warranty of any kind, either expressed or implied, including but not limited to the implied warranties of merchantability and/or fitness for a particular purpose.

    Friday, November 7, 2014 2:03 AM