none
Installation error on SCOM 2019 RRS feed

  • Question

  • Hi All,

    I am trying to install SCOM 2019 on Windows Server 2019 OS. My SQL DB and DWs are also installed on OS2019 and SQL version 2017. I have enabled TLS 1.0 and TLS 1.2 via registry in both the management server and the DBs as well. However I am receiving the below error message when I try to install.

    ==========================================

    [17:32:35]: Error: :PopulateUserRoles: failed : Threw Exception.Type: System.ArgumentException, Exception Error Code: 0x80070057, Exception.Message: Value does not fall within the expected range.
    [17:32:35]: Error: :StackTrace:   at Microsoft.Mom.Sdk.UserRoleSetup.SetupProgram.populateUserRoles(String adminRoleGroup, String sdkAccount, InstallTypes installType, String installDirectory, Boolean overwriteExistingUsers)
       at Microsoft.EnterpriseManagement.OperationsManager.Setup.ServerConfiguration.PopulateUserRoles(String adminRoleGroup, String sdkAccount, String installDirPath)
    [17:32:35]: Error: :FATAL ACTION: PopulateUserRoles
    [17:32:35]: Error: :FATAL ACTION: DatabaseActions
    [17:32:35]: Error: :ProcessInstalls: Running the PostProcessDelegate returned false.
    [17:32:35]: Always: :SetErrorType: Setting VitalFailure. currentInstallItem: Database Configuration
    [17:32:35]: Error: :ProcessInstalls: Running the PostProcessDelegate for OMDATABASE failed.... This is a fatal item.  Setting rollback.
    [17:32:35]: Info: :SetProgressScreen: FinishMinorStep.
    [17:32:35]: Always: :!***** Installing: OMSERVER ***
    [17:32:35]: Info: :ProcessInstalls: Rollback is set and we are not doing an uninstall so we will stop processing installs

    ===================================

    Has anybody encountered similar situations and do you know of any fix that I can refer to?


    Thanks, Shreeram

    Wednesday, October 16, 2019 6:54 AM

All replies