locked
how to change Port settings in WSUS RRS feed

  • Question

  • Hi , I've installed WSUS 3.0 , now I want to change the Default Port settings. How can I do it now ?
    Regards, COMDINI
    Saturday, April 2, 2011 6:22 PM

Answers

  • I would unisntall, keep the database and logfiles and install it using the correct ports. After that you also need to modify the component configuration, software update component in the ConfigMgr. console.
    Kent Agerlund | My blogs: http://blog.coretech.dk/author/kea/ and http://scug.dk/ | Twitter @Agerlund | Linkedin: /kentagerlund
    • Marked as answer by comdini Sunday, April 3, 2011 2:40 AM
    Saturday, April 2, 2011 7:21 PM

All replies

  • Is that question related to plain WSUS or the Software Update Point in ConfigMgr?
    Torsten Meringer | http://www.mssccmfaq.de
    Saturday, April 2, 2011 7:18 PM
  • Hi,


    1. If you have already installed SUP, remove it.
    2. On the WSUS Server, open a command promp, go under "c:\program fils\update services\tools" execute this command wsusutil usecustomwebsite true
    This command will create the WSUS custom web site with old content and also the 8530 port.

    3. Install SUP.

     


    Bechir Gharbi | http://myitforum.com/cs2/blogs/bgharbi/
    • Proposed as answer by Petr Kasl Tuesday, October 16, 2012 10:38 AM
    Saturday, April 2, 2011 7:21 PM
  • I would unisntall, keep the database and logfiles and install it using the correct ports. After that you also need to modify the component configuration, software update component in the ConfigMgr. console.
    Kent Agerlund | My blogs: http://blog.coretech.dk/author/kea/ and http://scug.dk/ | Twitter @Agerlund | Linkedin: /kentagerlund
    • Marked as answer by comdini Sunday, April 3, 2011 2:40 AM
    Saturday, April 2, 2011 7:21 PM
  • No need to uninstall anything at all....

    Just follow below steps :

    Environment : Windows Server 2008 R2 with WSUS 3.0 SP2

    1) Go to Start -> RUN -> inetmgr

    2) Go to "WSUS Administration" Site

    3) Under "Edit Site", click on "Bindings"

    3) Change the ports which you required(for e.g. 80), and click OK

    4) Open Registry Editor with Start -> RUN -> regedit

    5) Goto HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Update Services\Server\Setup

    6) Change "Port Number" Value to Required Port No (for e.g. 80)

    7) Goto Command prompt and type following command

    cscript "WSUS Installation Location\Update Services\setup\installselfupdateonport80.vbs

    e.g.

    "cscript "c:\Program Files\Update Services\setup\installselfupdateonport80.vbs"

    C:\Windows\system32>cscript "c:\Program Files\Update Services\setup\installselfupdateonport80.vbs"
    Microsoft (R) Windows Script Host Version 5.8
    Copyright (C) Microsoft Corporation. All rights reserved.

    SetupSelfupdateTree: Finding the index of the Web site on which WUS is installed
    ...
    SetupSelfupdateTree: Leaving GetWUSWebSiteIndex.
    SetupSelfupdateTree: Finding the index of the web site bound to port 80...
    SetupSelfupdateTree: iWebSiteIndex: 2 ServerBindings: :8080:index: 0
    SetupSelfupdateTree: iWebSiteIndex: 179262852 ServerBindings: :80:index: 0
    SetupSelfupdateTree: Found the index of site on Port 80: 179262852
    SetupSelfupdateTree: rootMetabasePath: IIS://LocalHost/W3SVC/179262852/ROOT
    SetupSelfupdateTree: szPort80RootPath=C:\Program Files\Update Services\WebServices\Root\
    SetupSelfupdateTree: iWusWebSiteIndex=179262852 iPort80WebSiteIndex=179262852
    SetupSelfupdateTree: Warning: This is standalone WUS install. No need to do conf
    iguration for SxS install.
    Success: InstallSelfupdateOnPort80 succeeded.

    8) You Have Done It!!!

    :)


    • Edited by ashx Thursday, August 25, 2011 11:55 AM wordwrap
    • Proposed as answer by 鳥毅 Friday, April 10, 2015 6:58 AM
    Thursday, August 25, 2011 11:54 AM
  • Hi All.

    I required the same solution, I installed another package (VMWare vCenter Server) and needed to get Port 80 back. WSUS was already installed; Windows 2008 R2 Standard SP1, WSUS 3.0 SP2.

    The solution that worked for me was a combination of Bechirs' and ashxs'.

    In my case the WSUS web componts were installed under the Default Web Site, so directly chaning the binding on this was not going to work and would break other IIS based application I had in the default site.

    I applied the suggestion from Bechir first and ran;

    On the WSUS Server, open a command promp, go under "c:\program fils\update services\tools" execute this command wsusutil usecustomwebsite true

    This basically moves all WSUS web components from the Default Web Site to a new one named WSUS Administration which then brought it in line with ashx's posting, although, the bindings were already done.

    So, to summarize;

    1. On the WSUS Server, open a command promp, go under "c:\program fils\update services\tools" execute this command wsusutil usecustomwebsite true

    2. Open Registry Editor with Start -> RUN -> regedit

              Goto HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Update Services\Server\Setup

              Change "Port Number" Value to Required Port No (for e.g. 80)

    3. Goto Command prompt and type following command

    cscript "WSUS Installation Location\Update Services\setup\installselfupdateonport80.vbs

    e.g.

    "cscript "c:\Program Files\Update Services\setup\installselfupdateonport80.vbs"

    C:\Windows\system32>cscript "c:\Program Files\Update Services\setup\installselfupdateonport80.vbs"
    Microsoft (R) Windows Script Host Version 5.8
    Copyright (C) Microsoft Corporation. All rights reserved.

    SetupSelfupdateTree: Finding the index of the Web site on which WUS is installed
    ...
    SetupSelfupdateTree: Leaving GetWUSWebSiteIndex.
    SetupSelfupdateTree: Finding the index of the web site bound to port 80...
    SetupSelfupdateTree: iWebSiteIndex: 2 ServerBindings: :8080:index: 0
    SetupSelfupdateTree: iWebSiteIndex: 179262852 ServerBindings: :80:index: 0
    SetupSelfupdateTree: Found the index of site on Port 80: 179262852
    SetupSelfupdateTree: rootMetabasePath: IIS://LocalHost/W3SVC/179262852/ROOT
    SetupSelfupdateTree: szPort80RootPath=C:\Program Files\Update Services\WebServices\Root\
    SetupSelfupdateTree: iWusWebSiteIndex=179262852 iPort80WebSiteIndex=179262852
    SetupSelfupdateTree: Warning: This is standalone WUS install. No need to do conf
    iguration for SxS install.
    Success: InstallSelfupdateOnPort80 succeeded.

    4. You Have Done It!!!

    • Proposed as answer by DScully Wednesday, September 14, 2011 12:35 AM
    Wednesday, September 14, 2011 12:33 AM
  • Genius.  Thanks greatly.  Why anyone would want to reinstall when your instructions are spot on, I'm not sure.

    I followed them on a w2k8 IIS7.5 box and had no issues switching from 8531 to 443.

     


    • Edited by Jake Devros Wednesday, September 28, 2011 6:24 PM
    Wednesday, September 28, 2011 6:23 PM
  • Thanks, This helps a lot !!!
    Thursday, March 14, 2013 11:25 AM
  • Hi ashx

    Where do I find the .vbs file? Is it a script you wrote yourself or where can I get my hands on it?

    Because obviously the file must be in that location when you run the cmd...

    I need to resolve this issue asap as I want to change the port from port 80 to 8530.

    Thank you 

    Regards from RSA

    Wednesday, April 10, 2013 11:04 AM
  • Dude88 that file is most likely in C:\Program Files\Update Services\setup\installselfupdateonport80.vbs.
    Thursday, May 9, 2013 10:18 PM
  • Hi All.

    I required the same solution, I installed another package (VMWare vCenter Server) and needed to get Port 80 back. WSUS was already installed; Windows 2008 R2 Standard SP1, WSUS 3.0 SP2.

    The solution that worked for me was a combination of Bechirs' and ashxs'.

    In my case the WSUS web componts were installed under the Default Web Site, so directly chaning the binding on this was not going to work and would break other IIS based application I had in the default site.

    I applied the suggestion from Bechir first and ran;

    On the WSUS Server, open a command promp, go under "c:\program fils\update services\tools" execute this command wsusutil usecustomwebsite true

    This basically moves all WSUS web components from the Default Web Site to a new one named WSUS Administration which then brought it in line with ashx's posting, although, the bindings were already done.

    So, to summarize;

    1. On the WSUS Server, open a command promp, go under "c:\program fils\update services\tools" execute this command wsusutil usecustomwebsite true

    2. Open Registry Editor with Start -> RUN -> regedit

              Goto HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Update Services\Server\Setup

              Change "Port Number" Value to Required Port No (for e.g. 80)

    3. Goto Command prompt and type following command

    cscript "WSUS Installation Location\Update Services\setup\installselfupdateonport80.vbs

    e.g.

    "cscript "c:\Program Files\Update Services\setup\installselfupdateonport80.vbs"

    C:\Windows\system32>cscript "c:\Program Files\Update Services\setup\installselfupdateonport80.vbs"
    Microsoft (R) Windows Script Host Version 5.8
    Copyright (C) Microsoft Corporation. All rights reserved.

    SetupSelfupdateTree: Finding the index of the Web site on which WUS is installed
    ...
    SetupSelfupdateTree: Leaving GetWUSWebSiteIndex.
    SetupSelfupdateTree: Finding the index of the web site bound to port 80...
    SetupSelfupdateTree: iWebSiteIndex: 2 ServerBindings: :8080:index: 0
    SetupSelfupdateTree: iWebSiteIndex: 179262852 ServerBindings: :80:index: 0
    SetupSelfupdateTree: Found the index of site on Port 80: 179262852
    SetupSelfupdateTree: rootMetabasePath: IIS://LocalHost/W3SVC/179262852/ROOT
    SetupSelfupdateTree: szPort80RootPath=C:\Program Files\Update Services\WebServices\Root\
    SetupSelfupdateTree: iWusWebSiteIndex=179262852 iPort80WebSiteIndex=179262852
    SetupSelfupdateTree: Warning: This is standalone WUS install. No need to do conf
    iguration for SxS install.
    Success: InstallSelfupdateOnPort80 succeeded.

    4. You Have Done It!!!

    Perfect instructions - One thing to note is if you are not going to use port 80 you have to update your WSUS group policy setting for "Specify intranet Microsoft update service location" to point to http://Wsusservername:NewPortNumber



    Rob

    Friday, August 30, 2013 3:52 AM
  • DEAR SIR:

    MY Environment is Windows Server 2012 with WSUS 4.0

    where can i find the cscript installselfupdateonport80.vbs

    i cant find it in C:\Program Files\Update Services\Setup

    pls help me  

    thx!!!

    Friday, October 4, 2013 2:43 AM
  • Use the wsusutil usecustomwebsite  command

    The tool is located in c:\Program Files\Update Services\Tools

    The command to change the WSUS website to use port 80 is: wsusutil usecustomwebsite false

    Thursday, May 22, 2014 9:12 PM
  • I have a Windows 2012 server that has the setting usecustomwebsite set to false
    The WSUS console fails to launch on this server. When I execute usecustomwebsite true the WSUS console will start. When I run usecustomwebsite false again the WSUS console will not start. Does anyone know how to correct this?

    Wednesday, June 25, 2014 11:22 PM
  • I have a Windows 2012 server that has the setting usecustomwebsite set to false
    The WSUS console fails to launch on this server. When I execute usecustomwebsite true the WSUS console will start. When I run usecustomwebsite false again the WSUS console will not start. Does anyone know how to correct this?

    You will get a better answer in the wsus forum for this.

    http://www.enhansoft.com/

    Thursday, June 26, 2014 12:05 AM
  • Im glad that it worked for you!!!

    .::[ashX]::.

    Thursday, September 25, 2014 4:47 AM
  • No need to look for this script for WSUS 2012. I have done it. Worked fine with me.

    Just goto IIS and change the Port.

    IIS Manager -> Sites -> WSUS Administration -> Properties - > Edit Bindings
    Change the port which you want.


    .::[ashX]::.

    Thursday, September 25, 2014 4:51 AM
  • Use:

    "C:\Program Files\Update Services\Tools\WSUSutil" usecustomwebsite false

    to change to Port 80

    Tuesday, December 12, 2017 10:51 AM