Network Error (tcp_error) A communication error occurred: "Operation timed out" - After 6 min in ASP.NET application while DB pulls data RRS feed

  • Question

  • Hello Team, 

    I have some Weird problem with my application. My application works fine since day before yesterday and no problem at all. today when users started testing the application with huge data , users are getting below error continuously . 

    Network Error (tcp_error)  
    Network Error (tcp_error) A communication error occurred: "Operation timed out" after 6 min in asp.net
    The Web Server may be down, too busy, or experiencing other problems preventing it from responding to requests. 
    You may wish to try again at a later time 

    I have tried lot of options like 

    1. reset the IIS. 

    2. Provide permissions to physical directory. 

    3. Httpruntim tag settings in webconfig file . MaxrequestLenght and Querytimeout settings. 

    4. Impersonation enabled ( i do not think its required). 


    Please can you help me on this. After exact 6 minutes we are getting this error while dataadpter filling the dataset in background. if you run this from local host it was working fine. (sometimes it took time to complete but output comes). 

    Please suggest !. Thanks a lot in advance. 



    Friday, October 7, 2016 9:04 PM

All replies

  • For ASP.Net issues try one of the ASP.Net Forums but which Forum I do not know.

    La vida loca

    Saturday, October 8, 2016 12:56 AM
  • For ASP.Net issues try one of the ASP.Net Forums but which Forum I do not know.

    La vida loca

    Maybe IIS Forum will also help the OP a lot :-)

    The OP should first confirm which is the CORE problem:Code, IIS settings or ASP.NET Deploy, and then ask the confirmed question on the confirmed forum.


    ASP.NET Forum
    FreeRice Donate
    Issues to report

    Saturday, October 8, 2016 1:32 AM
  • Hi Malesu,

    I tried searching the solution from last 2 day and i found this :


    netsh int ip reset

    netsh winsock reset


    Computer restart  is must after these steps.

    2) Open the Configuration Panel, Network connections. Select the network connection that's giving you troubles. Right click on it, select properties. Remove QOS service. Check the TCP/IP settings: if they're setup by DHCP, leave things as they are. If not, write down all information in that screen and change it to DHCP. Reboot and you should be on your way.

    Please try hope it works :)

    Sunday, October 9, 2016 4:24 PM
  • Edit the values for the following registry settings under HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters\:

    KeepAliveTime: 30000

    KeepAliveInterval: 1000

    TcpMaxDataRetransmissions: 10

    Monday, December 28, 2020 6:35 AM