locked
Orchestrator 2012 R2 Webconsole and Webservice Error RRS feed

  • Question

  • Hi,

    I'm getting the following error on both the webconsole and web service

    HTTP Error 401.1 - Unauthorized

    You do not have permission to view this directory or page using the credentials that you supplied.

    The Orchestrator webservice works when using http://localhost:81/Orchestrator2012/Orchestrator.svc/ and no credentials are required. The webconsole also fails with localhost.

    I'm running orchestrator in my lab on VM's running Windows Server 2012 R2.

    Any help on this would be appreciated.

    Wednesday, March 9, 2016 12:40 AM

Answers

  • Hi,

    make sure Orchestrator WebServices points to the correct Database (https://technet.microsoft.com/en-us/library/hh473578.aspx):

    1. Log on with administrative credentials to the computer with the Orchestration console installed.

    2. Open a Command Prompt window with administrator credentials.

    3. Run the following command to decrypt the Web.config file:

      C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe -pdf "connectionStrings" "C:\Program Files (x86)\Microsoft System Center 2012\Orchestrator\Web Service\Orchestrator2012"

    4. To start the IIS Manager, click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.

    5. Expand the Sites node, and then click Microsoft System Center 2012 Orchestrator Web Service.

    6. In the Features View (of Appilcation Orchestrator2012 ), double-click Connection Strings.

    7. In the Connections String pane, double-click OrchestratorContext.

    8. In the Custom box, scroll down to the portion of the string that includes the server name (Data Source) and database name (Initial Catalog). Check if these values are correct.

    9. Click OK to close the dialog box.

    10. Close IIS Manager.

    11. Run the following command to encrypt the Web.config file:

      C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe -pef "connectionStrings" "C:\Program Files (x86)\Microsoft System Center 2012\Orchestrator\Web Service\Orchestrator2012"

    Regard,

    Stefan


    Visit go2azure.eu and my blog at www.sc-orchestrator.eu !

    Friday, March 11, 2016 7:37 AM
    Answerer

All replies

  • Hi,

    In IIS Manager check the websites

    • Microsoft System Center 2012 Orchestrator Orchestration Console
    • Microsoft System Center 2012 Orchestrator Web Service

    The correct Application Pool should be “System Center 2012 Orchestrator Web Features” for both. The AppPool should have the Orchestrator service account credentials mapped to it which were configured during installation.

    In the "c:\program files (x86)\Microsoft System Center 2012\Orchestrator\Orchestration Console" folder open the a web.config file. Locate this line:

    • <add key="ScoServiceUri" value="http://Server:81/Orchestrator2012/Orchestrator.svc"/>

    Copy it and add this line directly underneath:

    • <add key="ScoServiceUri" value="http://Server.domain.com:81/Orchestrator2012/Orchestrator.svc"/>

    Save the File.

    This will ensure that you can access the Orchestrator Web Console using either the FQDN or NetBIOS names from a web browser.

    Remember to restart the websites in IIS Manager after making any changes.

    Regards,

    Stefan


    Visit go2azure.eu and my blog at www.sc-orchestrator.eu !

    • Proposed as answer by Natascia Heil Thursday, March 10, 2016 7:53 AM
    Wednesday, March 9, 2016 7:27 AM
    Answerer
  • Hi,

    Have you reviewed the IIS log?


    Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Wednesday, March 9, 2016 9:49 AM
  • Hi,

    Tried all the above settings and still the same error. What I noticed is that, I did a fresh installation of Orchestrator onto a another new VM. The application pool that it uses is the default app pool, ad not the Orchestrator App pool.

    So the issue is still the same. I've looked at the IIS logs and it only gives me the same reason 401.2 and then 401.1

    Friday, March 11, 2016 1:29 AM
  • Hi,

    make sure Orchestrator WebServices points to the correct Database (https://technet.microsoft.com/en-us/library/hh473578.aspx):

    1. Log on with administrative credentials to the computer with the Orchestration console installed.

    2. Open a Command Prompt window with administrator credentials.

    3. Run the following command to decrypt the Web.config file:

      C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe -pdf "connectionStrings" "C:\Program Files (x86)\Microsoft System Center 2012\Orchestrator\Web Service\Orchestrator2012"

    4. To start the IIS Manager, click Start, point to Administrative Tools, and then click Internet Information Services (IIS) Manager.

    5. Expand the Sites node, and then click Microsoft System Center 2012 Orchestrator Web Service.

    6. In the Features View (of Appilcation Orchestrator2012 ), double-click Connection Strings.

    7. In the Connections String pane, double-click OrchestratorContext.

    8. In the Custom box, scroll down to the portion of the string that includes the server name (Data Source) and database name (Initial Catalog). Check if these values are correct.

    9. Click OK to close the dialog box.

    10. Close IIS Manager.

    11. Run the following command to encrypt the Web.config file:

      C:\Windows\Microsoft.NET\Framework\v4.0.30319\aspnet_regiis.exe -pef "connectionStrings" "C:\Program Files (x86)\Microsoft System Center 2012\Orchestrator\Web Service\Orchestrator2012"

    Regard,

    Stefan


    Visit go2azure.eu and my blog at www.sc-orchestrator.eu !

    Friday, March 11, 2016 7:37 AM
    Answerer